ACK increased Cseq on reinvite

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

ACK increased Cseq on reinvite

Schneur Rosenberg
Hi, I have this scenario, I'm sending to a carrier that requires
authentication and I use uac_auth(), when I send a call to the carrier
everything works fine, but when OpenSIPs sends a reinvite the carrier
responds witha 200 OK, OpenSIPs  replies with a ACK but it falsely
increments the CSeq , causing the carrier to ignore it, and then the
carrier will keep on resending 200 OK's and OpenSIPs still returns the
wrong ACK and eventually the carrier hangs up.

I'm running OpenSIPs 2.4.1

thanks
Scot

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: ACK increased Cseq on reinvite

Bogdan-Andrei Iancu-2
Hi Schneur,

Could you please post a link to a pcap showing this exact problem - the
trace should be from the opensips machine, covering the traffic from
caller and callee side too for the whole duration of the call.

Regards,

Bogdan-Andrei Iancu

OpenSIPS Founder and Developer
   http://www.opensips-solutions.com
OpenSIPS Bootcamp 2018
   http://opensips.org/training/OpenSIPS_Bootcamp_2018/

On 11/06/2018 02:41 PM, Schneur Rosenberg wrote:

> Hi, I have this scenario, I'm sending to a carrier that requires
> authentication and I use uac_auth(), when I send a call to the carrier
> everything works fine, but when OpenSIPs sends a reinvite the carrier
> responds witha 200 OK, OpenSIPs  replies with a ACK but it falsely
> increments the CSeq , causing the carrier to ignore it, and then the
> carrier will keep on resending 200 OK's and OpenSIPs still returns the
> wrong ACK and eventually the carrier hangs up.
>
> I'm running OpenSIPs 2.4.1
>
> thanks
> Scot
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: ACK increased Cseq on reinvite

Schneur Rosenberg
For security reasons I will email it directly to you.

thanks
On Tue, Nov 6, 2018 at 11:21 PM Bogdan-Andrei Iancu <[hidden email]> wrote:

>
> Hi Schneur,
>
> Could you please post a link to a pcap showing this exact problem - the
> trace should be from the opensips machine, covering the traffic from
> caller and callee side too for the whole duration of the call.
>
> Regards,
>
> Bogdan-Andrei Iancu
>
> OpenSIPS Founder and Developer
>    http://www.opensips-solutions.com
> OpenSIPS Bootcamp 2018
>    http://opensips.org/training/OpenSIPS_Bootcamp_2018/
>
> On 11/06/2018 02:41 PM, Schneur Rosenberg wrote:
> > Hi, I have this scenario, I'm sending to a carrier that requires
> > authentication and I use uac_auth(), when I send a call to the carrier
> > everything works fine, but when OpenSIPs sends a reinvite the carrier
> > responds witha 200 OK, OpenSIPs  replies with a ACK but it falsely
> > increments the CSeq , causing the carrier to ignore it, and then the
> > carrier will keep on resending 200 OK's and OpenSIPs still returns the
> > wrong ACK and eventually the carrier hangs up.
> >
> > I'm running OpenSIPs 2.4.1
> >
> > thanks
> > Scot
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: ACK increased Cseq on reinvite

Schneur Rosenberg
Bogdan, any update?
On Wed, Nov 7, 2018 at 11:59 AM Schneur Rosenberg
<[hidden email]> wrote:

>
> For security reasons I will email it directly to you.
>
> thanks
> On Tue, Nov 6, 2018 at 11:21 PM Bogdan-Andrei Iancu <[hidden email]> wrote:
> >
> > Hi Schneur,
> >
> > Could you please post a link to a pcap showing this exact problem - the
> > trace should be from the opensips machine, covering the traffic from
> > caller and callee side too for the whole duration of the call.
> >
> > Regards,
> >
> > Bogdan-Andrei Iancu
> >
> > OpenSIPS Founder and Developer
> >    http://www.opensips-solutions.com
> > OpenSIPS Bootcamp 2018
> >    http://opensips.org/training/OpenSIPS_Bootcamp_2018/
> >
> > On 11/06/2018 02:41 PM, Schneur Rosenberg wrote:
> > > Hi, I have this scenario, I'm sending to a carrier that requires
> > > authentication and I use uac_auth(), when I send a call to the carrier
> > > everything works fine, but when OpenSIPs sends a reinvite the carrier
> > > responds witha 200 OK, OpenSIPs  replies with a ACK but it falsely
> > > increments the CSeq , causing the carrier to ignore it, and then the
> > > carrier will keep on resending 200 OK's and OpenSIPs still returns the
> > > wrong ACK and eventually the carrier hangs up.
> > >
> > > I'm running OpenSIPs 2.4.1
> > >
> > > thanks
> > > Scot
> > >
> > > _______________________________________________
> > > Users mailing list
> > > [hidden email]
> > > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
> >

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: ACK increased Cseq on reinvite

Bogdan-Andrei Iancu-2
In reply to this post by Schneur Rosenberg
Thanks Schneur,

Indeed, I see that during the re-INVITe, the cseq of the ACK bumps to
105 instead of 104 (from 103 on caller leg).

Please open a bug report on the github tracker, to have this issue in
our attention.

Regards,

Bogdan-Andrei Iancu

OpenSIPS Founder and Developer
   http://www.opensips-solutions.com
OpenSIPS Bootcamp 2018
   http://opensips.org/training/OpenSIPS_Bootcamp_2018/

On 11/07/2018 12:01 PM, Schneur Rosenberg wrote:

> Attached please find the trace, Im sending you the trace in private
> for security and privacy reasons, thank you
>
>
> On Wed, Nov 7, 2018 at 11:59 AM Schneur Rosenberg
> <[hidden email]> wrote:
>> For security reasons I will email it directly to you.
>>
>> thanks
>> On Tue, Nov 6, 2018 at 11:21 PM Bogdan-Andrei Iancu <[hidden email]> wrote:
>>> Hi Schneur,
>>>
>>> Could you please post a link to a pcap showing this exact problem - the
>>> trace should be from the opensips machine, covering the traffic from
>>> caller and callee side too for the whole duration of the call.
>>>
>>> Regards,
>>>
>>> Bogdan-Andrei Iancu
>>>
>>> OpenSIPS Founder and Developer
>>>     http://www.opensips-solutions.com
>>> OpenSIPS Bootcamp 2018
>>>     http://opensips.org/training/OpenSIPS_Bootcamp_2018/
>>>
>>> On 11/06/2018 02:41 PM, Schneur Rosenberg wrote:
>>>> Hi, I have this scenario, I'm sending to a carrier that requires
>>>> authentication and I use uac_auth(), when I send a call to the carrier
>>>> everything works fine, but when OpenSIPs sends a reinvite the carrier
>>>> responds witha 200 OK, OpenSIPs  replies with a ACK but it falsely
>>>> increments the CSeq , causing the carrier to ignore it, and then the
>>>> carrier will keep on resending 200 OK's and OpenSIPs still returns the
>>>> wrong ACK and eventually the carrier hangs up.
>>>>
>>>> I'm running OpenSIPs 2.4.1
>>>>
>>>> thanks
>>>> Scot
>>>>
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users