Add Menu to OpenSIPS-CP

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Add Menu to OpenSIPS-CP

Spady#7
Hi List,
I was wondering is there is a way, and/or is possible, to add a menu to OpenSIPS-CP under System Tab.
I would like to populate AVP Table by Control Panel. It would be easier then do it by opensipsctl command.

Regards.
Reply | Threaded
Open this post in threaded view
|

Re: Add Menu to OpenSIPS-CP

Alex Ionescu-2
Hi Spady,

Sure, you can do that very easily. Just use the TViewer tool.
Edit ../opensips-cp/config/tools/system/tviewer/local.inc.php. You should have something like this:

$config->custom_table = "usr_preferences";
$config->custom_table_columns = array ("Id" => "id","UUID" => "uuid","Username" => "username","Domain" => "domain","Attribute" => "attribute","Type" => "type","Value" => "value");


Hope this helps you.

Regards,
Alex

On 12/03/2011 01:02 PM, spady wrote:
Hi List,
I was wondering is there is a way, and/or is possible, to add a menu to
OpenSIPS-CP under System Tab.
I would like to populate AVP Table by Control Panel. It would be easier then
do it by opensipsctl command.

Regards.

--
View this message in context: http://opensips-open-sip-server.1449251.n2.nabble.com/Add-Menu-to-OpenSIPS-CP-tp7057646p7057646.html
Sent from the OpenSIPS - Users mailing list archive at Nabble.com.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Add Menu to OpenSIPS-CP

Spady#7
Thanksssssssssss Alex!!! It works perfectly!!!!!
Reply | Threaded
Open this post in threaded view
|

Re: Add Menu to OpenSIPS-CP

Spady#7
Alex, just to be sure, Can I add more than one mysql's table at the time??
I tried to put also "address" tabel into local's file but seems it 's not working.
Can you just confirm that?
Regards