Bug in uri_db module, OpenSIPS v1.4.4

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug in uri_db module, OpenSIPS v1.4.4

Robert Borz
I just tried using the uri_db module together with db_postgres module:

loadmodule "uri_db.so"
modparam("uri_db", "use_uri_table", 1)

Does not use the "uri" table and tries looking up the user still in the subscriber table.

Relevant output with debug level 5:
DBG:db_postgres:db_postgres_submit_query: 0x74c8e8 PQsendQuery(select username from subscriber where username='*********' AND domain='*******.de' AND uri_user='************')

The docs say, that use_uri_table has to be set to another value than 0, which means true. Seems not to work right now...


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Bug in uri_db module, OpenSIPS v1.4.4

Robert Borz
Allright, just my mistake? Just trying to convert my current OpenSER configuration.

Adding the additional parameter
        modparam("uri_db", "db_table", "uri")
fixed this issue.


Sorry...


Robert.

-----Original Message-----
From: Robert Borz [mailto:[hidden email]]
Sent: Thursday, March 05, 2009 6:12 PM
To: '[hidden email]'
Subject: Bug in uri_db module, OpenSIPS v1.4.4

I just tried using the uri_db module together with db_postgres module:

loadmodule "uri_db.so"
modparam("uri_db", "use_uri_table", 1)

Does not use the "uri" table and tries looking up the user still in the subscriber table.

Relevant output with debug level 5:
DBG:db_postgres:db_postgres_submit_query: 0x74c8e8 PQsendQuery(select username from subscriber where username='*********' AND domain='*******.de' AND uri_user='************')

The docs say, that use_uri_table has to be set to another value than 0, which means true. Seems not to work right now...


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Bug in uri_db module, OpenSIPS v1.4.4

Bogdan-Andrei Iancu
Hi Robert,

Looks like a bug to me - could you please upload a new bug report on the
tracker about this problem?

Thanks and regards,
Bogdan

Robert Borz wrote:

> Allright, just my mistake? Just trying to convert my current OpenSER configuration.
>
> Adding the additional parameter
> modparam("uri_db", "db_table", "uri")
> fixed this issue.
>
>
> Sorry...
>
>
> Robert.
>
> -----Original Message-----
> From: Robert Borz [mailto:[hidden email]]
> Sent: Thursday, March 05, 2009 6:12 PM
> To: '[hidden email]'
> Subject: Bug in uri_db module, OpenSIPS v1.4.4
>
> I just tried using the uri_db module together with db_postgres module:
>
> loadmodule "uri_db.so"
> modparam("uri_db", "use_uri_table", 1)
>
> Does not use the "uri" table and tries looking up the user still in the subscriber table.
>
> Relevant output with debug level 5:
> DBG:db_postgres:db_postgres_submit_query: 0x74c8e8 PQsendQuery(select username from subscriber where username='*********' AND domain='*******.de' AND uri_user='************')
>
> The docs say, that use_uri_table has to be set to another value than 0, which means true. Seems not to work right now...
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Bug in uri_db module, OpenSIPS v1.4.4

Robert Borz
Hi Bogdan,

I filed a anonymous bug report on the new tracker.


Regards,
Robert.

-----Original Message-----
From: [hidden email] [mailto:[hidden email]]
Sent: Thursday, March 05, 2009 6:36 PM
To: [hidden email]
Cc: [hidden email]
Subject: Re: [OpenSIPS-Users] Bug in uri_db module, OpenSIPS v1.4.4

Hi Robert,

Looks like a bug to me - could you please upload a new bug report on the
tracker about this problem?

Thanks and regards,
Bogdan

Robert Borz wrote:

> Allright, just my mistake? Just trying to convert my current OpenSER configuration.
>
> Adding the additional parameter
> modparam("uri_db", "db_table", "uri")
> fixed this issue.
>
>
> Sorry...
>
>
> Robert.
>
> -----Original Message-----
> From: Robert Borz [mailto:[hidden email]]
> Sent: Thursday, March 05, 2009 6:12 PM
> To: '[hidden email]'
> Subject: Bug in uri_db module, OpenSIPS v1.4.4
>
> I just tried using the uri_db module together with db_postgres module:
>
> loadmodule "uri_db.so"
> modparam("uri_db", "use_uri_table", 1)
>
> Does not use the "uri" table and tries looking up the user still in the subscriber table.
>
> Relevant output with debug level 5:
> DBG:db_postgres:db_postgres_submit_query: 0x74c8e8 PQsendQuery(select username from subscriber where username='*********' AND domain='*******.de' AND uri_user='************')
>
> The docs say, that use_uri_table has to be set to another value than 0, which means true. Seems not to work right now...
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Bug in uri_db module, OpenSIPS v1.4.4

Sergio Gutierrez

Hi Robert.

Please update again from branch (stable version)

Regards.

Sergio.

On Fri, Mar 6, 2009 at 2:46 AM, Robert Borz <[hidden email]> wrote:
Hi Sergio,

I just checked out the current svn version. But the problem still exists. Here's my module configuration:

loadmodule "uri_db.so"
modparam("uri_db", "db_url", "postgres://opensips:********@*********/opensips_1_4")
modparam("uri_db", "use_uri_table", 1)
modparam("uri_db", "use_domain", 0)

And here's the output generated with debug 5:

DBG:db_postgres:db_postgres_val2str: PQescapeStringConn: in: 9 chars, out: 9 chars
DBG:db_postgres:db_postgres_val2str: PQescapeStringConn: in: 10 chars, out: 10 chars
DBG:db_postgres:db_postgres_val2str: PQescapeStringConn: in: 12 chars, out: 12 chars
DBG:db_postgres:db_postgres_submit_query: 0x74c578 PQsendQuery(select username from subscriber where username='sip/10000' AND domain='**********' AND uri_user='************')
DBG:core:db_new_result: allocate 48 bytes for result set at 0x74da00
DBG:db_postgres:db_postgres_store_result: 0x74c578 PQresultStatus(PGRES_FATAL_ERROR) PQgetResult(0x84ba20)
ERROR:db_postgres:db_postgres_store_result: 0x74c578 - invalid query, execution aborted
ERROR:db_postgres:db_postgres_store_result: 0x74c578: PGRES_FATAL_ERROR
ERROR:db_postgres:db_postgres_store_result: 0x74c578: ERROR:  column "uri_user" does not exist#012LINE 1: ... username='*********' AND domain='**********' AND uri_user='...#012                                                             ^#012
DBG:core:db_free_columns: freeing 0 columns
DBG:core:db_free_rows: freeing 0 rows
DBG:core:db_free_result: freeing result set at 0x74da00
DBG:db_postgres:free_query: PQclear(0x84ba20) result set
ERROR:core:db_do_query: error while storing result
ERROR:uri_db:check_username: Error while querying database


Regards,
Robert.


________________________________________
From: [hidden email] [mailto:[hidden email]]
Sent: Thursday, March 05, 2009 8:52 PM
Subject: Re: [OpenSIPS-Users] Bug in uri_db module, OpenSIPS v1.4.4

Hello Robert.

Please, update  from SVN and try again.

You can download stable version by using:
svn co https://opensips.svn.sourceforge.net/svnroot/opensips/branches/1.4 opensips_1_4

Please confirm us whether it works, to proceed to close your bug report.

Thanks for reporting.

Best regards.

Sergio.


On Thu, Mar 5, 2009 at 12:49 PM, Robert Borz <[hidden email]> wrote:
Hi Bogdan,

I filed a anonymous bug report on the new tracker.


Regards,
Robert.

-----Original Message-----
From: [hidden email] [mailto:[hidden email]]
Sent: Thursday, March 05, 2009 6:36 PM
To: [hidden email]
Cc: [hidden email]
Subject: Re: [OpenSIPS-Users] Bug in uri_db module, OpenSIPS v1.4.4

Hi Robert,

Looks like a bug to me - could you please upload a new bug report on the
tracker about this problem?

Thanks and regards,
Bogdan

Robert Borz wrote:
> Allright, just my mistake? Just trying to convert my current OpenSER configuration.
>
> Adding the additional parameter
>       modparam("uri_db", "db_table", "uri")
> fixed this issue.
>
>
> Sorry...
>
>
> Robert.
>
> -----Original Message-----
> From: Robert Borz [mailto:[hidden email]]
> Sent: Thursday, March 05, 2009 6:12 PM
> To: '[hidden email]'
> Subject: Bug in uri_db module, OpenSIPS v1.4.4
>
> I just tried using the uri_db module together with db_postgres module:
>
> loadmodule "uri_db.so"
> modparam("uri_db", "use_uri_table", 1)
>
> Does not use the "uri" table and tries looking up the user still in the subscriber table.
>
> Relevant output with debug level 5:
> DBG:db_postgres:db_postgres_submit_query: 0x74c8e8 PQsendQuery(select username from subscriber where username='*********' AND domain='*******.de' AND uri_user='************')
>
> The docs say, that use_uri_table has to be set to another value than 0, which means true. Seems not to work right now...
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
Sergio Gutiérrez




--
Sergio Gutiérrez

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Bug in uri_db module, OpenSIPS v1.4.4

Robert Borz
Hi Sergio,

I fetched opensips_1_4 from 1.4 branch from svn and now it does as expected. Great work! Thank you. :-)


Regards,
Robert

________________________________________
From: [hidden email] [mailto:[hidden email]]
Sent: Friday, March 06, 2009 4:13 PM
To: [hidden email]
Cc: [hidden email]
Subject: Re: [OpenSIPS-Users] Bug in uri_db module, OpenSIPS v1.4.4


Hi Robert.

Please update again from branch (stable version)

Regards.

Sergio.
On Fri, Mar 6, 2009 at 2:46 AM, Robert Borz <[hidden email]> wrote:
Hi Sergio,

I just checked out the current svn version. But the problem still exists. Here's my module configuration:

loadmodule "uri_db.so"
modparam("uri_db", "db_url", "postgres://opensips:********@*********/opensips_1_4")
modparam("uri_db", "use_uri_table", 1)
modparam("uri_db", "use_domain", 0)

And here's the output generated with debug 5:

DBG:db_postgres:db_postgres_val2str: PQescapeStringConn: in: 9 chars, out: 9 chars
DBG:db_postgres:db_postgres_val2str: PQescapeStringConn: in: 10 chars, out: 10 chars
DBG:db_postgres:db_postgres_val2str: PQescapeStringConn: in: 12 chars, out: 12 chars
DBG:db_postgres:db_postgres_submit_query: 0x74c578 PQsendQuery(select username from subscriber where username='sip/10000' AND domain='**********' AND uri_user='************')
DBG:core:db_new_result: allocate 48 bytes for result set at 0x74da00
DBG:db_postgres:db_postgres_store_result: 0x74c578 PQresultStatus(PGRES_FATAL_ERROR) PQgetResult(0x84ba20)
ERROR:db_postgres:db_postgres_store_result: 0x74c578 - invalid query, execution aborted
ERROR:db_postgres:db_postgres_store_result: 0x74c578: PGRES_FATAL_ERROR
ERROR:db_postgres:db_postgres_store_result: 0x74c578: ERROR:  column "uri_user" does not exist#012LINE 1: ... username='*********' AND domain='**********' AND uri_user='...#012                                                             ^#012
DBG:core:db_free_columns: freeing 0 columns
DBG:core:db_free_rows: freeing 0 rows
DBG:core:db_free_result: freeing result set at 0x74da00
DBG:db_postgres:free_query: PQclear(0x84ba20) result set
ERROR:core:db_do_query: error while storing result
ERROR:uri_db:check_username: Error while querying database


Regards,
Robert.


________________________________________
From: [hidden email] [mailto:[hidden email]]
Sent: Thursday, March 05, 2009 8:52 PM
To: [hidden email]
Subject: Re: [OpenSIPS-Users] Bug in uri_db module, OpenSIPS v1.4.4

Hello Robert.

Please, update  from SVN and try again.

You can download stable version by using:
svn co https://opensips.svn.sourceforge.net/svnroot/opensips/branches/1.4 opensips_1_4

Please confirm us whether it works, to proceed to close your bug report.

Thanks for reporting.

Best regards.

Sergio.


On Thu, Mar 5, 2009 at 12:49 PM, Robert Borz <[hidden email]> wrote:
Hi Bogdan,

I filed a anonymous bug report on the new tracker.


Regards,
Robert.

-----Original Message-----
From: [hidden email] [mailto:[hidden email]]
Sent: Thursday, March 05, 2009 6:36 PM
To: [hidden email]
Cc: [hidden email]
Subject: Re: [OpenSIPS-Users] Bug in uri_db module, OpenSIPS v1.4.4

Hi Robert,

Looks like a bug to me - could you please upload a new bug report on the
tracker about this problem?

Thanks and regards,
Bogdan

Robert Borz wrote:

> Allright, just my mistake? Just trying to convert my current OpenSER configuration.
>
> Adding the additional parameter
>       modparam("uri_db", "db_table", "uri")
> fixed this issue.
>
>
> Sorry...
>
>
> Robert.
>
> -----Original Message-----
> From: Robert Borz [mailto:[hidden email]]
> Sent: Thursday, March 05, 2009 6:12 PM
> To: '[hidden email]'
> Subject: Bug in uri_db module, OpenSIPS v1.4.4
>
> I just tried using the uri_db module together with db_postgres module:
>
> loadmodule "uri_db.so"
> modparam("uri_db", "use_uri_table", 1)
>
> Does not use the "uri" table and tries looking up the user still in the subscriber table.
>
> Relevant output with debug level 5:
> DBG:db_postgres:db_postgres_submit_query: 0x74c8e8 PQsendQuery(select username from subscriber where username='*********' AND domain='*******.de' AND uri_user='************')
>
> The docs say, that use_uri_table has to be set to another value than 0, which means true. Seems not to work right now...
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
Sergio Gutiérrez



--
Sergio Gutiérrez


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users