CDRTool - Rating engine does not rate

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

CDRTool - Rating engine does not rate

Alberto Listas
Hi,

I have installed OpenSips 1.5.1, FreeRadius 2.1.6, CDRTool 6.8.0. The calls
work but they all appear as
free in CDRTool. I am using the standard customer and rate tables that come
with the
software. When I telnet to the rating engine and use the example in the
documentation
I get the result below:

ShowPrice From=sip:[hidden email] To=sip:[hidden email]
Gateway=10.0.0.1 Duration=59
0
Duration: 59 s
         App: audio
         Destination: 31650
         Customer: domain=example.com
(And nothing else...)

I don't get a price and the /var/log/syslog displays this error:

Jul 10 18:28:49 os2 cdrtool[11392]: Error: Cannot find rates for callid=,
billing party=[hidden email], customer domain=example.com,
gateway=10.0.0.1, destination=31650, profile=grn_premium, app=audio

I don't see the error. There is an entry in customers for the domain
example.com, there
is a rate for destination 31650. But the rating engine does find any.

Anybody has a suggestion???

Thanks,

Alberto


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: CDRTool - Rating engine does not rate

ASHWINI NAIDU
Have you populated all the relavent data needed for CDRTool rating Destinations table,customers, prfiles and rates.

if yes. Delete the entries in Your memcache table and restart ur rating engine and try to get search again. I guess this should work.


On Sat, Jul 11, 2009 at 3:21 AM, Alberto Listas <[hidden email]> wrote:
Hi,

I have installed OpenSips 1.5.1, FreeRadius 2.1.6, CDRTool 6.8.0. The calls
work but they all appear as
free in CDRTool. I am using the standard customer and rate tables that come
with the
software. When I telnet to the rating engine and use the example in the
documentation
I get the result below:

ShowPrice From=[hidden email] To=[hidden email]
Gateway=10.0.0.1 Duration=59
0
Duration: 59 s
        App: audio
        Destination: 31650
        Customer: domain=example.com
(And nothing else...)

I don't get a price and the /var/log/syslog displays this error:

Jul 10 18:28:49 os2 cdrtool[11392]: Error: Cannot find rates for callid=,
billing party=[hidden email], customer domain=example.com,
gateway=10.0.0.1, destination=31650, profile=grn_premium, app=audio

I don't see the error. There is an entry in customers for the domain
example.com, there
is a rate for destination 31650. But the rating engine does find any.

Anybody has a suggestion???

Thanks,

Alberto


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
Thanking You,
Ashwini BR Naidu

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: CDRTool - Rating engine does not rate

Alberto Listas
Hello Ashwini,
I populated the tables with the data that came with the product. It uses the same name for the Profile
and the Rate. It does not have any data for profiles, but customers, Rates and Destinations are OK.
With the same name for the profile and the rate I failed to create the Profile entry linking the two. Now
after creating the profile and reloading the software it works properly.
 
Two Question:
- Is there a way for the system to recalculated all the calls in the database that now look like they are free?
- How do I delete the entries in memcache? I had to reboot,cause I didn't find how to do this. Could you point
me to the proper documentation?
 
Thanks for your help,
 
Alberto
 
---- Original Message -----
Sent: Saturday, July 11, 2009 2:27 AM
Subject: Re: [OpenSIPS-Users] CDRTool - Rating engine does not rate

Have you populated all the relavent data needed for CDRTool rating Destinations table,customers, prfiles and rates.

if yes. Delete the entries in Your memcache table and restart ur rating engine and try to get search again. I guess this should work.


On Sat, Jul 11, 2009 at 3:21 AM, Alberto Listas <[hidden email]> wrote:
Hi,

I have installed OpenSips 1.5.1, FreeRadius 2.1.6, CDRTool 6.8.0. The calls
work but they all appear as
free in CDRTool. I am using the standard customer and rate tables that come
with the
software. When I telnet to the rating engine and use the example in the
documentation
I get the result below:

ShowPrice From=[hidden email] To=[hidden email] Gateway=10.0.0.1 Duration=59
0
Duration: 59 s
        App: audio
        Destination: 31650
        Customer: domain=example.com
(And nothing else...)

I don't get a price and the /var/log/syslog displays this error:

Jul 10 18:28:49 os2 cdrtool[11392]: Error: Cannot find rates for callid=,
billing party=[hidden email], customer domain=example.com,
gateway=10.0.0.1, destination=31650, profile=grn_premium, app=audio

I don't see the error. There is an entry in customers for the domain
example.com, there
is a rate for destination 31650. But the rating engine does find any.

Anybody has a suggestion???

Thanks,

Alberto


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
Thanking You,
Ashwini BR Naidu

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: CDRTool - Rating engine does not rate

bay2x1
In reply to this post by ASHWINI NAIDU
I think the problem is in your profiles table, check if you have a profile entry/record for grn_premium .  If you encounter an error while importing the sample data for CDRTool (importRatingTables.php) we might have the same problem.  I resolve this issue by inserting a record for grn_premium using the CDRTool web application (profiles section).


ASHWINI NAIDU wrote
Have you populated all the relavent data needed for CDRTool rating
Destinations table,customers, prfiles and rates.

if yes. Delete the entries in Your memcache table and restart ur rating
engine and try to get search again. I guess this should work.


On Sat, Jul 11, 2009 at 3:21 AM, Alberto Listas <listas@b2br.net> wrote:

> Hi,
>
> I have installed OpenSips 1.5.1, FreeRadius 2.1.6, CDRTool 6.8.0. The calls
> work but they all appear as
> free in CDRTool. I am using the standard customer and rate tables that come
> with the
> software. When I telnet to the rating engine and use the example in the
> documentation
> I get the result below:
>
> ShowPrice From=sip:123@example.com <sip%3A123@example.com> To=
> sip:0031650222333@example.com <sip%3A0031650222333@example.com>
> Gateway=10.0.0.1 Duration=59
> 0
> Duration: 59 s
>         App: audio
>         Destination: 31650
>         Customer: domain=example.com
> (And nothing else...)
>
> I don't get a price and the /var/log/syslog displays this error:
>
> Jul 10 18:28:49 os2 cdrtool[11392]: Error: Cannot find rates for callid=,
> billing party=123@example.com, customer domain=example.com,
> gateway=10.0.0.1, destination=31650, profile=grn_premium, app=audio
>
> I don't see the error. There is an entry in customers for the domain
> example.com, there
> is a rate for destination 31650. But the rating engine does find any.
>
> Anybody has a suggestion???
>
> Thanks,
>
> Alberto
>
>
> _______________________________________________
> Users mailing list
> Users@lists.opensips.org
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>



--
Thanking You,
Ashwini BR Naidu

_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: CDRTool - Rating engine does not rate

Alberto Listas
I did not see an error in the import. But I also solved the problem
adding a profile for grn_premium.
Thanks,
Alberto
----- Original Message -----
From: "bay2x1" <[hidden email]>
To: <[hidden email]>
Sent: Monday, July 13, 2009 2:05 AM
Subject: Re: [OpenSIPS-Users] CDRTool - Rating engine does not rate


>
> I think the problem is in your profiles table, check if you have a profile
> entry/record for grn_premium .  If you encounter an error while importing
> the sample data for CDRTool (importRatingTables.php) we might have the
> same
> problem.  I resolve this issue by inserting a record for grn_premium using
> the CDRTool web application (profiles section).
>
>
>
> ASHWINI NAIDU wrote:
>>
>> Have you populated all the relavent data needed for CDRTool rating
>> Destinations table,customers, prfiles and rates.
>>
>> if yes. Delete the entries in Your memcache table and restart ur rating
>> engine and try to get search again. I guess this should work.
>>
>>
>> On Sat, Jul 11, 2009 at 3:21 AM, Alberto Listas <[hidden email]> wrote:
>>
>>> Hi,
>>>
>>> I have installed OpenSips 1.5.1, FreeRadius 2.1.6, CDRTool 6.8.0. The
>>> calls
>>> work but they all appear as
>>> free in CDRTool. I am using the standard customer and rate tables that
>>> come
>>> with the
>>> software. When I telnet to the rating engine and use the example in the
>>> documentation
>>> I get the result below:
>>>
>>> ShowPrice From=sip:[hidden email] <sip%[hidden email]> To=
>>> sip:[hidden email] <sip%[hidden email]>
>>> Gateway=10.0.0.1 Duration=59
>>> 0
>>> Duration: 59 s
>>>         App: audio
>>>         Destination: 31650
>>>         Customer: domain=example.com
>>> (And nothing else...)
>>>
>>> I don't get a price and the /var/log/syslog displays this error:
>>>
>>> Jul 10 18:28:49 os2 cdrtool[11392]: Error: Cannot find rates for
>>> callid=,
>>> billing party=[hidden email], customer domain=example.com,
>>> gateway=10.0.0.1, destination=31650, profile=grn_premium, app=audio
>>>
>>> I don't see the error. There is an entry in customers for the domain
>>> example.com, there
>>> is a rate for destination 31650. But the rating engine does find any.
>>>
>>> Anybody has a suggestion???
>>>
>>> Thanks,
>>>
>>> Alberto
>>>
>>>
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>
>>
>>
>> --
>> Thanking You,
>> Ashwini BR Naidu
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>
>
> -----
> http://opensips.blogspot.com http://opensips.blogspot.com
> --
> View this message in context:
> http://n2.nabble.com/CDRTool---Rating-engine-does-not-rate-tp3241434p3248819.html
> Sent from the OpenSIPS - Users mailing list archive at Nabble.com.
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


--------------------------------------------------------------------------------



No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.375 / Virus Database: 270.13.6/2221 - Release Date: 07/06/09
17:54:00


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users