Confused -> ERROR:auth:consume_credentials: no authorized credentials found (error in scripts)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Confused -> ERROR:auth:consume_credentials: no authorized credentials found (error in scripts)

Alan Frisch
>Try to send a BYE inmediatelly after answering the call. Does the error also occur?

Indeed, I tried having the calling end hang up almost immediately
after it connected to the gateway as well as 1 minute connection...
both yield the same result.

I can suppress the message by editing the relevant section of
challenge.c to include the METHOD_BYE.

...
                        if (_m->REQ_METHOD!=METHOD_ACK
                                      && _m->REQ_METHOD!=METHOD_CANCEL
                                      && _m->REQ_METHOD!=METHOD_BYE) {

                                LM_ERR("no authorized credentials
found (error in scripts)\n");
...

This suppresses the message, but I think it may just be a way of
hiding another issue.

Perhaps Bogdan can enlighten us with his wisdom? :)

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Confused -> ERROR:auth:consume_credentials: noauthorized credentials found (error in scripts)

Robert Borz
Hi Alan,

this issue sounds a bit like the one I had some time ago... I also started with a sample configuration from the sipwise wizard.

See http://lists.opensips.org/pipermail/users/2009-January/002639.html
and http://lists.opensips.org/pipermail/users/2009-January/002630.html

I ended up with the solution Bogdan presented to me:

> if you do auth -> use consume_credentials
>   -> if no auth, use remove_hf()

This means, after I do auth (after calling proxy_authorize() on invite or www_authorize() on register) I call consume_credentials(), otherwise in the 'base-outbound' route I just inserted

if (is_present_hf("Proxy-Authorization")) {
        remove_hf("Proxy-Authorization");
}

to get rid of the credentials (Proxy-Authorization header) in ACKs and BYEs for upstream. This works very well for me.

And last but not least: no annoying "ERROR:auth:consume_credentials: noauthorized credentials found (error in scripts)" anymore. :-)


Regards,
Robert

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Alan Frisch
Sent: Thursday, March 26, 2009 10:55 PM
To: [hidden email]
Subject: [OpenSIPS-Users] Confused -> ERROR:auth:consume_credentials: noauthorized credentials found (error in scripts)

>Try to send a BYE inmediatelly after answering the call. Does the error also occur?

Indeed, I tried having the calling end hang up almost immediately
after it connected to the gateway as well as 1 minute connection...
both yield the same result.

I can suppress the message by editing the relevant section of
challenge.c to include the METHOD_BYE.

...
                        if (_m->REQ_METHOD!=METHOD_ACK
                                      && _m->REQ_METHOD!=METHOD_CANCEL
                                      && _m->REQ_METHOD!=METHOD_BYE) {

                                LM_ERR("no authorized credentials
found (error in scripts)\n");
...

This suppresses the message, but I think it may just be a way of
hiding another issue.

Perhaps Bogdan can enlighten us with his wisdom? :)

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Confused -> ERROR:auth:consume_credentials: noauthorized credentials found (error in scripts)

Alan Frisch
Robert,

That worked like a charm.  Thanks!


On Fri, Mar 27, 2009 at 2:02 AM, Robert Borz <[hidden email]> wrote:
Hi Alan,

this issue sounds a bit like the one I had some time ago... I also started with a sample configuration from the sipwise wizard.

See http://lists.opensips.org/pipermail/users/2009-January/002639.html
and http://lists.opensips.org/pipermail/users/2009-January/002630.html

I ended up with the solution Bogdan presented to me:

> if you do auth -> use consume_credentials
>   -> if no auth, use remove_hf()

This means, after I do auth (after calling proxy_authorize() on invite or www_authorize() on register) I call consume_credentials(), otherwise in the 'base-outbound' route I just inserted

if (is_present_hf("Proxy-Authorization")) {
       remove_hf("Proxy-Authorization");
}

to get rid of the credentials (Proxy-Authorization header) in ACKs and BYEs for upstream. This works very well for me.

And last but not least: no annoying "ERROR:auth:consume_credentials: noauthorized credentials found (error in scripts)" anymore. :-)


Regards,
Robert


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users