DB version error in upgrading to 1.5

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

DB version error in upgrading to 1.5

Carlo Dimaggio
Hi all,

I have upgraded my server to opensips 1.5 (with the migration of db)  
but when I restart I have this problem:

Mar 24 15:01:29 sip /sbin/opensips[4122]:  
ERROR:core:db_check_table_version: invalid version 4 for table trusted  
found, expected 5
Mar 24 15:01:29 sip /sbin/opensips[4122]:  
ERROR:permissions:init_trusted: error during table version check.
Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:permissions:mod_init:  
failed to initialize the allow_trusted function
Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:core:init_mod: failed  
to initialize module permissions
Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:core:main: error while  
initializing modules

I have tried to delete the old db (migrated from 1.4) and to create a  
new db (with opensipsdbctl create) but I have still the same problem.

What is the error?


Thank you,
Carlo Dimaggio

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

R: DB version error in upgrading to 1.5

Mauro Davì
Hi Carlo,

you need to modify also the table_version value in the version table.

Regards,

        MD

Ciao Carlo,

c'è una tabella in opensips chiamata "version" nel tuo caso devi impostare il valore del campo table_version a 5 in corrispondenza della riga table_name="trusted".

Buon Lavoro
        MD
 
-----Messaggio originale-----
Da: [hidden email] [mailto:[hidden email]] Per conto di Carlo Dimaggio
Inviato: martedì 24 marzo 2009 15:08
A: [hidden email]
Oggetto: [OpenSIPS-Users] DB version error in upgrading to 1.5

Hi all,

I have upgraded my server to opensips 1.5 (with the migration of db)  
but when I restart I have this problem:

Mar 24 15:01:29 sip /sbin/opensips[4122]:  
ERROR:core:db_check_table_version: invalid version 4 for table trusted  
found, expected 5
Mar 24 15:01:29 sip /sbin/opensips[4122]:  
ERROR:permissions:init_trusted: error during table version check.
Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:permissions:mod_init:  
failed to initialize the allow_trusted function
Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:core:init_mod: failed  
to initialize module permissions
Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:core:main: error while  
initializing modules

I have tried to delete the old db (migrated from 1.4) and to create a  
new db (with opensipsdbctl create) but I have still the same problem.

What is the error?


Thank you,
Carlo Dimaggio

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: DB version error in upgrading to 1.5

Bogdan-Andrei Iancu
In reply to this post by Carlo Dimaggio
Hi Carlo,

to update your database to 1.5 (from 1.4 version) you need to do
"opensipdbctl migrate" - this should solve your problem.

Regards,
Bogdan

Carlo Dimaggio wrote:

> Hi all,
>
> I have upgraded my server to opensips 1.5 (with the migration of db)  
> but when I restart I have this problem:
>
> Mar 24 15:01:29 sip /sbin/opensips[4122]:  
> ERROR:core:db_check_table_version: invalid version 4 for table trusted  
> found, expected 5
> Mar 24 15:01:29 sip /sbin/opensips[4122]:  
> ERROR:permissions:init_trusted: error during table version check.
> Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:permissions:mod_init:  
> failed to initialize the allow_trusted function
> Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:core:init_mod: failed  
> to initialize module permissions
> Mar 24 15:01:29 sip /sbin/opensips[4122]: ERROR:core:main: error while  
> initializing modules
>
> I have tried to delete the old db (migrated from 1.4) and to create a  
> new db (with opensipsdbctl create) but I have still the same problem.
>
> What is the error?
>
>
> Thank you,
> Carlo Dimaggio
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: DB version error in upgrading to 1.5

Carlo Dimaggio

Il giorno 24/mar/09, alle ore 15:22, Bogdan-Andrei Iancu ha scritto:

> Hi Carlo,
>
> to update your database to 1.5 (from 1.4 version) you need to do  
> "opensipdbctl migrate" - this should solve your problem.
>
> Regards,
> Bogdan

Hi Bogdan,

I've used the command 'opensipsdbctl migrate' but I have the same  
problem (the version of trusted table is 4 instead of 5). Do I change  
manually the number to 5 as Mauro suggested?

Thanks,
Carlo


The output of opensipsdbctl migrate is:

# opensipsdbctl migrate opensips opensips_15
MySQL password for root:
INFO: Creating new Database opensips_new....
INFO: test server charset
INFO: creating database opensips_new ...
INFO: Core OpenSIPS tables succesfully created.
Install presence related tables? (y/n): y
INFO: creating presence tables into opensips_new ...
INFO: Presence tables succesfully created.
Install tables for imc cpl siptrace domainpolicy carrierroute  
userblacklist? (y/n): y
INFO: creating extra tables into opensips_new ...
INFO: Extra tables succesfully created.
INFO: Migrating data from opensips to opensips_new....
INFO:  -- Migrating opensips.acc to opensips_new.acc.....OK
INFO:  -- Migrating opensips.missed_calls to  
opensips_new.missed_calls.....OK
INFO:  -- Migrating opensips.aliases to opensips_new.aliases.....OK
INFO:  -- Migrating opensips.dbaliases to opensips_new.dbaliases.....OK
INFO:  -- Migrating opensips.grp to opensips_new.grp.....OK
INFO:  -- Migrating opensips.re_grp to opensips_new.re_grp.....OK
INFO:  -- Migrating opensips.silo to opensips_new.silo.....OK
INFO:  -- Migrating opensips.domain to opensips_new.domain.....OK
INFO:  -- Migrating opensips.uri to opensips_new.uri.....OK
INFO:  -- Migrating opensips.usr_preferences to  
opensips_new.usr_preferences.....OK
INFO:  -- Migrating opensips.trusted to opensips_new.trusted.....OK
INFO:  -- Migrating opensips.address to opensips_new.address.....OK
INFO:  -- Migrating opensips.speed_dial to  
opensips_new.speed_dial.....OK
ERROR: failed to migrate opensips.gw to opensips_new.gw!!!
Skip it and continue (y/n)? y
  -- Migrating opensips.gw_grp to opensips_new.gw_grp.....SKIPPED (no  
source)
INFO:  -- Migrating opensips.lcr to opensips_new.lcr.....OK
INFO:  -- Migrating opensips.pdt to opensips_new.pdt.....OK
INFO:  -- Migrating opensips.subscriber to  
opensips_new.subscriber.....OK
INFO:  -- Migrating opensips.cpl to opensips_new.cpl.....OK
  -- Migrating opensips.siptrace to opensips_new.siptrace.....SKIPPED  
(no source)
INFO:  -- Migrating opensips.imc_rooms to opensips_new.imc_rooms.....OK
  -- Migrating opensips.im_members to  
opensips_new.imc_members.....SKIPPED (no source)
INFO: Migration successfully completed.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: DB version error in upgrading to 1.5

Bogdan-Andrei Iancu
I just checked and creating a new DB will set a 5 version for the
trusted table. Are you sure you are not mixing somehow the old and new DB ?

Regards,
Bogdan

Carlo Dimaggio wrote:

> Il giorno 24/mar/09, alle ore 15:22, Bogdan-Andrei Iancu ha scritto:
>
>  
>> Hi Carlo,
>>
>> to update your database to 1.5 (from 1.4 version) you need to do  
>> "opensipdbctl migrate" - this should solve your problem.
>>
>> Regards,
>> Bogdan
>>    
>
> Hi Bogdan,
>
> I've used the command 'opensipsdbctl migrate' but I have the same  
> problem (the version of trusted table is 4 instead of 5). Do I change  
> manually the number to 5 as Mauro suggested?
>
> Thanks,
> Carlo
>
>
> The output of opensipsdbctl migrate is:
>
> # opensipsdbctl migrate opensips opensips_15
> MySQL password for root:
> INFO: Creating new Database opensips_new....
> INFO: test server charset
> INFO: creating database opensips_new ...
> INFO: Core OpenSIPS tables succesfully created.
> Install presence related tables? (y/n): y
> INFO: creating presence tables into opensips_new ...
> INFO: Presence tables succesfully created.
> Install tables for imc cpl siptrace domainpolicy carrierroute  
> userblacklist? (y/n): y
> INFO: creating extra tables into opensips_new ...
> INFO: Extra tables succesfully created.
> INFO: Migrating data from opensips to opensips_new....
> INFO:  -- Migrating opensips.acc to opensips_new.acc.....OK
> INFO:  -- Migrating opensips.missed_calls to  
> opensips_new.missed_calls.....OK
> INFO:  -- Migrating opensips.aliases to opensips_new.aliases.....OK
> INFO:  -- Migrating opensips.dbaliases to opensips_new.dbaliases.....OK
> INFO:  -- Migrating opensips.grp to opensips_new.grp.....OK
> INFO:  -- Migrating opensips.re_grp to opensips_new.re_grp.....OK
> INFO:  -- Migrating opensips.silo to opensips_new.silo.....OK
> INFO:  -- Migrating opensips.domain to opensips_new.domain.....OK
> INFO:  -- Migrating opensips.uri to opensips_new.uri.....OK
> INFO:  -- Migrating opensips.usr_preferences to  
> opensips_new.usr_preferences.....OK
> INFO:  -- Migrating opensips.trusted to opensips_new.trusted.....OK
> INFO:  -- Migrating opensips.address to opensips_new.address.....OK
> INFO:  -- Migrating opensips.speed_dial to  
> opensips_new.speed_dial.....OK
> ERROR: failed to migrate opensips.gw to opensips_new.gw!!!
> Skip it and continue (y/n)? y
>   -- Migrating opensips.gw_grp to opensips_new.gw_grp.....SKIPPED (no  
> source)
> INFO:  -- Migrating opensips.lcr to opensips_new.lcr.....OK
> INFO:  -- Migrating opensips.pdt to opensips_new.pdt.....OK
> INFO:  -- Migrating opensips.subscriber to  
> opensips_new.subscriber.....OK
> INFO:  -- Migrating opensips.cpl to opensips_new.cpl.....OK
>   -- Migrating opensips.siptrace to opensips_new.siptrace.....SKIPPED  
> (no source)
> INFO:  -- Migrating opensips.imc_rooms to opensips_new.imc_rooms.....OK
>   -- Migrating opensips.im_members to  
> opensips_new.imc_members.....SKIPPED (no source)
> INFO: Migration successfully completed.
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: DB version error in upgrading to 1.5

Carlo Dimaggio

Il giorno 24/mar/09, alle ore 16:15, Bogdan-Andrei Iancu ha scritto:

> I just checked and creating a new DB will set a 5 version for the  
> trusted table. Are you sure you are not mixing somehow the old and  
> new DB ?

I don't think, but I'll investigate better...
For now, I have set manually the version table.

Thank you,
Carlo

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: DB version error in upgrading to 1.5

Bogdan-Andrei Iancu
And only the trusted table was affected ? the rest of the tables are ok?

Thanks and regards,
Bogdan

Carlo Dimaggio wrote:

> Il giorno 24/mar/09, alle ore 16:15, Bogdan-Andrei Iancu ha scritto:
>
>  
>> I just checked and creating a new DB will set a 5 version for the  
>> trusted table. Are you sure you are not mixing somehow the old and  
>> new DB ?
>>    
>
> I don't think, but I'll investigate better...
> For now, I have set manually the version table.
>
> Thank you,
> Carlo
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: DB version error in upgrading to 1.5

Carlo Dimaggio

Il giorno 24/mar/09, alle ore 17:05, Bogdan-Andrei Iancu ha scritto:

> And only the trusted table was affected ? the rest of the tables are  
> ok?

Hi Bogdan,

At the end, I have modified trusted, gw, address, lcr, subscriber,  
dialog, grp, location, userblacklist tables.
It seems a little bit strange, but for now all is fine.

Best regards,
Carlo


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users