Quantcast

Debian TLS-enabled packages

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Debian TLS-enabled packages

Jock McKechnie
Hey all;

The official OpenSIPS Debian repo appears to only includes no-TLS
versions of OpenSIPS, and I did see a message back in 2013 where
someone asked about it and someone else very kindly built them a quick
.deb for it, which was nifty but not "official", as it were.

Is OpenSIPS likely to be providing the TLS version of OpenSIPS on
their repos at any time, or is there an official reason why they
don't?

Just curious, I've been enjoying being pampered by them for so long
now I have to move to TLS across the board it'd be nice to continue to
use them and not have to move to compiling internally.

As always, many thanks;

 - Jock

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Debian TLS-enabled packages

Razvan Crainea-3
Hi, Jock!

OpenSIPS 1.11 has the TLS code in it's core sources. That's why, due to
licence incompatibilities, we decided to compile the opensips binary
without the TLS code, hence no TLS capabilities. If you need TLS for
opensips 1.11, you'll have to generate your own packages.
Starting with OpenSIPS 2.1, the TLS engine has been taken out of the
core, as a separate module named proto_tls. This allowed us to make
separate packages (with proper licensing) for the TLS engine. You can
find this module in the opensips-tls-module package in the debian
repository[1]. All 2.x versions contain it.

[1] http://apt.opensips.org

Best regards,

Răzvan Crainea
OpenSIPS Solutions
www.opensips-solutions.com

On 04/14/2017 11:21 PM, Jock McKechnie wrote:

> Hey all;
>
> The official OpenSIPS Debian repo appears to only includes no-TLS
> versions of OpenSIPS, and I did see a message back in 2013 where
> someone asked about it and someone else very kindly built them a quick
> .deb for it, which was nifty but not "official", as it were.
>
> Is OpenSIPS likely to be providing the TLS version of OpenSIPS on
> their repos at any time, or is there an official reason why they
> don't?
>
> Just curious, I've been enjoying being pampered by them for so long
> now I have to move to TLS across the board it'd be nice to continue to
> use them and not have to move to compiling internally.
>
> As always, many thanks;
>
>   - Jock
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Loading...