ERROR:db_mysql:db_mysql_new_connection: driver error(2013)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ERROR:db_mysql:db_mysql_new_connection: driver error(2013)

Manivasagam Sivaraman
I installed notls-1.5.1 with db_mysql option and when I start the server I get "ERROR:db_mysql:db_mysql_new_connection: driver error(2013)" error.
 
I'm able to login to mysql server from commandline with out any problem. I even tried using the same user name specified in the opensipsrcctl file and I'm able to login to mysql from command line.
 
Here is the full opensips start up error:
Restarting opensips: opensipsListening on
             udp: 172.16.0.138 [172.16.0.138]:5060
Aliases:
             udp: sips.smithmicro.com.smsi.com:5060
Jun  5 15:42:44 [2550] INFO:core:init_tcp: using epoll_lt as the TCP io watch me                                             thod (auto detected)
Jun  5 15:42:44 [2552] NOTICE:core:main: version: opensips 1.5.1-notls (i386/lin                                             ux)
Jun  5 15:42:44 [2552] INFO:core:main: using 64 Mb shared memory
Jun  5 15:42:44 [2552] INFO:core:main: using 1 Mb private memory per process
.
sips:~# Jun  5 15:42:45 [2552] NOTICE:signaling:mod_init: initializing module ..                                             .
Jun  5 15:42:45 [2552] INFO:sl:mod_init: Initializing StateLess engine
Jun  5 15:42:45 [2552] INFO:tm:mod_init: TM - initializing...
Jun  5 15:42:46 [2552] INFO:maxfwd:mod_init: initializing...
Jun  5 15:42:46 [2552] INFO:usrloc:ul_init_locks: locks array size 512
Jun  5 15:42:46 [2552] INFO:registrar:mod_init: initializing...
Jun  5 15:42:46 [2552] INFO:textops:mod_init: initializing...
Jun  5 15:42:46 [2552] INFO:xlog:mod_init: initializing...
Jun  5 15:42:46 [2552] INFO:acc:mod_init: initializing...
Jun  5 15:42:46 [2552] INFO:auth:mod_init: initializing...
Jun  5 15:42:46 [2552] INFO:auth_db:mod_init: initializing...
Jun  5 15:42:46 [2552] NOTICE:presence:mod_init: initializing module ...
Jun  5 15:42:49 [2552] ERROR:db_mysql:db_mysql_new_connection: driver error(2013                                             ): Lost connection to MySQL server at 'reading initial communication packet', sy                                             stem error: 111
Jun  5 15:42:49 [2552] ERROR:core:db_do_init: could not add connection to the po                                             ol
Jun  5 15:42:49 [2552] ERROR:usrloc:register_udomain: failed to open database co                                             nnection
Jun  5 15:42:49 [2552] ERROR:registrar:domain_fixup: failed to register domain
Jun  5 15:42:49 [2552] ERROR:core:fix_actions: fixing failed (code=-1) at cfg li                                             ne 345
Jun  5 15:42:49 [2552] CRITICAL:core:fix_expr: fix_actions error
Jun  5 15:42:49 [2552] ERROR:core:main: failed to fix configuration with err cod                                             e -1
Jun  5 15:42:49 [2552] NOTICE:presence:destroy: destroy module ...
 
Please help.
 

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: ERROR:db_mysql:db_mysql_new_connection: driver error(2013)

Bogdan-Andrei Iancu
Hi,

This kind of error typically mean that opensips was not able to get to a
mysql server. Are you sure you correctly configured the DB_URL in the
USRLOC module ? (pointing to the right server) ?

Regards,
Bogdan

Manivasagam Sivaraman wrote:

> I installed notls-1.5.1 with db_mysql option and when I start the
> server I get "ERROR:db_mysql:db_mysql_new_connection: driver
> error(2013)" error.
>  
> I'm able to login to mysql server from commandline with out any
> problem. I even tried using the same user name specified in the
> opensipsrcctl file and I'm able to login to mysql from command line.
>  
> Here is the full opensips start up error:
> Restarting opensips: opensipsListening on
>              udp: 172.16.0.138 [172.16.0.138]:5060
> Aliases:
>              udp: sips.smithmicro.com.smsi.com:5060
> <http://sips.smithmicro.com.smsi.com:5060>
> Jun  5 15:42:44 [2550] INFO:core:init_tcp: using epoll_lt as the TCP
> io watch me                                             thod (auto
> detected)
> Jun  5 15:42:44 [2552] NOTICE:core:main: version: opensips 1.5.1-notls
> (i386/lin                                             ux)
> Jun  5 15:42:44 [2552] INFO:core:main: using 64 Mb shared memory
> Jun  5 15:42:44 [2552] INFO:core:main: using 1 Mb private memory per
> process
> .
> sips:~# Jun  5 15:42:45 [2552] NOTICE:signaling:mod_init: initializing
> module ..                                             .
> Jun  5 15:42:45 [2552] INFO:sl:mod_init: Initializing StateLess engine
> Jun  5 15:42:45 [2552] INFO:tm:mod_init: TM - initializing...
> Jun  5 15:42:46 [2552] INFO:maxfwd:mod_init: initializing...
> Jun  5 15:42:46 [2552] INFO:usrloc:ul_init_locks: locks array size 512
> Jun  5 15:42:46 [2552] INFO:registrar:mod_init: initializing...
> Jun  5 15:42:46 [2552] INFO:textops:mod_init: initializing...
> Jun  5 15:42:46 [2552] INFO:xlog:mod_init: initializing...
> Jun  5 15:42:46 [2552] INFO:acc:mod_init: initializing...
> Jun  5 15:42:46 [2552] INFO:auth:mod_init: initializing...
> Jun  5 15:42:46 [2552] INFO:auth_db:mod_init: initializing...
> Jun  5 15:42:46 [2552] NOTICE:presence:mod_init: initializing module ...
> Jun  5 15:42:49 [2552] ERROR:db_mysql:db_mysql_new_connection: driver
> error(2013                                             ): Lost
> connection to MySQL server at 'reading initial communication packet',
> sy                                             stem error: 111
> Jun  5 15:42:49 [2552] ERROR:core:db_do_init: could not add connection
> to the po                                             ol
> Jun  5 15:42:49 [2552] ERROR:usrloc:register_udomain: failed to open
> database co                                             nnection
> Jun  5 15:42:49 [2552] ERROR:registrar:domain_fixup: failed to
> register domain
> Jun  5 15:42:49 [2552] ERROR:core:fix_actions: fixing failed (code=-1)
> at cfg li                                             ne 345
> Jun  5 15:42:49 [2552] CRITICAL:core:fix_expr: fix_actions error
> Jun  5 15:42:49 [2552] ERROR:core:main: failed to fix configuration
> with err cod                                             e -1
> Jun  5 15:42:49 [2552] NOTICE:presence:destroy: destroy module ...
>  
> Please help.
>  
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users