Errors while setting up Opensips with Berkeley DB

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Errors while setting up Opensips with Berkeley DB

Jan Rozhon
Hi list,

I am trying to set up and run opensips with berkeley module. After
configuration, and creating of database I get this error:

chieftec:~# opensipsctl add 1234 1234
/usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
username='1234' and domain='10.0.0.140';: command not found
INFO: user '1234' already exists

Nothing else in syslog nor in messages. Could you give me a hint how to
solve this issue.

Thanks in advace, Jan Rozhon


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Errors while setting up Opensips with Berkeley DB

David J.-2
Where is the error?

Check your database and make sure you dont have an entry for that user.


Jan Rozhon wrote:

> Hi list,
>
> I am trying to set up and run opensips with berkeley module. After
> configuration, and creating of database I get this error:
>
> chieftec:~# opensipsctl add 1234 1234
> /usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
> username='1234' and domain='10.0.0.140';: command not found
> INFO: user '1234' already exists
>
> Nothing else in syslog nor in messages. Could you give me a hint how to
> solve this issue.
>
> Thanks in advace, Jan Rozhon
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Errors while setting up Opensips with Berkeley DB

Jan Rozhon
No, user in database - checked twice. Problem is, that I cannot add any
user....


Dne 5.3.2010 16:39, David J. napsal(a):

> Where is the error?
>
> Check your database and make sure you dont have an entry for that user.
>
>
> Jan Rozhon wrote:
>    
>> Hi list,
>>
>> I am trying to set up and run opensips with berkeley module. After
>> configuration, and creating of database I get this error:
>>
>> chieftec:~# opensipsctl add 1234 1234
>> /usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
>> username='1234' and domain='10.0.0.140';: command not found
>> INFO: user '1234' already exists
>>
>> Nothing else in syslog nor in messages. Could you give me a hint how to
>> solve this issue.
>>
>> Thanks in advace, Jan Rozhon
>>
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>>      
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>    


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Errors while setting up Opensips with Berkeley DB

David J.-2
And your sure your checking the same database your script is pointing to?



Jan Rozhon wrote:

> No, user in database - checked twice. Problem is, that I cannot add any
> user....
>
>
> Dne 5.3.2010 16:39, David J. napsal(a):
>  
>> Where is the error?
>>
>> Check your database and make sure you dont have an entry for that user.
>>
>>
>> Jan Rozhon wrote:
>>    
>>    
>>> Hi list,
>>>
>>> I am trying to set up and run opensips with berkeley module. After
>>> configuration, and creating of database I get this error:
>>>
>>> chieftec:~# opensipsctl add 1234 1234
>>> /usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
>>> username='1234' and domain='10.0.0.140';: command not found
>>> INFO: user '1234' already exists
>>>
>>> Nothing else in syslog nor in messages. Could you give me a hint how to
>>> solve this issue.
>>>
>>> Thanks in advace, Jan Rozhon
>>>
>>>
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>>      
>>>      
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>    
>>    
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Errors while setting up Opensips with Berkeley DB

Jan Rozhon
Definitely sure....it's the only one I have.

Dne 5.3.2010 16:44, David J. napsal(a):

> And your sure your checking the same database your script is pointing to?
>
>
>
> Jan Rozhon wrote:
>    
>> No, user in database - checked twice. Problem is, that I cannot add any
>> user....
>>
>>
>> Dne 5.3.2010 16:39, David J. napsal(a):
>>
>>      
>>> Where is the error?
>>>
>>> Check your database and make sure you dont have an entry for that user.
>>>
>>>
>>> Jan Rozhon wrote:
>>>
>>>
>>>        
>>>> Hi list,
>>>>
>>>> I am trying to set up and run opensips with berkeley module. After
>>>> configuration, and creating of database I get this error:
>>>>
>>>> chieftec:~# opensipsctl add 1234 1234
>>>> /usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
>>>> username='1234' and domain='10.0.0.140';: command not found
>>>> INFO: user '1234' already exists
>>>>
>>>> Nothing else in syslog nor in messages. Could you give me a hint how to
>>>> solve this issue.
>>>>
>>>> Thanks in advace, Jan Rozhon
>>>>
>>>>
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>
>>>>
>>>>
>>>>
>>>>          
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>>        
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>>      
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>    


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Errors while setting up Opensips with Berkeley DB

David J.-2
Yikes! Can you run any of the other opensipsctl commands on that database?
Or do they fail as well?



Jan Rozhon wrote:

> Definitely sure....it's the only one I have.
>
> Dne 5.3.2010 16:44, David J. napsal(a):
>  
>> And your sure your checking the same database your script is pointing to?
>>
>>
>>
>> Jan Rozhon wrote:
>>    
>>    
>>> No, user in database - checked twice. Problem is, that I cannot add any
>>> user....
>>>
>>>
>>> Dne 5.3.2010 16:39, David J. napsal(a):
>>>
>>>      
>>>      
>>>> Where is the error?
>>>>
>>>> Check your database and make sure you dont have an entry for that user.
>>>>
>>>>
>>>> Jan Rozhon wrote:
>>>>
>>>>
>>>>        
>>>>        
>>>>> Hi list,
>>>>>
>>>>> I am trying to set up and run opensips with berkeley module. After
>>>>> configuration, and creating of database I get this error:
>>>>>
>>>>> chieftec:~# opensipsctl add 1234 1234
>>>>> /usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
>>>>> username='1234' and domain='10.0.0.140';: command not found
>>>>> INFO: user '1234' already exists
>>>>>
>>>>> Nothing else in syslog nor in messages. Could you give me a hint how to
>>>>> solve this issue.
>>>>>
>>>>> Thanks in advace, Jan Rozhon
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> Users mailing list
>>>>> [hidden email]
>>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>          
>>>>>          
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>
>>>>
>>>>        
>>>>        
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>>      
>>>      
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>    
>>    
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Errors while setting up Opensips with Berkeley DB

David J.-2
In reply to this post by Jan Rozhon
ex: opensipsctl db show subscriber


Jan Rozhon wrote:

> Definitely sure....it's the only one I have.
>
> Dne 5.3.2010 16:44, David J. napsal(a):
>  
>> And your sure your checking the same database your script is pointing to?
>>
>>
>>
>> Jan Rozhon wrote:
>>    
>>    
>>> No, user in database - checked twice. Problem is, that I cannot add any
>>> user....
>>>
>>>
>>> Dne 5.3.2010 16:39, David J. napsal(a):
>>>
>>>      
>>>      
>>>> Where is the error?
>>>>
>>>> Check your database and make sure you dont have an entry for that user.
>>>>
>>>>
>>>> Jan Rozhon wrote:
>>>>
>>>>
>>>>        
>>>>        
>>>>> Hi list,
>>>>>
>>>>> I am trying to set up and run opensips with berkeley module. After
>>>>> configuration, and creating of database I get this error:
>>>>>
>>>>> chieftec:~# opensipsctl add 1234 1234
>>>>> /usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
>>>>> username='1234' and domain='10.0.0.140';: command not found
>>>>> INFO: user '1234' already exists
>>>>>
>>>>> Nothing else in syslog nor in messages. Could you give me a hint how to
>>>>> solve this issue.
>>>>>
>>>>> Thanks in advace, Jan Rozhon
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> Users mailing list
>>>>> [hidden email]
>>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>          
>>>>>          
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>
>>>>
>>>>        
>>>>        
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>>      
>>>      
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>    
>>    
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Errors while setting up Opensips with Berkeley DB

Jan Rozhon
In reply to this post by David J.-2
chieftec:~# opensipsctl rm 1234
/usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
username='1234' and domain='10.0.0.140';: command not found
/usr/sbin/opensipsctl: line 2114: delete from dbaliases where
username='1234' and domain='10.0.0.140';: command not found
/usr/sbin/opensipsctl: line 2120: delete from subscriber where
username='1234' and domain='10.0.0.140';: command not found

chieftec:~# opensipsctl passwd 1234 1234
/usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
username='1234' and domain='10.0.0.140';: command not found
/usr/sbin/opensipsctl: line 2085: update subscriber set
ha1='3c423895135a99fe03133f46fc2c2c68',
ha1b='7d71b4b4ed0ed05a312db1521afa7843', password='1234' WHERE
username='1234' and domain=    '10.0.0.140';: command not found
ERROR: password change failed

Nothing works. Even after reinit of database.



Dne 5.3.2010 16:48, David J. napsal(a):

> Yikes! Can you run any of the other opensipsctl commands on that database?
> Or do they fail as well?
>
>
>
> Jan Rozhon wrote:
>    
>> Definitely sure....it's the only one I have.
>>
>> Dne 5.3.2010 16:44, David J. napsal(a):
>>
>>      
>>> And your sure your checking the same database your script is pointing to?
>>>
>>>
>>>
>>> Jan Rozhon wrote:
>>>
>>>
>>>        
>>>> No, user in database - checked twice. Problem is, that I cannot add any
>>>> user....
>>>>
>>>>
>>>> Dne 5.3.2010 16:39, David J. napsal(a):
>>>>
>>>>
>>>>
>>>>          
>>>>> Where is the error?
>>>>>
>>>>> Check your database and make sure you dont have an entry for that user.
>>>>>
>>>>>
>>>>> Jan Rozhon wrote:
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>            
>>>>>> Hi list,
>>>>>>
>>>>>> I am trying to set up and run opensips with berkeley module. After
>>>>>> configuration, and creating of database I get this error:
>>>>>>
>>>>>> chieftec:~# opensipsctl add 1234 1234
>>>>>> /usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
>>>>>> username='1234' and domain='10.0.0.140';: command not found
>>>>>> INFO: user '1234' already exists
>>>>>>
>>>>>> Nothing else in syslog nor in messages. Could you give me a hint how to
>>>>>> solve this issue.
>>>>>>
>>>>>> Thanks in advace, Jan Rozhon
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> Users mailing list
>>>>>> [hidden email]
>>>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>              
>>>>> _______________________________________________
>>>>> Users mailing list
>>>>> [hidden email]
>>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>            
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>
>>>>
>>>>
>>>>
>>>>          
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>>        
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>>      
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>    


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Errors while setting up Opensips with Berkeley DB

Jan Rozhon
In reply to this post by David J.-2
Same problem

chieftec:~# opensipsctl db show subscriber
/usr/sbin/opensipsctl: line 954: select * FROM subscriber;: command not
found



Dne 5.3.2010 16:49, David J. napsal(a):

> ex: opensipsctl db show subscriber
>
>
> Jan Rozhon wrote:
>    
>> Definitely sure....it's the only one I have.
>>
>> Dne 5.3.2010 16:44, David J. napsal(a):
>>
>>      
>>> And your sure your checking the same database your script is pointing to?
>>>
>>>
>>>
>>> Jan Rozhon wrote:
>>>
>>>
>>>        
>>>> No, user in database - checked twice. Problem is, that I cannot add any
>>>> user....
>>>>
>>>>
>>>> Dne 5.3.2010 16:39, David J. napsal(a):
>>>>
>>>>
>>>>
>>>>          
>>>>> Where is the error?
>>>>>
>>>>> Check your database and make sure you dont have an entry for that user.
>>>>>
>>>>>
>>>>> Jan Rozhon wrote:
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>            
>>>>>> Hi list,
>>>>>>
>>>>>> I am trying to set up and run opensips with berkeley module. After
>>>>>> configuration, and creating of database I get this error:
>>>>>>
>>>>>> chieftec:~# opensipsctl add 1234 1234
>>>>>> /usr/sbin/opensipsctl: line 196: select count(*) from subscriber where
>>>>>> username='1234' and domain='10.0.0.140';: command not found
>>>>>> INFO: user '1234' already exists
>>>>>>
>>>>>> Nothing else in syslog nor in messages. Could you give me a hint how to
>>>>>> solve this issue.
>>>>>>
>>>>>> Thanks in advace, Jan Rozhon
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> Users mailing list
>>>>>> [hidden email]
>>>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>              
>>>>> _______________________________________________
>>>>> Users mailing list
>>>>> [hidden email]
>>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>            
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>>
>>>>
>>>>
>>>>
>>>>          
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>>        
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>>      
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>    


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users