Getting error while Starting Opensips

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Getting error while Starting Opensips

Faisal Rehman
Hi Everyone,

I am using Open sips version: opensips 1.7.1-notls (x86_64/linux) for load balancing project, but I am getting the following error while Starting OpenSIPS:


Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:parse_uri: uri too short: <> (0)
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:dispatcher:add_dest2list: bad uri []
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:dispatcher:mod_init: could not initiate a connect to the database
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:init_mod: failed to initialize module dispatcher
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:main: error while initializing modules
Jan  3 08:52:52 lb-sf-mc opensips: INFO:core:daemonize: pre-daemon process exiting with -1


Any help would be highly appreciated :)
 
Regards,

Faisal Rehman

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Getting error while Starting Opensips

SamyGo
Hi,
you probably forgot to add destination URIs in some table for dispatcher module.

 ERROR:dispatcher:mod_init: could not initiate a connect to the database 

Regards,
Sammy.


On Tue, Jan 3, 2012 at 7:04 PM, Faisal Rehman <[hidden email]> wrote:
Hi Everyone,

I am using Open sips version: opensips 1.7.1-notls (x86_64/linux) for load balancing project, but I am getting the following error while Starting OpenSIPS:


Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:parse_uri: uri too short: <> (0)
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:dispatcher:add_dest2list: bad uri []
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:dispatcher:mod_init: could not initiate a connect to the database
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:init_mod: failed to initialize module dispatcher
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:main: error while initializing modules
Jan  3 08:52:52 lb-sf-mc opensips: INFO:core:daemonize: pre-daemon process exiting with -1


Any help would be highly appreciated :)
 
Regards,

Faisal Rehman

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Getting error while Starting Opensips

Faisal Rehman
Hi Sammy,

Is that manadatory, because I think we can put the values in load_balancer table only?

 
Regards,

Faisal Rehman

From: Sammy Govind <[hidden email]>
To: Faisal Rehman <[hidden email]>; OpenSIPS users mailling list <[hidden email]>
Sent: Tuesday, January 3, 2012 7:08 PM
Subject: Re: [OpenSIPS-Users] Getting error while Starting Opensips

Hi,
you probably forgot to add destination URIs in some table for dispatcher module.

 ERROR:dispatcher:mod_init: could not initiate a connect to the database 

Regards,
Sammy.


On Tue, Jan 3, 2012 at 7:04 PM, Faisal Rehman <[hidden email]> wrote:
Hi Everyone,

I am using Open sips version: opensips 1.7.1-notls (x86_64/linux) for load balancing project, but I am getting the following error while Starting OpenSIPS:


Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:parse_uri: uri too short: <> (0)
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:dispatcher:add_dest2list: bad uri []
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:dispatcher:mod_init: could not initiate a connect to the database
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:init_mod: failed to initialize module dispatcher
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:main: error while initializing modules
Jan  3 08:52:52 lb-sf-mc opensips: INFO:core:daemonize: pre-daemon process exiting with -1


Any help would be highly appreciated :)
 
Regards,

Faisal Rehman

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users





_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Getting error while Starting Opensips

Razvan Crainea
Hi, Faisal!

Only the load_balancer table is requiered. Your problem is that you didn't specify the db_url parameter for the load_balancer module. See http://www.opensips.org/html/docs/modules/devel/load_balancer.html#id249159 for more details.

Regards,
--
Răzvan Crainea
OpenSIPS Developer

On 01/03/2012 04:15 PM, Faisal Rehman wrote:
Hi Sammy,

Is that manadatory, because I think we can put the values in load_balancer table only?

 
Regards,

Faisal Rehman

From: Sammy Govind [hidden email]
To: Faisal Rehman [hidden email]; OpenSIPS users mailling list [hidden email]
Sent: Tuesday, January 3, 2012 7:08 PM
Subject: Re: [OpenSIPS-Users] Getting error while Starting Opensips

Hi,
you probably forgot to add destination URIs in some table for dispatcher module.

 ERROR:dispatcher:mod_init: could not initiate a connect to the database 

Regards,
Sammy.


On Tue, Jan 3, 2012 at 7:04 PM, Faisal Rehman <[hidden email]> wrote:
Hi Everyone,

I am using Open sips version: opensips 1.7.1-notls (x86_64/linux) for load balancing project, but I am getting the following error while Starting OpenSIPS:


Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:parse_uri: uri too short: <> (0)
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:dispatcher:add_dest2list: bad uri []
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:dispatcher:mod_init: could not initiate a connect to the database
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:init_mod: failed to initialize module dispatcher
Jan  3 08:52:52 lb-sf-mc /usr/local/sbin/opensips[16405]: ERROR:core:main: error while initializing modules
Jan  3 08:52:52 lb-sf-mc opensips: <a class="moz-txt-link-freetext" href="INFO:core:daemonize:">INFO:core:daemonize: pre-daemon process exiting with -1


Any help would be highly appreciated :)
 
Regards,

Faisal Rehman

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users






_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users