Install opensips to systemd

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Install opensips to systemd

Robert Dyck
I had a working opensips 1.11 installed by Fedora package manager. I have been
trying opensips 2.2.2 and decided to make the jump. Since 2.2.2 is not
available as a package from Fedora I cloned the source.

I have tried installing using menuconfig and also make but neither installs the
necessary files for systemd. I see that the files exist in the source directory
"packaging". Is there a way to trigger the installation of the necessary files
for systemd or does it need to be done manually.

I have thought of re-installing 1.11 from the package manager and then
overwriting the opensips binary. The problem I see is that a package upgrade
would overwrite 2.2.2 because the package manager sees opensips as an
installed package.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Install opensips to systemd

Răzvan Crainea-2
No, unfortunately there is no way to install the systemd files
automatically, you have to do it manually.

Best regards,

Răzvan Crainea
OpenSIPS Solutions
www.opensips-solutions.com

On 01/08/2017 10:49 PM, Robert Dyck wrote:

> I had a working opensips 1.11 installed by Fedora package manager. I have been
> trying opensips 2.2.2 and decided to make the jump. Since 2.2.2 is not
> available as a package from Fedora I cloned the source.
>
> I have tried installing using menuconfig and also make but neither installs the
> necessary files for systemd. I see that the files exist in the source directory
> "packaging". Is there a way to trigger the installation of the necessary files
> for systemd or does it need to be done manually.
>
> I have thought of re-installing 1.11 from the package manager and then
> overwriting the opensips binary. The problem I see is that a package upgrade
> would overwrite 2.2.2 because the package manager sees opensips as an
> installed package.
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users