Load Balancer Module - MySQL issue.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Load Balancer Module - MySQL issue.

Alan Frisch
I've been experimenting with OpenSIPs new Load Balancer module and have run into a bit of a snag.  Used the configuration from the Tutorial on Load Balancer, though needed some lines added as it seems incomplete (ie. load_balancer module needs to be added to the loadmodule section).

When I attempt to run OpenSIPS, I receive the following error about MySQL:

Mar  8 16:17:03 [5279] DBG:db_mysql:db_mysql_new_connection: opening connection: mysql://xxxx:xxxx@localhost/opensips
Mar  8 16:17:03 [5279] DBG:db_mysql:db_mysql_new_connection: connection type is Localhost via UNIX socket
Mar  8 16:17:03 [5279] DBG:db_mysql:db_mysql_new_connection: protocol version is 10
Mar  8 16:17:03 [5279] DBG:db_mysql:db_mysql_new_connection: server version is 5.0.68
Mar  8 16:17:03 [5279] CRITICAL:load_balancer:mi_child_init: cannot initialize database connection
Mar  8 16:17:03 [5279] ERROR:core:init_mi_child: failed to init <lb_reload>
Mar  8 16:17:03 [5279] CRITICAL:mi_fifo:fifo_process: faild to init the mi process
Mar  8 16:17:03 [5274] INFO:core:handle_sigs: child process 5279 exited normally, status=255
Mar  8 16:17:03 [5274] INFO:core:handle_sigs: terminating due to SIGCHLD
Mar  8 16:17:03 [5277] INFO:core:sig_usr: signal 15 received

I can connect no problem from the command line and other modules that rely on the same db_url load their data from the DB without issue.

Any help on this one is aprpeciated!

AF.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Load Balancer Module - MySQL issue.

Bogdan-Andrei Iancu
Hi Alan,

Alan Frisch wrote:
> I've been experimenting with OpenSIPs new Load Balancer module and
> have run into a bit of a snag.  Used the configuration from the
> Tutorial on Load Balancer, though needed some lines added as it seems
> incomplete (ie. load_balancer module needs to be added to the
> loadmodule section).
Thanks for the reports - I fixed the script by loading the LB module
also; if you spoted any other issues, please edit the page or let me
know about the errors.

>
> When I attempt to run OpenSIPS, I receive the following error about MySQL:
>
> Mar  8 16:17:03 [5279] DBG:db_mysql:db_mysql_new_connection: opening
> connection: mysql://xxxx:xxxx@localhost/opensips
> Mar  8 16:17:03 [5279] DBG:db_mysql:db_mysql_new_connection:
> connection type is Localhost via UNIX socket
> Mar  8 16:17:03 [5279] DBG:db_mysql:db_mysql_new_connection: protocol
> version is 10
> Mar  8 16:17:03 [5279] DBG:db_mysql:db_mysql_new_connection: server
> version is 5.0.68
> Mar  8 16:17:03 [5279] CRITICAL:load_balancer:mi_child_init: cannot
> initialize database connection
> Mar  8 16:17:03 [5279] ERROR:core:init_mi_child: failed to init
> <lb_reload>
> Mar  8 16:17:03 [5279] CRITICAL:mi_fifo:fifo_process: faild to init
> the mi process
> Mar  8 16:17:03 [5274] INFO:core:handle_sigs: child process 5279
> exited normally, status=255
> Mar  8 16:17:03 [5274] INFO:core:handle_sigs: terminating due to SIGCHLD
> Mar  8 16:17:03 [5277] INFO:core:sig_usr: signal 15 received
>
> I can connect no problem from the command line and other modules that
> rely on the same db_url load their data from the DB without issue.

It was a bug which is fixed now. Please update from SVN and try again.

Thanks and regards,
Bogdan

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users