Log problem

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Log problem

Miha
Hi,

my opensips.cfg:
debug=6
log_stderror=yes
log_facility=LOG_LOCAL0

syslog.conf

#opensips
local0.* -/var/log/opensips.log


Where could be a poroblem that opensips does not log?
Opensips.log is empty.

Thanks!

BR,
Miha



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

Saúl Ibarra Corretgé

On Nov 19, 2012, at 12:26 PM, Miha wrote:

> Hi,
>
> my opensips.cfg:
> debug=6
> log_stderror=yes
> log_facility=LOG_LOCAL0
>
> syslog.conf
>
> #opensips
> local0.* -/var/log/opensips.log
>
>
> Where could be a poroblem that opensips does not log?
> Opensips.log is empty.
>

Remove that '-' from the syslog.conf line, that prevents the matching entries from going there. It should look like this:

#opensips
local0.* /var/log/opensips.log


Regards,

PS: This applies to rsyslog.

--
Saúl Ibarra Corretgé
AG Projects




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

Miha
HI,

here is my pastebin when I do opensips start:
http://pastebin.com/Z9hxrHB2


debug=6
log_stderror=yes
log_facility=LOG_LOCAL0


syslog.conf



#opensips
local0.*                                                /var/log/opensips.log



Still no luck:(

I tried to cat massages, opensips.log but there is no opensips log.

Br,
Miha

On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
On Nov 19, 2012, at 12:26 PM, Miha wrote:

Hi,

my opensips.cfg:
debug=6
log_stderror=yes
log_facility=LOG_LOCAL0

syslog.conf

#opensips
local0.* -/var/log/opensips.log


Where could be a poroblem that opensips does not log?
Opensips.log is empty.

Remove that '-' from the syslog.conf line, that prevents the matching entries from going there. It should look like this:

#opensips
local0.* /var/log/opensips.log


Regards,

PS: This applies to rsyslog.

--
Saúl Ibarra Corretgé
AG Projects




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

Muhammad Shahzad
you need restart syslog service. Under debian you can do this by,

service rsyslog restart

This will create log file as well.

Thank you.


On Mon, Nov 19, 2012 at 1:44 PM, Miha <[hidden email]> wrote:
HI,

here is my pastebin when I do opensips start:
http://pastebin.com/Z9hxrHB2


debug=6
log_stderror=yes
log_facility=LOG_LOCAL0


syslog.conf



#opensips
local0.*                                                /var/log/opensips.log



Still no luck:(

I tried to cat massages, opensips.log but there is no opensips log.

Br,
Miha


On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
On Nov 19, 2012, at 12:26 PM, Miha wrote:

Hi,

my opensips.cfg:
debug=6
log_stderror=yes
log_facility=LOG_LOCAL0

syslog.conf

#opensips
local0.* -/var/log/opensips.log


Where could be a poroblem that opensips does not log?
Opensips.log is empty.

Remove that '-' from the syslog.conf line, that prevents the matching entries from going there. It should look like this:

#opensips
local0.* /var/log/opensips.log


Regards,

PS: This applies to rsyslog.

--
Saúl Ibarra Corretgé
AG Projects




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Muhammad Shahzad
-----------------------------------
CISCO Rich Media Communication Specialist (CRMCS)
CISCO Certified Network Associate (CCNA)
Cell: +49 176 99 83 10 85
MSN: [hidden email]
Email: [hidden email]

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

Miha
Hi,

I am using centos. I have restarted syslog service
(/etc/init.d/syslog restart) which created me opensips.log.

But still it is empty.

On Mon, 19 Nov 2012 14:34:31 +0100
 Muhammad Shahzad <[hidden email]> wrote:

> you need restart syslog service. Under debian you can do
> this by,
>
> service rsyslog restart
>
> This will create log file as well.
>
> Thank you.
>
>
> On Mon, Nov 19, 2012 at 1:44 PM, Miha <[hidden email]>
> wrote:
>
> >  HI,
> >
> > here is my pastebin when I do opensips start:
> > http://pastebin.com/Z9hxrHB2
> >
> >
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> >
> > syslog.conf
> >
> >
> >
> > #opensips
> > local0.*
> > /var/log/opensips.log
> >
> >
> >
> > Still no luck:(
> >
> > I tried to cat massages, opensips.log but there is no
> opensips log.
> >
> > Br,
> > Miha
> >
> >
> > On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
> >
> > On Nov 19, 2012, at 12:26 PM, Miha wrote:
> >
> >
> >  Hi,
> >
> > my opensips.cfg:
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> > syslog.conf
> >
> > #opensips
> > local0.* -/var/log/opensips.log
> >
> >
> > Where could be a poroblem that opensips does not log?
> > Opensips.log is empty.
> >
> >
> >  Remove that '-' from the syslog.conf line, that
> prevents the matching entries from going there. It should
> look like this:
> >
> > #opensips
> > local0.* /var/log/opensips.log
> >
> >
> > Regards,
> >
> > PS: This applies to rsyslog.
> >
> > --
> > Saúl Ibarra Corretgé
> > AG Projects
> >
> >
> >
> >
> > _______________________________________________
> > Users mailing
>
[hidden email]://lists.opensips.org/cgi-bin/mailman/listinfo/users

> >
> >
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> >
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
>
>
> --
> Muhammad Shahzad
> -----------------------------------
> CISCO Rich Media Communication Specialist (CRMCS)
> CISCO Certified Network Associate (CCNA)
> Cell: +49 176 99 83 10 85
> MSN: [hidden email]
> Email: [hidden email]

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

shaheryarkh
Here is the sequence of actions, which must be done in order,

1. edit syslog.conf to define your custom log file for opensips.
2. restart syslog service.
3. restart opensips.

Thank you.


On Mon, Nov 19, 2012 at 5:28 PM, Miha <[hidden email]> wrote:
Hi,

I am using centos. I have restarted syslog service
(/etc/init.d/syslog restart) which created me opensips.log.

But still it is empty.

On Mon, 19 Nov 2012 14:34:31 +0100
 Muhammad Shahzad <[hidden email]> wrote:
> you need restart syslog service. Under debian you can do
> this by,
>
> service rsyslog restart
>
> This will create log file as well.
>
> Thank you.
>
>
> On Mon, Nov 19, 2012 at 1:44 PM, Miha <[hidden email]>
> wrote:
>
> >  HI,
> >
> > here is my pastebin when I do opensips start:
> > http://pastebin.com/Z9hxrHB2
> >
> >
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> >
> > syslog.conf
> >
> >
> >
> > #opensips
> > local0.*
> > /var/log/opensips.log
> >
> >
> >
> > Still no luck:(
> >
> > I tried to cat massages, opensips.log but there is no
> opensips log.
> >
> > Br,
> > Miha
> >
> >
> > On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
> >
> > On Nov 19, 2012, at 12:26 PM, Miha wrote:
> >
> >
> >  Hi,
> >
> > my opensips.cfg:
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> > syslog.conf
> >
> > #opensips
> > local0.* -/var/log/opensips.log
> >
> >
> > Where could be a poroblem that opensips does not log?
> > Opensips.log is empty.
> >
> >
> >  Remove that '-' from the syslog.conf line, that
> prevents the matching entries from going there. It should
> look like this:
> >
> > #opensips
> > local0.* /var/log/opensips.log
> >
> >
> > Regards,
> >
> > PS: This applies to rsyslog.
> >
> > --
> > Saúl Ibarra Corretgé
> > AG Projects
> >
> >
> >
> >
> > _______________________________________________
> > Users mailing
>
[hidden email]://lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> >
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
>
>
> --
> Muhammad Shahzad
> -----------------------------------
> CISCO Rich Media Communication Specialist (CRMCS)
> CISCO Certified Network Associate (CCNA)
> Cell: <a href="tel:%2B49%20176%2099%2083%2010%2085" value="+4917699831085">+49 176 99 83 10 85
> MSN: [hidden email]
> Email: [hidden email]


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

Miha
Hi Muhammad,

exactly  that it did, that is the problem:)

Could be wrong opensips version (1.8.2)?

Here is my pastebin: http://pastebin.com/H8jXpkub

You can see that I did exactly what you said:)

Thanks for help!

BR,
Miha

On 11/19/2012 7:34 PM, Muhammad Shahzad wrote:
Here is the sequence of actions, which must be done in order,

1. edit syslog.conf to define your custom log file for opensips.
2. restart syslog service.
3. restart opensips.

Thank you.


On Mon, Nov 19, 2012 at 5:28 PM, Miha <[hidden email]> wrote:
Hi,

I am using centos. I have restarted syslog service
(/etc/init.d/syslog restart) which created me opensips.log.

But still it is empty.

On Mon, 19 Nov 2012 14:34:31 +0100
 Muhammad Shahzad <[hidden email]> wrote:
> you need restart syslog service. Under debian you can do
> this by,
>
> service rsyslog restart
>
> This will create log file as well.
>
> Thank you.
>
>
> On Mon, Nov 19, 2012 at 1:44 PM, Miha <[hidden email]>
> wrote:
>
> >  HI,
> >
> > here is my pastebin when I do opensips start:
> > http://pastebin.com/Z9hxrHB2
> >
> >
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> >
> > syslog.conf
> >
> >
> >
> > #opensips
> > local0.*
> > /var/log/opensips.log
> >
> >
> >
> > Still no luck:(
> >
> > I tried to cat massages, opensips.log but there is no
> opensips log.
> >
> > Br,
> > Miha
> >
> >
> > On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
> >
> > On Nov 19, 2012, at 12:26 PM, Miha wrote:
> >
> >
> >  Hi,
> >
> > my opensips.cfg:
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> > syslog.conf
> >
> > #opensips
> > local0.* -/var/log/opensips.log
> >
> >
> > Where could be a poroblem that opensips does not log?
> > Opensips.log is empty.
> >
> >
> >  Remove that '-' from the syslog.conf line, that
> prevents the matching entries from going there. It should
> look like this:
> >
> > #opensips
> > local0.* /var/log/opensips.log
> >
> >
> > Regards,
> >
> > PS: This applies to rsyslog.
> >
> > --
> > Saúl Ibarra Corretgé
> > AG Projects
> >
> >
> >
> >
> > _______________________________________________
> > Users mailing
>
[hidden email]lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> >
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
>
>
> --
> Muhammad Shahzad
> -----------------------------------
> CISCO Rich Media Communication Specialist (CRMCS)
> CISCO Certified Network Associate (CCNA)
> Cell: <a moz-do-not-send="true" href="tel:%2B49%20176%2099%2083%2010%2085" value="+4917699831085">+49 176 99 83 10 85
> MSN: [hidden email]
> Email: [hidden email]



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

Binan83
Hi Miha,

Check if you have another OpenSIPS on your machine (maybe installed by your OS).

// Binan



Från: Miha <[hidden email]>
Till: Muhammad Shahzad <[hidden email]>
Kopia: OpenSIPS users mailling list <[hidden email]>
Skickat: tisdag, 20 november 2012 8:09
Ämne: Re: [OpenSIPS-Users] Log problem

Hi Muhammad,

exactly  that it did, that is the problem:)

Could be wrong opensips version (1.8.2)?

Here is my pastebin: http://pastebin.com/H8jXpkub

You can see that I did exactly what you said:)

Thanks for help!

BR,
Miha

On 11/19/2012 7:34 PM, Muhammad Shahzad wrote:
Here is the sequence of actions, which must be done in order,

1. edit syslog.conf to define your custom log file for opensips.
2. restart syslog service.
3. restart opensips.

Thank you.


On Mon, Nov 19, 2012 at 5:28 PM, Miha <[hidden email]> wrote:
Hi,

I am using centos. I have restarted syslog service
(/etc/init.d/syslog restart) which created me opensips.log.

But still it is empty.

On Mon, 19 Nov 2012 14:34:31 +0100
 Muhammad Shahzad <[hidden email]> wrote:
> you need restart syslog service. Under debian you can do
> this by,
>
> service rsyslog restart
>
> This will create log file as well.
>
> Thank you.
>
>
> On Mon, Nov 19, 2012 at 1:44 PM, Miha <[hidden email]>
> wrote:
>
> >  HI,
> >
> > here is my pastebin when I do opensips start:
> > http://pastebin.com/Z9hxrHB2
> >
> >
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> >
> > syslog.conf
> >
> >
> >
> > #opensips
> > local0.*
> > /var/log/opensips.log
> >
> >
> >
> > Still no luck:(
> >
> > I tried to cat massages, opensips.log but there is no
> opensips log.
> >
> > Br,
> > Miha
> >
> >
> > On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
> >
> > On Nov 19, 2012, at 12:26 PM, Miha wrote:
> >
> >
> >  Hi,
> >
> > my opensips.cfg:
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> > syslog.conf
> >
> > #opensips
> > local0.* -/var/log/opensips.log
> >
> >
> > Where could be a poroblem that opensips does not log?
> > Opensips.log is empty.
> >
> >
> >  Remove that '-' from the syslog.conf line, that
> prevents the matching entries from going there. It should
> look like this:
> >
> > #opensips
> > local0.* /var/log/opensips.log
> >
> >
> > Regards,
> >
> > PS: This applies to rsyslog.
> >
> > --
> > Saúl Ibarra Corretgé
> > AG Projects
> >
> >
> >
> >
> > _______________________________________________
> > Users mailing
>
[hidden email]lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> >
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
>
>
> --
> Muhammad Shahzad
> -----------------------------------
> CISCO Rich Media Communication Specialist (CRMCS)
> CISCO Certified Network Associate (CCNA)
> Cell: +49 176 99 83 10 85
> MSN: [hidden email]
> Email: [hidden email]



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
voipmagazine.wordpress.com/
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

Miha
I checked it but do not see any other verison installed.

I will try to install new centos and that do new installation of opensips.

Thanks!
Miha

On 11/20/2012 9:21 AM, Binan AL Halabi wrote:
Hi Miha,

Check if you have another OpenSIPS on your machine (maybe installed by your OS).

// Binan



Från: Miha [hidden email]
Till: Muhammad Shahzad [hidden email]
Kopia: OpenSIPS users mailling list [hidden email]
Skickat: tisdag, 20 november 2012 8:09
Ämne: Re: [OpenSIPS-Users] Log problem

Hi Muhammad,

exactly  that it did, that is the problem:)

Could be wrong opensips version (1.8.2)?

Here is my pastebin: http://pastebin.com/H8jXpkub

You can see that I did exactly what you said:)

Thanks for help!

BR,
Miha

On 11/19/2012 7:34 PM, Muhammad Shahzad wrote:
Here is the sequence of actions, which must be done in order,

1. edit syslog.conf to define your custom log file for opensips.
2. restart syslog service.
3. restart opensips.

Thank you.


On Mon, Nov 19, 2012 at 5:28 PM, Miha <[hidden email]> wrote:
Hi,

I am using centos. I have restarted syslog service
(/etc/init.d/syslog restart) which created me opensips.log.

But still it is empty.

On Mon, 19 Nov 2012 14:34:31 +0100
 Muhammad Shahzad <[hidden email]> wrote:
> you need restart syslog service. Under debian you can do
> this by,
>
> service rsyslog restart
>
> This will create log file as well.
>
> Thank you.
>
>
> On Mon, Nov 19, 2012 at 1:44 PM, Miha <[hidden email]>
> wrote:
>
> >  HI,
> >
> > here is my pastebin when I do opensips start:
> > http://pastebin.com/Z9hxrHB2
> >
> >
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> >
> > syslog.conf
> >
> >
> >
> > #opensips
> > local0.*
> > /var/log/opensips.log
> >
> >
> >
> > Still no luck:(
> >
> > I tried to cat massages, opensips.log but there is no
> opensips log.
> >
> > Br,
> > Miha
> >
> >
> > On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
> >
> > On Nov 19, 2012, at 12:26 PM, Miha wrote:
> >
> >
> >  Hi,
> >
> > my opensips.cfg:
> > debug=6
> > log_stderror=yes
> > log_facility=LOG_LOCAL0
> >
> > syslog.conf
> >
> > #opensips
> > local0.* -/var/log/opensips.log
> >
> >
> > Where could be a poroblem that opensips does not log?
> > Opensips.log is empty.
> >
> >
> >  Remove that '-' from the syslog.conf line, that
> prevents the matching entries from going there. It should
> look like this:
> >
> > #opensips
> > local0.* /var/log/opensips.log
> >
> >
> > Regards,
> >
> > PS: This applies to rsyslog.
> >
> > --
> > Saúl Ibarra Corretgé
> > AG Projects
> >
> >
> >
> >
> > _______________________________________________
> > Users mailing
>
[hidden email]lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> >
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
>
>
> --
> Muhammad Shahzad
> -----------------------------------
> CISCO Rich Media Communication Specialist (CRMCS)
> CISCO Certified Network Associate (CCNA)
> Cell: +49 176 99 83 10 85
> MSN: [hidden email]
> Email: [hidden email]



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

shaheryarkh

You have log stderr on. Opensips will not log to file in this case. Turn it off.

Thank you.

On Nov 20, 2012 9:31 AM, "Miha" <[hidden email]> wrote:
>
> I checked it but do not see any other verison installed.
>
> I will try to install new centos and that do new installation of opensips.
>
> Thanks!
> Miha
>
> On 11/20/2012 9:21 AM, Binan AL Halabi wrote:
>>
>> Hi Miha,
>>
>> Check if you have another OpenSIPS on your machine (maybe installed by your OS).
>>
>> // Binan
>>
>>
>> ________________________________
>> Från: Miha <[hidden email]>
>> Till: Muhammad Shahzad <[hidden email]>
>> Kopia: OpenSIPS users mailling list <[hidden email]>
>> Skickat: tisdag, 20 november 2012 8:09
>> Ämne: Re: [OpenSIPS-Users] Log problem
>>
>> Hi Muhammad,
>>
>> exactly  that it did, that is the problem:)
>>
>> Could be wrong opensips version (1.8.2)?
>>
>> Here is my pastebin: http://pastebin.com/H8jXpkub
>>
>> You can see that I did exactly what you said:)
>>
>> Thanks for help!
>>
>> BR,
>> Miha
>>
>> On 11/19/2012 7:34 PM, Muhammad Shahzad wrote:
>>>
>>> Here is the sequence of actions, which must be done in order,
>>>
>>> 1. edit syslog.conf to define your custom log file for opensips.
>>> 2. restart syslog service.
>>> 3. restart opensips.
>>>
>>> Thank you.
>>>
>>>
>>> On Mon, Nov 19, 2012 at 5:28 PM, Miha <[hidden email]> wrote:
>>>>
>>>> Hi,
>>>>
>>>> I am using centos. I have restarted syslog service
>>>> (/etc/init.d/syslog restart) which created me opensips.log.
>>>>
>>>> But still it is empty.
>>>>
>>>> On Mon, 19 Nov 2012 14:34:31 +0100
>>>>  Muhammad Shahzad <[hidden email]> wrote:
>>>> > you need restart syslog service. Under debian you can do
>>>> > this by,
>>>> >
>>>> > service rsyslog restart
>>>> >
>>>> > This will create log file as well.
>>>> >
>>>> > Thank you.
>>>> >
>>>> >
>>>> > On Mon, Nov 19, 2012 at 1:44 PM, Miha <[hidden email]>
>>>> > wrote:
>>>> >
>>>> > >  HI,
>>>> > >
>>>> > > here is my pastebin when I do opensips start:
>>>> > > http://pastebin.com/Z9hxrHB2
>>>> > >
>>>> > >
>>>> > > debug=6
>>>> > > log_stderror=yes
>>>> > > log_facility=LOG_LOCAL0
>>>> > >
>>>> > >
>>>> > > syslog.conf
>>>> > >
>>>> > >
>>>> > >
>>>> > > #opensips
>>>> > > local0.*
>>>> > > /var/log/opensips.log
>>>> > >
>>>> > >
>>>> > >
>>>> > > Still no luck:(
>>>> > >
>>>> > > I tried to cat massages, opensips.log but there is no
>>>> > opensips log.
>>>> > >
>>>> > > Br,
>>>> > > Miha
>>>> > >
>>>> > >
>>>> > > On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
>>>> > >
>>>> > > On Nov 19, 2012, at 12:26 PM, Miha wrote:
>>>> > >
>>>> > >
>>>> > >  Hi,
>>>> > >
>>>> > > my opensips.cfg:
>>>> > > debug=6
>>>> > > log_stderror=yes
>>>> > > log_facility=LOG_LOCAL0
>>>> > >
>>>> > > syslog.conf
>>>> > >
>>>> > > #opensips
>>>> > > local0.* -/var/log/opensips.log
>>>> > >
>>>> > >
>>>> > > Where could be a poroblem that opensips does not log?
>>>> > > Opensips.log is empty.
>>>> > >
>>>> > >
>>>> > >  Remove that '-' from the syslog.conf line, that
>>>> > prevents the matching entries from going there. It should
>>>> > look like this:
>>>> > >
>>>> > > #opensips
>>>> > > local0.* /var/log/opensips.log
>>>> > >
>>>> > >
>>>> > > Regards,
>>>> > >
>>>> > > PS: This applies to rsyslog.
>>>> > >
>>>> > > --
>>>> > > Saúl Ibarra Corretgé
>>>> > > AG Projects
>>>> > >
>>>> > >
>>>> > >
>>>> > >
>>>> > > _______________________________________________
>>>> > > Users mailing
>>>> >
>>>> [hidden email]://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>> > >
>>>> > >
>>>> > >
>>>> > > _______________________________________________
>>>> > > Users mailing list
>>>> > > [hidden email]
>>>> > >
>>>> > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>> > >
>>>> > >
>>>> >
>>>> >
>>>> > --
>>>> > Muhammad Shahzad
>>>> > -----------------------------------
>>>> > CISCO Rich Media Communication Specialist (CRMCS)
>>>> > CISCO Certified Network Associate (CCNA)
>>>> > Cell: +49 176 99 83 10 85
>>>> > MSN: [hidden email]
>>>> > Email: [hidden email]
>>>
>>>
>>
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>>
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Log problem

Miha
@Muhammad

thanks!

Miha

On 11/20/2012 9:56 AM, Muhammad Shahzad wrote:

You have log stderr on. Opensips will not log to file in this case. Turn it off.

Thank you.

On Nov 20, 2012 9:31 AM, "Miha" <[hidden email]> wrote:
>
> I checked it but do not see any other verison installed.
>
> I will try to install new centos and that do new installation of opensips.
>
> Thanks!
> Miha
>
> On 11/20/2012 9:21 AM, Binan AL Halabi wrote:
>>
>> Hi Miha,
>>
>> Check if you have another OpenSIPS on your machine (maybe installed by your OS).
>>
>> // Binan
>>
>>
>> ________________________________
>> Från: Miha <[hidden email]>
>> Till: Muhammad Shahzad <[hidden email]>
>> Kopia: OpenSIPS users mailling list <[hidden email]>
>> Skickat: tisdag, 20 november 2012 8:09
>> Ämne: Re: [OpenSIPS-Users] Log problem
>>
>> Hi Muhammad,
>>
>> exactly  that it did, that is the problem:)
>>
>> Could be wrong opensips version (1.8.2)?
>>
>> Here is my pastebin: http://pastebin.com/H8jXpkub
>>
>> You can see that I did exactly what you said:)
>>
>> Thanks for help!
>>
>> BR,
>> Miha
>>
>> On 11/19/2012 7:34 PM, Muhammad Shahzad wrote:
>>>
>>> Here is the sequence of actions, which must be done in order,
>>>
>>> 1. edit syslog.conf to define your custom log file for opensips.
>>> 2. restart syslog service.
>>> 3. restart opensips.
>>>
>>> Thank you.
>>>
>>>
>>> On Mon, Nov 19, 2012 at 5:28 PM, Miha <[hidden email]> wrote:
>>>>
>>>> Hi,
>>>>
>>>> I am using centos. I have restarted syslog service
>>>> (/etc/init.d/syslog restart) which created me opensips.log.
>>>>
>>>> But still it is empty.
>>>>
>>>> On Mon, 19 Nov 2012 14:34:31 +0100
>>>>  Muhammad Shahzad <[hidden email]> wrote:
>>>> > you need restart syslog service. Under debian you can do
>>>> > this by,
>>>> >
>>>> > service rsyslog restart
>>>> >
>>>> > This will create log file as well.
>>>> >
>>>> > Thank you.
>>>> >
>>>> >
>>>> > On Mon, Nov 19, 2012 at 1:44 PM, Miha <[hidden email]>
>>>> > wrote:
>>>> >
>>>> > >  HI,
>>>> > >
>>>> > > here is my pastebin when I do opensips start:
>>>> > > http://pastebin.com/Z9hxrHB2
>>>> > >
>>>> > >
>>>> > > debug=6
>>>> > > log_stderror=yes
>>>> > > log_facility=LOG_LOCAL0
>>>> > >
>>>> > >
>>>> > > syslog.conf
>>>> > >
>>>> > >
>>>> > >
>>>> > > #opensips
>>>> > > local0.*
>>>> > > /var/log/opensips.log
>>>> > >
>>>> > >
>>>> > >
>>>> > > Still no luck:(
>>>> > >
>>>> > > I tried to cat massages, opensips.log but there is no
>>>> > opensips log.
>>>> > >
>>>> > > Br,
>>>> > > Miha
>>>> > >
>>>> > >
>>>> > > On 11/19/2012 12:35 PM, Saúl Ibarra Corretgé wrote:
>>>> > >
>>>> > > On Nov 19, 2012, at 12:26 PM, Miha wrote:
>>>> > >
>>>> > >
>>>> > >  Hi,
>>>> > >
>>>> > > my opensips.cfg:
>>>> > > debug=6
>>>> > > log_stderror=yes
>>>> > > log_facility=LOG_LOCAL0
>>>> > >
>>>> > > syslog.conf
>>>> > >
>>>> > > #opensips
>>>> > > local0.* -/var/log/opensips.log
>>>> > >
>>>> > >
>>>> > > Where could be a poroblem that opensips does not log?
>>>> > > Opensips.log is empty.
>>>> > >
>>>> > >
>>>> > >  Remove that '-' from the syslog.conf line, that
>>>> > prevents the matching entries from going there. It should
>>>> > look like this:
>>>> > >
>>>> > > #opensips
>>>> > > local0.* /var/log/opensips.log
>>>> > >
>>>> > >
>>>> > > Regards,
>>>> > >
>>>> > > PS: This applies to rsyslog.
>>>> > >
>>>> > > --
>>>> > > Saúl Ibarra Corretgé
>>>> > > AG Projects
>>>> > >
>>>> > >
>>>> > >
>>>> > >
>>>> > > _______________________________________________
>>>> > > Users mailing
>>>> >
>>>> [hidden email]lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>> > >
>>>> > >
>>>> > >
>>>> > > _______________________________________________
>>>> > > Users mailing list
>>>> > > [hidden email]
>>>> > >
>>>> > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>> > >
>>>> > >
>>>> >
>>>> >
>>>> > --
>>>> > Muhammad Shahzad
>>>> > -----------------------------------
>>>> > CISCO Rich Media Communication Specialist (CRMCS)
>>>> > CISCO Certified Network Associate (CCNA)
>>>> > Cell: +49 176 99 83 10 85
>>>> > MSN: [hidden email]
>>>> > Email: [hidden email]
>>>
>>>
>>
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>>
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users