MedaiProxy libiptc && libip4tc error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

MedaiProxy libiptc && libip4tc error

vivid333
Hello:

            why did error " No valid iptc library was found on the system. Please install iptables development libraries" happen?

1. My System Config is :
        [root@mail mediaproxy-2.5.1]# lsb_release -a
        LSB Version:    :core-4.0-amd64:core-4.0-ia32:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-ia32:graphics-4.0-noarch:printing-4.0-amd64:
                                printing-4.0-ia32:printing-4.0-noarch
        Distributor ID:    CentOS
        Description:    CentOS release 5.6 (Final)
        Release:    5.6
        Codename:    Final
        [root@mail mediaproxy-2.5.1]# uname -a
        Linux mail.xxxxxx.com 2.6.18-243.el5 #1 SMP Mon Feb 7 18:47:27 EST 2011 x86_64 x86_64 x86_64 GNU/Linux
   
2. Mediaproxy version:  2.5.1

3. Prerequisites
            yum install libnfnetlink   
            yum install libnfnetlink-devel
            yum install libnetfilter_conntrack-devel
            yum install iptables-devel.x86_64
           
4. [root@mail ~]# whereis libiptc
    libiptc: /usr/include/libiptc

    [root@mail mediaproxy-2.5.1]# ./setup.py build
    No valid iptc library was found on the system. Please install iptables development libraries.

       



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: MedaiProxy libiptc && libip4tc error

Saúl Ibarra Corretgé
Hi,

On Aug 26, 2011, at 5:56 AM, vivid333 wrote:

> Hello:
>
>             why did error " No valid iptc library was found on the system. Please install iptables development libraries" happen?
>
> 1. My System Config is :
>         [root@mail mediaproxy-2.5.1]# lsb_release -a
>         LSB Version:    :core-4.0-amd64:core-4.0-ia32:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-ia32:graphics-4.0-noarch:printing-4.0-amd64:
>                                 printing-4.0-ia32:printing-4.0-noarch
>         Distributor ID:    CentOS
>         Description:    CentOS release 5.6 (Final)
>         Release:    5.6
>         Codename:    Final
>         [root@mail mediaproxy-2.5.1]# uname -a
>         Linux mail.xxxxxx.com 2.6.18-243.el5 #1 SMP Mon Feb 7 18:47:27 EST 2011 x86_64 x86_64 x86_64 GNU/Linux
>    
> 2. Mediaproxy version:  2.5.1
>
> 3. Prerequisites
>             yum install libnfnetlink    
>             yum install libnfnetlink-devel
>             yum install libnetfilter_conntrack-devel
>             yum install iptables-devel.x86_64
>            
> 4. [root@mail ~]# whereis libiptc
>     libiptc: /usr/include/libiptc
>
>     [root@mail mediaproxy-2.5.1]# ./setup.py build
>     No valid iptc library was found on the system. Please install iptables development libraries.
>

CentOS 5 contains iptables libraries which are over 5 years old and we just can't support them anymore. If you want to run MediaProxy on CentOS you can either upgrade to CentOS 6 or use MediaProxy 2.4.4, which still works with the old libraries.


Regards,

--
Saúl Ibarra Corretgé
AG Projects




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users