MediaProxy v2.4.1 - Seems to require Python 2.5+

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

MediaProxy v2.4.1 - Seems to require Python 2.5+

Alan Frisch
The docs still say MP requires Python 2.4 or higher... but while
running this 2.4.1 on Python 2.4 I get the below popping up
occasionally.  Seems to be related to the use of the all() command in
the dispatcher.py script.  AFAIK this command is only available in
Python 2.5+.

Feb 28 04:06:22 pbx media-dispatcher[22137]: session with call_id
1788f21d256768406b6003580b516303@174.133.77.90 from relay 10.0.0.1 did
timeout
Feb 28 04:06:22 pbx media-dispatcher[22137]: Traceback (most recent call last):
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/twisted/python/log.py", line 51, in
callWithLogger
Feb 28 04:06:22 pbx media-dispatcher[22137]:     return
callWithContext({"system": lp}, func, *args, **kw)
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/twisted/python/log.py", line 36, in
callWithContext
Feb 28 04:06:22 pbx media-dispatcher[22137]:     return
context.call({ILogContext: newCtx}, func, *args, **kw)
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/twisted/python/context.py", line 59,
in callWithContext
Feb 28 04:06:22 pbx media-dispatcher[22137]:     return
self.currentContext().callWithContext(ctx, func, *args, **kw)
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/twisted/python/context.py", line 37,
in callWithContext
Feb 28 04:06:22 pbx media-dispatcher[22137]:     return func(*args,**kw)
Feb 28 04:06:22 pbx media-dispatcher[22137]: --- <exception caught here> ---
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/twisted/internet/selectreactor.py",
line 146, in _doReadOrWrite
Feb 28 04:06:22 pbx media-dispatcher[22137]:     why =
getattr(selectable, method)()
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/gnutls/interfaces/twisted/__init__.py",
line 82, in doRead
Feb 28 04:06:22 pbx media-dispatcher[22137]:     return
tcp.Connection.doRead(self)
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/twisted/internet/tcp.py", line 362,
in doRead
Feb 28 04:06:22 pbx media-dispatcher[22137]:     return
self.protocol.dataReceived(data)
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/twisted/protocols/basic.py", line
148, in dataReceived
Feb 28 04:06:22 pbx media-dispatcher[22137]:     self.lineReceived(line)
Feb 28 04:06:22 pbx media-dispatcher[22137]:   File
"/usr/lib/python2.4/site-packages/mediaproxy/dispatcher.py", line 273,
in lineReceived
Feb 28 04:06:22 pbx media-dispatcher[22137]:     all_streams_ice =
all(stream_info["status"] == "unselected ICE candidate" for
stream_info in stats["streams$
Feb 28 04:06:22 pbx media-dispatcher[22137]: exceptions.NameError:
global name 'all' is not defined
Feb 28 04:06:22 pbx media-dispatcher[22137]: error: Connection with
relay at 10.0.0.1 was lost: global name 'all' is not defined
Feb 28 04:06:22 pbx media-relay[22161]: error: Connection with
dispatcher at 10.0.0.1:25060 was lost: A TLS packet with unexpected
length was received.
Feb 28 04:06:22 pbx media-dispatcher[22137]: error: Relay for this
session (10.0.0.1) is no longer connected
Feb 28 04:06:23 pbx media-dispatcher[22137]: warning: user requested
media_relay 10.0.0.1 is not available
Feb 28 04:06:23 pbx media-dispatcher[22137]: error: No suitable relay found
Feb 28 04:06:23 pbx /usr/local/sbin/opensips[22182]:
ERROR:mediaproxy:use_media_proxy: mediaproxy returned error

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users