Multidomain TLS with opensips 3.1 part 2

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Multidomain TLS with opensips 3.1 part 2

xaled

Hi,

 

I got server and client tls config working in opensips.cfg and now trying to get it running with mysql DB.

 

I tried to use the latest opensips-cp (I know that 3.1 is not officially supported) to import client certificate data that I created using opensips-cli and getting a segfault.

 

Maybe I should try importing client cert from cli? What would be the correct way to import certificate in to mysql from linux shell?

 

9 02:29:30 test /usr/sbin/opensips[8551]: INFO:tls_mgm:init_tls_dom: Processing TLS domain 'test-cli'

Jul  9 02:29:30 test /usr/sbin/opensips[8551]: DBG:tls_mgm:init_tls_dom: no DH params file for tls domain 'test-cli' defined, using default '(null)'

Jul  9 02:29:30 test /usr/sbin/opensips[8551]: NOTICE:tls_mgm:init_tls_dom: No EC curve defined

Jul  9 02:29:30 test /usr/sbin/opensips[8551]: DBG:tls_mgm:init_tls_dom: cipher list null ... setting default

Jul  9 02:29:30 test /usr/sbin/opensips[8551]: INFO:tls_mgm:get_ssl_ctx_verify_mode: server verification activated.

Jul  9 02:29:30 test /usr/sbin/opensips[8551]: NOTICE:tls_mgm:init_tls_dom: no CA dir for tls 'test-cli' defined, using default '/etc/pki/CA/'

Jul  9 02:29:30 test /usr/sbin/opensips[8551]: NOTICE:tls_mgm:init_tls_dom: no crl for tls, using none

Jul  9 02:29:30 test /usr/sbin/opensips[8551]: DBG:core:count_module_procs: modules require 2 extra processes

Jul  9 02:29:30 test /usr/sbin/opensips[8551]: CRITICAL:core:sig_usr: segfault in attendant (starter) process!

 

Thanks,

Xaled


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users