New OpenXCAP release 1.1.1 (and collateral software)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

New OpenXCAP release 1.1.1 (and collateral software)

Adrian Georgescu
Hello,

There is a new release of OpenXCAP (1.1.1) and collateral software  
soap-simple-proxy (1.0.7), python-xcaplib (1.0.10) available.

These releases contain bug fixes discovered at the last SIPIT in Tokio  
and better compatibility with and checks for the software they depends  
upon.

To upgrade your debian unstable installation:

apt-get update
apt-get install openxcap
apt-get install soap-simple-proxy
apt-get install python-xcapclient

Or download the tar files from:

http://download.ag-projects.com/XCAP/

Changelogs

openxcap (1.1.1) unstable; urgency=low

   * Merged the ThorNode section of the configuration file into  
ThorNetwork
   * Fixed config.ini.sample to fit in 80 chars width
   * Better TLS defaults in the sample configuration file
   * Better logging of exceptions in the script
   * Adapted code to the latest API changes in python-application 1.1.5
   * Fixed handling of XMLRPC errors in publish_xcapdiff of OpenSIPS  
interface
   * Fixed lintian warning about missing misc:Depends
   * Fixed default value for ServerConfig.applications setting
   * Removed unused config file
   * Updated include and prune lists in MANIFEST.in
   * Fixed backend config setting default type
   * Removed unused imports
   * Simplified and updated debian build dependencies
   * Updated requirements in INSTALL
   * Updated debian dependencies
   * Simplified dependency checking by using the  
application.dependency module
   * Changed how the system config directory is set to use latest API
   * Updated Python dependency to 2.5 in INSTALL
   * Moved todo items to wiki tickets
   * Update copyright text
   * Bumped standards version and version for python-application
   * Fixed reading OpenSIPS xmplrpc_url config option
   * Added version check for python-application on startup
   * Removed _datatypes attribute from ConfigSection subsclasses
   * Reverted classmethods of ConfigSection class to functions
   * Removed ConfigFile.read_settings() overriden method
   * Made "algorithm"/"stale" unquoting patch Python 2.4 compatible
   * Make "algorithm" and "stale" header parameters not quoted
   * Restart software on debian upgrade

soap-simple-proxy (1.0.7) unstable; urgency=low

   * Replaced python-all-dev build dependency with python
   * Fixed use of process.system_config_directory
   * Removed workaround for python < 2.3
   * Adapted configuration to python-application >= 1.1.5
   * Added dependency checks in script
   * Added dependency on python-application >= 1.1.5 in debian/control
   * Bumped Standards-Version to 3.8.2
   * Fixed ServiceURL configuration datatype and the default values  
using it

soap-simple-proxy (1.0.6) unstable; urgency=low

   * Fixed XCAPClient to allow both digest and basic authentication
   * Added LSB header to init script
   * Added misc:Depends dependency to fix lintian warning
   * Replaced call to deprecated startSyslog with start_syslog
   * Redirected stderr to stdout to fix display of SOAPpy messages
   * Changed to python-support
   * Changed order of includes in debian/rules to make cdbs happy
   * Removed restriction of not starting application at installation
   * Removed deprecated control fields in favor of debian/pyversions
   * Added Lucian Stanescu to uploaders list
   * Updated copyright notice
   * Bumped Standards-Version to 3.8.1

soap-simple-proxy (1.0.5) unstable; urgency=low

   * Changed a lxml argument from positional to keyword

soap-simple-proxy (1.0.4) unstable; urgency=low

   * Added XCAPError exception which relays non 2xx/404 responses from  
OpenXCAP
     to the SOAP client

python-xcaplib (1.0.10) unstable; urgency=low

   * Added 'sip:' prefix to XUI
   * Fixed handling of bodyless error responses
   * Fixed handling of configuration data for python-application >=  
1.1.2
   * Replaced use of deprecated _datatypes attribute with ConfigSetting
   * Added dependency on python-application >= 1.1.4
   * Replaced python-all-dev build dependency with python
   * Bumped Standards-Version to 3.8.2
   * Added ${misc:Depends} to debian/control
   * Replaced use of deprecated ConfigFile.read_settings with  
ConfigSection.read


Regards,
Adrian


_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel
Reply | Threaded
Open this post in threaded view
|

Re: [OpenSIPS-Users] New OpenXCAP release 1.1.1 (and collateral software)

Thiago Rondon

When I update the software (and config.ini too) :

Starting OpenXCAP server:
openxcap/usr/lib/pymodules/python2.5/application/configuration/__init__.py:52:
DeprecationWarning: read_settings is deprecated in favor of using
ConfigSection.read and will be removed in 1.2.0.
  warn("read_settings is deprecated in favor of using ConfigSection.read
and will be removed in 1.2.0.", DeprecationWarning)

-Thiago Rondon

Adrian Georgescu escreveu:

> Hello,
>
> There is a new release of OpenXCAP (1.1.1) and collateral software  
> soap-simple-proxy (1.0.7), python-xcaplib (1.0.10) available.
>
> These releases contain bug fixes discovered at the last SIPIT in Tokio  
> and better compatibility with and checks for the software they depends  
> upon.
>
> To upgrade your debian unstable installation:
>
> apt-get update
> apt-get install openxcap
> apt-get install soap-simple-proxy
> apt-get install python-xcapclient
>
> Or download the tar files from:
>
> http://download.ag-projects.com/XCAP/
>
> Changelogs
>
> openxcap (1.1.1) unstable; urgency=low
>
>    * Merged the ThorNode section of the configuration file into  
> ThorNetwork
>    * Fixed config.ini.sample to fit in 80 chars width
>    * Better TLS defaults in the sample configuration file
>    * Better logging of exceptions in the script
>    * Adapted code to the latest API changes in python-application 1.1.5
>    * Fixed handling of XMLRPC errors in publish_xcapdiff of OpenSIPS  
> interface
>    * Fixed lintian warning about missing misc:Depends
>    * Fixed default value for ServerConfig.applications setting
>    * Removed unused config file
>    * Updated include and prune lists in MANIFEST.in
>    * Fixed backend config setting default type
>    * Removed unused imports
>    * Simplified and updated debian build dependencies
>    * Updated requirements in INSTALL
>    * Updated debian dependencies
>    * Simplified dependency checking by using the  
> application.dependency module
>    * Changed how the system config directory is set to use latest API
>    * Updated Python dependency to 2.5 in INSTALL
>    * Moved todo items to wiki tickets
>    * Update copyright text
>    * Bumped standards version and version for python-application
>    * Fixed reading OpenSIPS xmplrpc_url config option
>    * Added version check for python-application on startup
>    * Removed _datatypes attribute from ConfigSection subsclasses
>    * Reverted classmethods of ConfigSection class to functions
>    * Removed ConfigFile.read_settings() overriden method
>    * Made "algorithm"/"stale" unquoting patch Python 2.4 compatible
>    * Make "algorithm" and "stale" header parameters not quoted
>    * Restart software on debian upgrade
>
> soap-simple-proxy (1.0.7) unstable; urgency=low
>
>    * Replaced python-all-dev build dependency with python
>    * Fixed use of process.system_config_directory
>    * Removed workaround for python < 2.3
>    * Adapted configuration to python-application >= 1.1.5
>    * Added dependency checks in script
>    * Added dependency on python-application >= 1.1.5 in debian/control
>    * Bumped Standards-Version to 3.8.2
>    * Fixed ServiceURL configuration datatype and the default values  
> using it
>
> soap-simple-proxy (1.0.6) unstable; urgency=low
>
>    * Fixed XCAPClient to allow both digest and basic authentication
>    * Added LSB header to init script
>    * Added misc:Depends dependency to fix lintian warning
>    * Replaced call to deprecated startSyslog with start_syslog
>    * Redirected stderr to stdout to fix display of SOAPpy messages
>    * Changed to python-support
>    * Changed order of includes in debian/rules to make cdbs happy
>    * Removed restriction of not starting application at installation
>    * Removed deprecated control fields in favor of debian/pyversions
>    * Added Lucian Stanescu to uploaders list
>    * Updated copyright notice
>    * Bumped Standards-Version to 3.8.1
>
> soap-simple-proxy (1.0.5) unstable; urgency=low
>
>    * Changed a lxml argument from positional to keyword
>
> soap-simple-proxy (1.0.4) unstable; urgency=low
>
>    * Added XCAPError exception which relays non 2xx/404 responses from  
> OpenXCAP
>      to the SOAP client
>
> python-xcaplib (1.0.10) unstable; urgency=low
>
>    * Added 'sip:' prefix to XUI
>    * Fixed handling of bodyless error responses
>    * Fixed handling of configuration data for python-application >=  
> 1.1.2
>    * Replaced use of deprecated _datatypes attribute with ConfigSetting
>    * Added dependency on python-application >= 1.1.4
>    * Replaced python-all-dev build dependency with python
>    * Bumped Standards-Version to 3.8.2
>    * Added ${misc:Depends} to debian/control
>    * Replaced use of deprecated ConfigFile.read_settings with  
> ConfigSection.read
>
>
> Regards,
> Adrian
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
>  


_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel
Reply | Threaded
Open this post in threaded view
|

Re: [OpenSIPS-Users] New OpenXCAP release 1.1.1 (and collateral software )

Dan Pascu
On Tuesday 04 August 2009, Thiago Rondon wrote:
>
> When I update the software (and config.ini too) :
>
> Starting OpenXCAP server:
>
openxcap/usr/lib/pymodules/python2.5/application/configuration/__init__.py:52:
> DeprecationWarning: read_settings is deprecated in favor of using
> ConfigSection.read and will be removed in 1.2.0.
>   warn("read_settings is deprecated in favor of using ConfigSection.read
> and will be removed in 1.2.0.", DeprecationWarning)

It appears you upgraded python-application, but you're still running an old
openxcap. Try running:

openxcap --version
which openxcap

to figure out what's going on. Also try to run it on the console see if you
see the same message: sudo openxcap --no-fork

Otherwise the warning is harmless. It only means that the version of openxcap
you're running was not upgraded to use the new API in python-application, but
it's working fine nonetheless.

--
Dan

_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel