OPENSIPS not starting up

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

OPENSIPS not starting up

Premalatha Kuppan
Hi,

Iam new to OpenSIPS. Using latest version 1.6.2.

My MySQL server is on seperate machine.

When i run OpensISPS, iam getting the following error,

/etc/init.d/opensips start
chown: `opensips:opensips': invalid user

Please help.

I appreciate your valuable input asap.

Thanks,
Prem


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OPENSIPS not starting up

Max Mühlbronner
Hi,

i think this happens because the user "opensips" is missing on your system.

For a Debian System you could easily adjust the values USER= / GROUP=  
in /etc/default/opensips.
Or you could create the user and group "opensips" on your system first.
(if you want to use this group/userid).

Hope this helps.


Max M.

Premalatha Kuppan schrieb:

> Hi,
>
> Iam new to OpenSIPS. Using latest version 1.6.2.
>
> My MySQL server is on seperate machine.
>
> When i run OpensISPS, iam getting the following error,
>
> /etc/init.d/opensips start
> *chown: `opensips:opensips': invalid user
>
> *Please help.
>
> I appreciate your valuable input asap.
>
> Thanks,
> Prem*
> *
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OPENSIPS not starting up

Premalatha Kuppan
Thanks you.

I have created a user and group, the following problem is solved.

But facing other issues,

/etc/init.d/opensips start
Starting opensips: opensips/etc/init.d/opensips: line 117: start-stop-daemon: command not found
 already running.

Iam using RHEL, do redhat uses start-stop daemon ?

Please help.

On Thu, May 20, 2010 at 5:47 PM, Max Mühlbronner <[hidden email]> wrote:
Hi,

i think this happens because the user "opensips" is missing on your system.

For a Debian System you could easily adjust the values USER= / GROUP=
in /etc/default/opensips.
Or you could create the user and group "opensips" on your system first.
(if you want to use this group/userid).

Hope this helps.


Max M.

Premalatha Kuppan schrieb:
> Hi,
>
> Iam new to OpenSIPS. Using latest version 1.6.2.
>
> My MySQL server is on seperate machine.
>
> When i run OpensISPS, iam getting the following error,
>
> /etc/init.d/opensips start
> *chown: `opensips:opensips': invalid user
>
> *Please help.
>
> I appreciate your valuable input asap.
>
> Thanks,
> Prem*
> *
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OPENSIPS not starting up

Bogdan-Andrei Iancu
Hi Premalatha,

I guess you are using the debian speciafic script (which of course does
not work on redhat)

Better use :  packaging/rpm/opensips.init

Regards,
Bogdan

Premalatha Kuppan wrote:

> Thanks you.
>
> I have created a user and group, the following problem is solved.
>
> But facing other issues,
>
> /etc/init.d/opensips start
> Starting opensips: opensips/etc/init.d/opensips: line 117:
> *start-stop-daemon: command not found*
>  already running.
>
> Iam using RHEL, do redhat uses start-stop daemon ?
>
> Please help.
>
> On Thu, May 20, 2010 at 5:47 PM, Max Mühlbronner <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hi,
>
>     i think this happens because the user "opensips" is missing on
>     your system.
>
>     For a Debian System you could easily adjust the values USER= / GROUP=
>     in /etc/default/opensips.
>     Or you could create the user and group "opensips" on your system
>     first.
>     (if you want to use this group/userid).
>
>     Hope this helps.
>
>
>     Max M.
>
>     Premalatha Kuppan schrieb:
>     > Hi,
>     >
>     > Iam new to OpenSIPS. Using latest version 1.6.2.
>     >
>     > My MySQL server is on seperate machine.
>     >
>     > When i run OpensISPS, iam getting the following error,
>     >
>     > /etc/init.d/opensips start
>     > *chown: `opensips:opensips': invalid user
>     >
>     > *Please help.
>     >
>     > I appreciate your valuable input asap.
>     >
>     > Thanks,
>     > Prem*
>     > *
>     >
>     ------------------------------------------------------------------------
>     >
>     > _______________________________________________
>     > Users mailing list
>     > [hidden email] <mailto:[hidden email]>
>     > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>     >
>
>
>     _______________________________________________
>     Users mailing list
>     [hidden email] <mailto:[hidden email]>
>     http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


--
Bogdan-Andrei Iancu
www.voice-system.ro


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OPENSIPS not starting up

Premalatha Kuppan
Thanks Bogdan.

I have copied the opensips.init and opensips.default from packaging/rpm. But still, facing below prb,

 I dono from where 10.10.1.14 is filled for udp listen IP? Any help ?


May 25 05:07:56 204548-4 opensips: DBG:core:socket2str: <udp:127.0.0.1:5060>
May 25 05:07:56 204548-4 opensips: DBG:core:socket2str: <udp:10.140.1.110:5060>
May 25 05:08:36 204548-4 opensips: WARNING:core:fix_socket_list: could not rev. resolve 10.10.1.14
May 25 05:08:36 204548-4 opensips: DBG:core:socket2str: <udp:10.10.1.14:5060>

May 25 05:08:36 204548-4 opensips: DBG:core:socket2str: <udp:204.12.57.221:5060>
May 25 05:08:36 204548-4 opensips: DBG:core:socket2str: <tcp:127.0.0.1:5060>
May 25 05:08:36 204548-4 opensips: DBG:core:socket2str: <tcp:10.140.1.110:5060>
May 25 05:09:16 204548-4 opensips: WARNING:core:fix_socket_list: could not rev. resolve 10.10.1.14
May 25 05:09:16 204548-4 opensips: DBG:core:socket2str: <tcp:10.10.1.14:5060>
May 25 05:09:16 204548-4 opensips: DBG:core:socket2str: <tcp:204.12.57.221:5060>
May 25 05:09:16 204548-4 opensips: DBG:core:fm_malloc_init: F_OPTIMIZE=16384, /ROUNDTO=2048
May 25 05:09:16 204548-4 opensips: DBG:core:fm_malloc_init: F_HASH_SIZE=2099, fm_block size=33648
May 25 05:09:16 204548-4 opensips: DBG:core:fm_malloc_init: params (0x2af2311c2000, 134217728), start=0x2af2311c2000
May 25 05:09:16 204548-4 opensips: DBG:core:shm_mem_init_mallocs: success
May 25 05:09:16 204548-4 opensips: INFO:core:init_tcp: using epoll_lt as the TCP io watch method (auto detected)
May 25 05:09:16 204548-4 /usr/local/sbin/opensips[5953]: DBG:core:set_core_dump: core dump limits set to 18446744073709551615

I have one more doubt, I have seen your


On Fri, May 21, 2010 at 8:34 PM, Bogdan-Andrei Iancu <[hidden email]> wrote:
Hi Premalatha,

I guess you are using the debian speciafic script (which of course does
not work on redhat)

Better use :  packaging/rpm/opensips.init

Regards,
Bogdan

Premalatha Kuppan wrote:
> Thanks you.
>
> I have created a user and group, the following problem is solved.
>
> But facing other issues,
>
> /etc/init.d/opensips start
> Starting opensips: opensips/etc/init.d/opensips: line 117:
> *start-stop-daemon: command not found*
>  already running.
>
> Iam using RHEL, do redhat uses start-stop daemon ?
>
> Please help.
>
> On Thu, May 20, 2010 at 5:47 PM, Max Mühlbronner <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hi,
>
>     i think this happens because the user "opensips" is missing on
>     your system.
>
>     For a Debian System you could easily adjust the values USER= / GROUP=
>     in /etc/default/opensips.
>     Or you could create the user and group "opensips" on your system
>     first.
>     (if you want to use this group/userid).
>
>     Hope this helps.
>
>
>     Max M.
>
>     Premalatha Kuppan schrieb:
>     > Hi,
>     >
>     > Iam new to OpenSIPS. Using latest version 1.6.2.
>     >
>     > My MySQL server is on seperate machine.
>     >
>     > When i run OpensISPS, iam getting the following error,
>     >
>     > /etc/init.d/opensips start
>     > *chown: `opensips:opensips': invalid user
>     >
>     > *Please help.
>     >
>     > I appreciate your valuable input asap.
>     >
>     > Thanks,
>     > Prem*
>     > *
>     >
>     ------------------------------------------------------------------------
>     >
>     > _______________________________________________
>     > Users mailing list
>     > [hidden email] <mailto:[hidden email]>
>     > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>     >
>
>
>     _______________________________________________
>     Users mailing list
>     [hidden email] <mailto:[hidden email]>
>     http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>


--
Bogdan-Andrei Iancu
www.voice-system.ro


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OPENSIPS not starting up

Bogdan-Andrei Iancu
Hi Premalatha,

Premalatha Kuppan wrote:
> Thanks Bogdan.
>
> I have copied the opensips.init and opensips.default from
> packaging/rpm. But still, facing below prb,
>
>  I dono from where 10.10.1.14 is filled for udp listen IP? Any help ?
check the cfg for explicit "listen" params. If none (interface auto
detection) it mean you have 10.10.1.14 as interface or DNS record for
the name of the machine.

I strongly suggest you to fill in an explicit "listen=udp:IP:port" param
in cfg.

>
>
> May 25 05:07:56 204548-4 opensips: DBG:core:socket2str:
> <udp:127.0.0.1:5060 <http://127.0.0.1:5060>>
> May 25 05:07:56 204548-4 opensips: DBG:core:socket2str:
> <udp:10.140.1.110:5060 <http://10.140.1.110:5060>>
> *May 25 05:08:36 204548-4 opensips: WARNING:core:fix_socket_list:
> could not rev. resolve 10.10.1.14
> May 25 05:08:36 204548-4 opensips: DBG:core:socket2str:
> <udp:10.10.1.14:5060 <http://10.10.1.14:5060>> *
> May 25 05:08:36 204548-4 opensips: DBG:core:socket2str:
> <udp:204.12.57.221:5060 <http://204.12.57.221:5060>>
> May 25 05:08:36 204548-4 opensips: DBG:core:socket2str:
> <tcp:127.0.0.1:5060 <http://127.0.0.1:5060>>
> May 25 05:08:36 204548-4 opensips: DBG:core:socket2str:
> <tcp:10.140.1.110:5060 <http://10.140.1.110:5060>>
> May 25 05:09:16 204548-4 opensips: WARNING:core:fix_socket_list: could
> not rev. resolve 10.10.1.14
> May 25 05:09:16 204548-4 opensips: DBG:core:socket2str:
> <tcp:10.10.1.14:5060 <http://10.10.1.14:5060>>
> May 25 05:09:16 204548-4 opensips: DBG:core:socket2str:
> <tcp:204.12.57.221:5060 <http://204.12.57.221:5060>>
> May 25 05:09:16 204548-4 opensips: DBG:core:fm_malloc_init:
> F_OPTIMIZE=16384, /ROUNDTO=2048
> May 25 05:09:16 204548-4 opensips: DBG:core:fm_malloc_init:
> F_HASH_SIZE=2099, fm_block size=33648
> May 25 05:09:16 204548-4 opensips: DBG:core:fm_malloc_init: params
> (0x2af2311c2000, 134217728), start=0x2af2311c2000
> May 25 05:09:16 204548-4 opensips: DBG:core:shm_mem_init_mallocs: success
> May 25 05:09:16 204548-4 opensips: INFO:core:init_tcp: using epoll_lt
> as the TCP io watch method (auto detected)
> May 25 05:09:16 204548-4 /usr/local/sbin/opensips[5953]:
> DBG:core:set_core_dump: core dump limits set to 18446744073709551615
>
> I have one more doubt, I have seen your
my what :) ?

Regards,
Bogdan

>
>
> On Fri, May 21, 2010 at 8:34 PM, Bogdan-Andrei Iancu
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Hi Premalatha,
>
>     I guess you are using the debian speciafic script (which of course
>     does
>     not work on redhat)
>
>     Better use :  packaging/rpm/opensips.init
>
>     Regards,
>     Bogdan
>
>     Premalatha Kuppan wrote:
>     > Thanks you.
>     >
>     > I have created a user and group, the following problem is solved.
>     >
>     > But facing other issues,
>     >
>     > /etc/init.d/opensips start
>     > Starting opensips: opensips/etc/init.d/opensips: line 117:
>     > *start-stop-daemon: command not found*
>     >  already running.
>     >
>     > Iam using RHEL, do redhat uses start-stop daemon ?
>     >
>     > Please help.
>     >
>     > On Thu, May 20, 2010 at 5:47 PM, Max Mühlbronner <[hidden email]
>     <mailto:[hidden email]>
>     > <mailto:[hidden email] <mailto:[hidden email]>>> wrote:
>     >
>     >     Hi,
>     >
>     >     i think this happens because the user "opensips" is missing on
>     >     your system.
>     >
>     >     For a Debian System you could easily adjust the values USER=
>     / GROUP=
>     >     in /etc/default/opensips.
>     >     Or you could create the user and group "opensips" on your system
>     >     first.
>     >     (if you want to use this group/userid).
>     >
>     >     Hope this helps.
>     >
>     >
>     >     Max M.
>     >
>     >     Premalatha Kuppan schrieb:
>     >     > Hi,
>     >     >
>     >     > Iam new to OpenSIPS. Using latest version 1.6.2.
>     >     >
>     >     > My MySQL server is on seperate machine.
>     >     >
>     >     > When i run OpensISPS, iam getting the following error,
>     >     >
>     >     > /etc/init.d/opensips start
>     >     > *chown: `opensips:opensips': invalid user
>     >     >
>     >     > *Please help.
>     >     >
>     >     > I appreciate your valuable input asap.
>     >     >
>     >     > Thanks,
>     >     > Prem*
>     >     > *
>     >     >
>     >    
>     ------------------------------------------------------------------------
>     >     >
>     >     > _______________________________________________
>     >     > Users mailing list
>     >     > [hidden email] <mailto:[hidden email]>
>     <mailto:[hidden email] <mailto:[hidden email]>>
>     >     > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>     >     >
>     >
>     >
>     >     _______________________________________________
>     >     Users mailing list
>     >     [hidden email] <mailto:[hidden email]>
>     <mailto:[hidden email] <mailto:[hidden email]>>
>     >     http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>     >
>     >
>     >
>     ------------------------------------------------------------------------
>     >
>     > _______________________________________________
>     > Users mailing list
>     > [hidden email] <mailto:[hidden email]>
>     > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>     >
>
>
>     --
>     Bogdan-Andrei Iancu
>     www.voice-system.ro <http://www.voice-system.ro>
>
>
>     _______________________________________________
>     Users mailing list
>     [hidden email] <mailto:[hidden email]>
>     http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


--
Bogdan-Andrei Iancu
www.voice-system.ro


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users