OpenSIP 1.4.2 / 1.6.2 release

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSIP 1.4.2 / 1.6.2 release

venkateswararao regula
Hi All !
 
I was running Opensipserver version 1.4.2 past 2 years without any problem.
 
The topology is
UE1(v6) ---------------->(v6)SIPProxy(v4)------------->(v4)OpenSer(v4)----------->(v4)SIPProxy(v6)------------->(v6)UE2
 
The problem started with UE orginating from IPV6 address and trying to register with Opensip server running on IPV4 address. The registration works fine, problem creeps up with Invite message from Caller, the invite response is throwing "477 send failed(477/TM)" .
 
The following SIP call flow events on Callee leg... 100 Trying, 180 ringing, 200 OK are showing up good.
 
 
The Log Messages indicate the following:
 
 
Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: new branch at sip:410001@[3ffe::2:0:e9ff:fee0:8ced];EriBindingId=6
Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: ERROR:core:udp_send: sendto(sock,0x2b8fcfcb7cc0,1053,0,0x2b8fcfcb4b40,28): Address family not supported by protocol(97)
Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: ERROR:tm:msg_send: udp_send failed
Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: ERROR:tm:t_forward_nonack: sending request failed
Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: ACC: call missed: timestamp=1275934320;method=INVITE;from_tag=h7g4Esbg_42AA5AB;to_tag=;call_id=18f4a901@3ffe::1:0:28ff:fe88:8b81;code=477;reason=Request Failure
 
Apprciate the help in fixing this problem.
 
 
Thanks,
Rvrao

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSIP 1.4.2 / 1.6.2 release

Max Mühlbronner
Hi,

I would try to use something like this, although i have not tested it
yet and have not found any similar info. But i think force_send_socket
could take an ipv6 socket as an argument? So if it is ipv6 you would
send out via the correct socket? Maybe i am wrong, i can´t find any
documentation/info whether or not this is correct?

 if(af==INET6) {

        force_send_socket(ipv6address:5060);

    };




BR

Max M.


venkateswararao regula schrieb:

> Hi All !
>  
> I was running Opensipserver version 1.4.2 past 2 years without any
> problem.
>  
> The topology is
> UE1(v6)
> ---------------->(v6)SIPProxy(v4)------------->(v4)OpenSer(v4)----------->(v4)SIPProxy(v6)------------->(v6)UE2
>  
> The problem started with UE orginating from IPV6 address and trying to
> register with Opensip server running on IPV4 address. The registration
> works fine, problem creeps up with Invite message from Caller, the
> invite response is throwing "477 send failed(477/TM)" .
>  
> The following SIP call flow events on Callee leg... 100 Trying, 180
> ringing, 200 OK are showing up good.
>  
>  
> The Log Messages indicate the following:
>  
>  
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: new
> branch at sip:410001@[3ffe::2:0:e9ff:fee0:8ced];EriBindingId=6
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:core:udp_send:
> sendto(sock,0x2b8fcfcb7cc0,1053,0,0x2b8fcfcb4b40,28): Address family
> not supported by protocol(97)
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:tm:msg_send: udp_send failed
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:tm:t_forward_nonack: sending request failed
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: ACC: call
> missed:
> timestamp=1275934320;method=INVITE;from_tag=h7g4Esbg_42AA5AB;to_tag=;call_id=18f4a901@3ffe::1:0:28ff:fe88:8b81;code=477;reason=Request
> Failure
>  
> Apprciate the help in fixing this problem.
>  
>  
> Thanks,
> Rvrao
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSIP 1.4.2 / 1.6.2 release

venkateswararao regula
Hi BR !
 
Thanks for your updates.
 
Can you please point me to appropriate file to be modified and verified.
 
Thanks,
Rvrao

On Tue, Jun 8, 2010 at 7:43 AM, Max Mühlbronner <[hidden email]> wrote:
Hi,

I would try to use something like this, although i have not tested it
yet and have not found any similar info. But i think force_send_socket
could take an ipv6 socket as an argument? So if it is ipv6 you would
send out via the correct socket? Maybe i am wrong, i can´t find any
documentation/info whether or not this is correct?

 if(af==INET6) {

       force_send_socket(ipv6address:5060);

   };




BR

Max M.


venkateswararao regula schrieb:
> Hi All !
>
> I was running Opensipserver version 1.4.2 past 2 years without any
> problem.
>
> The topology is
> UE1(v6)
> ---------------->(v6)SIPProxy(v4)------------->(v4)OpenSer(v4)----------->(v4)SIPProxy(v6)------------->(v6)UE2
>
> The problem started with UE orginating from IPV6 address and trying to
> register with Opensip server running on IPV4 address. The registration
> works fine, problem creeps up with Invite message from Caller, the
> invite response is throwing "477 send failed(477/TM)" .
>
> The following SIP call flow events on Callee leg... 100 Trying, 180
> ringing, 200 OK are showing up good.
>
>
> The Log Messages indicate the following:
>
>
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: new
> branch at sip:410001@[3ffe::2:0:e9ff:fee0:8ced];EriBindingId=6
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:core:udp_send:
> sendto(sock,0x2b8fcfcb7cc0,1053,0,0x2b8fcfcb4b40,28): Address family
> not supported by protocol(97)
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:tm:msg_send: udp_send failed
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:tm:t_forward_nonack: sending request failed
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: ACC: call
> missed:
> timestamp=1275934320;method=INVITE;from_tag=h7g4Esbg_42AA5AB;to_tag=;call_id=18f4a901@3ffe::1:0:28ff:fe88:8b81;code=477;reason=Request
> Failure
>
> Apprciate the help in fixing this problem.
>
>
> Thanks,
> Rvrao
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSIP 1.4.2 / 1.6.2 release

Bogdan-Andrei Iancu
In reply to this post by venkateswararao regula
Hi Rvrao,

try setting the global param "mhomed=1"

Regards,
Bogdan

venkateswararao regula wrote:

> Hi All !
>  
> I was running Opensipserver version 1.4.2 past 2 years without any
> problem.
>  
> The topology is
> UE1(v6)
> ---------------->(v6)SIPProxy(v4)------------->(v4)OpenSer(v4)----------->(v4)SIPProxy(v6)------------->(v6)UE2
>  
> The problem started with UE orginating from IPV6 address and trying to
> register with Opensip server running on IPV4 address. The registration
> works fine, problem creeps up with Invite message from Caller, the
> invite response is throwing "477 send failed(477/TM)" .
>  
> The following SIP call flow events on Callee leg... 100 Trying, 180
> ringing, 200 OK are showing up good.
>  
>  
> The Log Messages indicate the following:
>  
>  
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: new
> branch at sip:410001@[3ffe::2:0:e9ff:fee0:8ced];EriBindingId=6
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:core:udp_send:
> sendto(sock,0x2b8fcfcb7cc0,1053,0,0x2b8fcfcb4b40,28): Address family
> not supported by protocol(97)
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:tm:msg_send: udp_send failed
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]:
> ERROR:tm:t_forward_nonack: sending request failed
> Jun  7 11:12:00 sys-pc2-new /usr/local/sbin/opensips[13248]: ACC: call
> missed:
> timestamp=1275934320;method=INVITE;from_tag=h7g4Esbg_42AA5AB;to_tag=;call_id=18f4a901@3ffe::1:0:28ff:fe88:8b81;code=477;reason=Request
> Failure
>  
> Apprciate the help in fixing this problem.
>  
>  
> Thanks,
> Rvrao
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


--
Bogdan-Andrei Iancu
www.voice-system.ro


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users