OpenSIPS 1.5 gives ERROR:core:init_mod: failed to initialize module registrar

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSIPS 1.5 gives ERROR:core:init_mod: failed to initialize module registrar

VoIPRookie
OpenSIPS is not running due to errors, these errors are about
registrar.so. The error occurs on starting opensips. I have 64bit box
running ubuntu server, all the dependencies were installed before
installing OpenSIPS, earlier i removed version 1.4.4 due to several
crashes.

Following is the link to screen output / opensips.cfg file :
http://pastebin.com/m738bb3f8

The highlighted portion is the error part, I can not pin point the
problem area, so please help me resolve this issue.
I am new to this environment so i need all the help i can get.


Thank you in advance for your time...


Khan

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSIPS 1.5 gives ERROR:core:init_mod: failed to initialize module registrar

Sergio Gutierrez
Hello Khan

After some changes in API in OpenSIPS, a new module was developed which export some functions which are required by other modules, for example registrar.

You must load modules in this order.

tm
sl
signaling

It would correct your problem.

Feel free to ask further questions.

Regards.

Sergio

On Tue, Mar 31, 2009 at 11:44 PM, Khan <[hidden email]> wrote:
OpenSIPS is not running due to errors, these errors are about
registrar.so. The error occurs on starting opensips. I have 64bit box
running ubuntu server, all the dependencies were installed before
installing OpenSIPS, earlier i removed version 1.4.4 due to several
crashes.

Following is the link to screen output / opensips.cfg file :
http://pastebin.com/m738bb3f8

The highlighted portion is the error part, I can not pin point the
problem area, so please help me resolve this issue.
I am new to this environment so i need all the help i can get.


Thank you in advance for your time...


Khan

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
Sergio Gutiérrez

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSIPS 1.5 gives ERROR:core:init_mod: failed to initialize module registrar

Sergio Gutierrez
Hello Khan.

I miss to mention; those modules must be loaded previous to registrar module

Regards.

Sergio

On Tue, Mar 31, 2009 at 11:52 PM, Sergio Gutierrez <[hidden email]> wrote:
Hello Khan

After some changes in API in OpenSIPS, a new module was developed which export some functions which are required by other modules, for example registrar.

You must load modules in this order.

tm
sl
signaling

It would correct your problem.

Feel free to ask further questions.

Regards.

Sergio


On Tue, Mar 31, 2009 at 11:44 PM, Khan <[hidden email]> wrote:
OpenSIPS is not running due to errors, these errors are about
registrar.so. The error occurs on starting opensips. I have 64bit box
running ubuntu server, all the dependencies were installed before
installing OpenSIPS, earlier i removed version 1.4.4 due to several
crashes.

Following is the link to screen output / opensips.cfg file :
http://pastebin.com/m738bb3f8

The highlighted portion is the error part, I can not pin point the
problem area, so please help me resolve this issue.
I am new to this environment so i need all the help i can get.


Thank you in advance for your time...


Khan

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
Sergio Gutiérrez



--
Sergio Gutiérrez

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSIPS 1.5 gives ERROR:core:init_mod: failed to initialize module registrar

Bogdan-Andrei Iancu
In reply to this post by VoIPRookie
Hi Khan,

Sergio is right - there are some changes from 1.4 to 1.5 - what changes
are required in order to migrate from 1.4 to 1.5 are documented here:
    http://www.opensips.org/index.php?n=Resources.DocsMigration14to15

and this is your particular case:
    http://www.opensips.org/index.php?n=Resources.DocsMigration14to15#toc5

Regards,
Bogdan

Khan wrote:

> OpenSIPS is not running due to errors, these errors are about
> registrar.so. The error occurs on starting opensips. I have 64bit box
> running ubuntu server, all the dependencies were installed before
> installing OpenSIPS, earlier i removed version 1.4.4 due to several
> crashes.
>
> Following is the link to screen output / opensips.cfg file :
> http://pastebin.com/m738bb3f8
>
> The highlighted portion is the error part, I can not pin point the
> problem area, so please help me resolve this issue.
> I am new to this environment so i need all the help i can get.
>
>
> Thank you in advance for your time...
>
>
> Khan
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users