OpenSIPS Dependencies Installation

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

OpenSIPS Dependencies Installation

JustForVoip

Hello,

I'm trying to install OPENSIPS on my virtual machine. However, I faced some issues and honestly I do not know if theses issues are related to my weakness in OpensSIPS, Linux, or both :(

I followed the following:

1- apt-get update

For dependencies:

2- apt-get install gcc bison flex make openssl libmysqlclient-dev perl libdbi-perl libdbd-mysql-perl libdbd-pg-perl libfrontier-rpc-perl libterm-readline-gnu-perl libberkeleydb-perl mysql-server ssh libxml2 libxml2-dev libxmlrpc-core-c3-dev libpcre3 libpcre3-dev subversion libncurses5-dev git ngrep libssl-dev

But I'm getting some errors about some dependencies.

Could you please advise, how I can know the right dependency that I should use?

Thanks in advance
_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenSIPS Dependencies Installation

Alexander Jankowsky

Are you installing Linux from a CD-DVD set or an Network install CD.
I solved a few problems by installing from a Network install CD.

Nearly everyone will ask you to list exactly which dependencies are getting errors.

If you can find an old or dedicated spare computer for a complete clean Linux install.
You might solve a few problems, in that way and might create some new problems!

Alex

-----Original Message-----
From: Users [mailto:[hidden email]] On Behalf Of Voice TAC
Sent: Saturday, 3 June 2017 8:01 PM
To: [hidden email]
Subject: [OpenSIPS-Users] OpenSIPS Dependencies Installation


Hello,

I'm trying to install OPENSIPS on my virtual machine. However, I faced some issues and honestly I do not know if theses issues are related to my weakness in OpensSIPS, Linux, or both :(

I followed the following:

1- apt-get update

For dependencies:

2- apt-get install gcc bison flex make openssl libmysqlclient-dev perl libdbi-perl libdbd-mysql-perl libdbd-pg-perl libfrontier-rpc-perl libterm-readline-gnu-perl libberkeleydb-perl mysql-server ssh libxml2 libxml2-dev libxmlrpc-core-c3-dev libpcre3 libpcre3-dev subversion libncurses5-dev git ngrep libssl-dev

But I'm getting some errors about some dependencies.

Could you please advise, how I can know the right dependency that I should use?

Thanks in advance
_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenSIPS Dependencies Installation

JustForVoip
Thank you for your help.

But what I mean in order to install OPENSIPS 2.3, what are the minimum required dependencies and where I can find them? Or this is something not possible because of some changes in Linux?


Sent from my iPhone

> On Jun 3, 2017, at 1:50 PM, Alexander Jankowsky <[hidden email]> wrote:
>
>
> Are you installing Linux from a CD-DVD set or an Network install CD.
> I solved a few problems by installing from a Network install CD.
>
> Nearly everyone will ask you to list exactly which dependencies are getting errors.
>
> If you can find an old or dedicated spare computer for a complete clean Linux install.
> You might solve a few problems, in that way and might create some new problems!
>
> Alex
>
> -----Original Message-----
> From: Users [mailto:[hidden email]] On Behalf Of Voice TAC
> Sent: Saturday, 3 June 2017 8:01 PM
> To: [hidden email]
> Subject: [OpenSIPS-Users] OpenSIPS Dependencies Installation
>
>
> Hello,
>
> I'm trying to install OPENSIPS on my virtual machine. However, I faced some issues and honestly I do not know if theses issues are related to my weakness in OpensSIPS, Linux, or both :(
>
> I followed the following:
>
> 1- apt-get update
>
> For dependencies:
>
> 2- apt-get install gcc bison flex make openssl libmysqlclient-dev perl libdbi-perl libdbd-mysql-perl libdbd-pg-perl libfrontier-rpc-perl libterm-readline-gnu-perl libberkeleydb-perl mysql-server ssh libxml2 libxml2-dev libxmlrpc-core-c3-dev libpcre3 libpcre3-dev subversion libncurses5-dev git ngrep libssl-dev
>
> But I'm getting some errors about some dependencies.
>
> Could you please advise, how I can know the right dependency that I should use?
>
> Thanks in advance
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenSIPS Dependencies Installation

Alexander Jankowsky

The dependencies list looks about right to get started with.
It is most probably some other basic error somewhere else.

You need to specifically indicate exactly which dependencies
are getting the errors and what those error messages are.

What name, what version of Linux are you using, how are you installing?
Can you do a full clean install of Linux without being on a Virtual Machine?

Alex

-----Original Message-----
From: Users [mailto:[hidden email]] On Behalf Of Voice TAC
Sent: Saturday, 3 June 2017 8:54 PM
To: OpenSIPS users mailling list
Subject: Re: [OpenSIPS-Users] OpenSIPS Dependencies Installation

Thank you for your help.

But what I mean in order to install OPENSIPS 2.3,
what are the minimum required dependencies and where I can find them?
Or this is something not possible because of some changes in Linux?




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenSIPS Dependencies Installation

Nick Altmann-3
In reply to this post by JustForVoip
Why don't use pre-builded opensips? http://apt.opensips.org .
You may need custom build for special needs, but I see, it's you first tries.

--
Nick

2017-06-03 14:23 GMT+03:00 Voice TAC <[hidden email]>:
Thank you for your help.

But what I mean in order to install OPENSIPS 2.3, what are the minimum required dependencies and where I can find them? Or this is something not possible because of some changes in Linux?


Sent from my iPhone

> On Jun 3, 2017, at 1:50 PM, Alexander Jankowsky <[hidden email]> wrote:
>
>
> Are you installing Linux from a CD-DVD set or an Network install CD.
> I solved a few problems by installing from a Network install CD.
>
> Nearly everyone will ask you to list exactly which dependencies are getting errors.
>
> If you can find an old or dedicated spare computer for a complete clean Linux install.
> You might solve a few problems, in that way and might create some new problems!
>
> Alex
>
> -----Original Message-----
> From: Users [mailto:[hidden email]] On Behalf Of Voice TAC
> Sent: Saturday, 3 June 2017 8:01 PM
> To: [hidden email]
> Subject: [OpenSIPS-Users] OpenSIPS Dependencies Installation
>
>
> Hello,
>
> I'm trying to install OPENSIPS on my virtual machine. However, I faced some issues and honestly I do not know if theses issues are related to my weakness in OpensSIPS, Linux, or both :(
>
> I followed the following:
>
> 1- apt-get update
>
> For dependencies:
>
> 2- apt-get install gcc bison flex make openssl libmysqlclient-dev perl libdbi-perl libdbd-mysql-perl libdbd-pg-perl libfrontier-rpc-perl libterm-readline-gnu-perl libberkeleydb-perl mysql-server ssh libxml2 libxml2-dev libxmlrpc-core-c3-dev libpcre3 libpcre3-dev subversion libncurses5-dev git ngrep libssl-dev
>
> But I'm getting some errors about some dependencies.
>
> Could you please advise, how I can know the right dependency that I should use?
>
> Thanks in advance
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenSIPS Dependencies Installation

JustForVoip
Hello,

I tried to use apt.opensips.org, but I got the follwoing:

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 049AD65B
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.RMTmIE5VUn --no-auto-check-trustdb --trust-model always --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyserver keyserver.ubuntu.com --recv-keys 049AD65B
gpg: requesting key 049AD65B from hkp server keyserver.ubuntu.com
gpg: key 049AD65B: public key "OpenSIPS Project <[hidden email]>" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
root@OpenSIPS:/usr/src# echo "deb http://apt.opensips.org jessie 2.3-releases" >>/etc/apt/sources.list

??

On Sun, Jun 4, 2017 at 12:12 AM, Nick Altmann <[hidden email]> wrote:
Why don't use pre-builded opensips? http://apt.opensips.org .
You may need custom build for special needs, but I see, it's you first tries.

--
Nick

2017-06-03 14:23 GMT+03:00 Voice TAC <[hidden email]>:
Thank you for your help.

But what I mean in order to install OPENSIPS 2.3, what are the minimum required dependencies and where I can find them? Or this is something not possible because of some changes in Linux?


Sent from my iPhone

> On Jun 3, 2017, at 1:50 PM, Alexander Jankowsky <[hidden email]> wrote:
>
>
> Are you installing Linux from a CD-DVD set or an Network install CD.
> I solved a few problems by installing from a Network install CD.
>
> Nearly everyone will ask you to list exactly which dependencies are getting errors.
>
> If you can find an old or dedicated spare computer for a complete clean Linux install.
> You might solve a few problems, in that way and might create some new problems!
>
> Alex
>
> -----Original Message-----
> From: Users [mailto:[hidden email]] On Behalf Of Voice TAC
> Sent: Saturday, 3 June 2017 8:01 PM
> To: [hidden email]
> Subject: [OpenSIPS-Users] OpenSIPS Dependencies Installation
>
>
> Hello,
>
> I'm trying to install OPENSIPS on my virtual machine. However, I faced some issues and honestly I do not know if theses issues are related to my weakness in OpensSIPS, Linux, or both :(
>
> I followed the following:
>
> 1- apt-get update
>
> For dependencies:
>
> 2- apt-get install gcc bison flex make openssl libmysqlclient-dev perl libdbi-perl libdbd-mysql-perl libdbd-pg-perl libfrontier-rpc-perl libterm-readline-gnu-perl libberkeleydb-perl mysql-server ssh libxml2 libxml2-dev libxmlrpc-core-c3-dev libpcre3 libpcre3-dev subversion libncurses5-dev git ngrep libssl-dev
>
> But I'm getting some errors about some dependencies.
>
> Could you please advise, how I can know the right dependency that I should use?
>
> Thanks in advance
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OpenSIPS Dependencies Installation

Alexander Jankowsky

 

You might try the Opensips already precompiled Debian package on Debian Linux.

I first began by compiling Opensips, first up to start with and ran into some problems.

Then I tried the precompiled debian package and soon got that running alright.

It is a very good way to get started and have a good look at what is going on.

 

There are also complete already running virtual machine image files around.

If you are still in a virtual machine you might try a prebuilt and running system.

Then you can have a good look around at what is going on in a working system.

I am not really all that familiar with virtual machine environments in practice.

 

I very much prefer a clean install onto a spare machine and a lot of note taking.

That way you can re-do things, fully clean reinstall and work from your own notes.

It only takes a little more time but I do find it more practical on a dedicated machine.

 

Once you have any working system then it is easier to plan and work from that.

 

Alex

 

 


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Loading...