[OpenSIPS-RLS Module] Cannot receive NOTIFY updates

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[OpenSIPS-RLS Module] Cannot receive NOTIFY updates

Patrice Dalle
Hi,

I would really appreciate if anyone can give me feedback about the problem described below.

I am trying to setup opensips to use rls with a resource list. So far I have been able to populate the rls-services XML file using XCAP and to subscribe to the resource-list but I cannot receive NOTIFYs with presence state. I only receive the initial NOTIFY...

I suspect that there might be a problem with the handling of PUBLISH requests as I see the following error in the opensips logs.

ERROR:mi_datagram:mi_datagram_server: command not available

I also see this warning but cannot tell if this is a problem?

DBG:pua:db_update: NO_UPDATEDB_FLAG

Logs are provided in attachment:
rls-services -> The RLS document on the XCAP server
opensips.cfg
sip_log_presence_rls_no_notify.txt -> The SIP packets logging
opensips.log

Thanks,
Patrice


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

logs.zip (30K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [OpenSIPS-RLS Module] Cannot receive NOTIFY updates

Patrice Dalle
Hi,

About the problem I reported earlier I made some progress and found out that there is an error in the method rls_handle_notify. That's probably why I do not see any NOTIFY with presence state information.

I see the following error:
DBG:rls:rls_handle_notify: no dialog match found in hash table

This is because res_id is zero after a call to
if(pua_get_record_id(&dialog, &res_id)< 0) // verify if within a stored dialog

Does anyone have a hint?
Thanks
-Patrice

On Wed, Mar 3, 2010 at 9:19 AM, Patrice Dalle <[hidden email]> wrote:
Hi,

I would really appreciate if anyone can give me feedback about the problem described below.

I am trying to setup opensips to use rls with a resource list. So far I have been able to populate the rls-services XML file using XCAP and to subscribe to the resource-list but I cannot receive NOTIFYs with presence state. I only receive the initial NOTIFY...

I suspect that there might be a problem with the handling of PUBLISH requests as I see the following error in the opensips logs.

ERROR:mi_datagram:mi_datagram_server: command not available

I also see this warning but cannot tell if this is a problem?

DBG:pua:db_update: NO_UPDATEDB_FLAG

Logs are provided in attachment:
rls-services -> The RLS document on the XCAP server
opensips.cfg
sip_log_presence_rls_no_notify.txt -> The SIP packets logging
opensips.log

Thanks,
Patrice



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [OpenSIPS-RLS Module] Cannot receive NOTIFY updates

Anca Vamanu-2
Hi Patrice,

What version of opensips are you using? I will test rls and see if there
is really a problem in the code.

Regards,
Anca

Patrice Dalle wrote:

> Hi,
>
> About the problem I reported earlier I made some progress and found
> out that there is an error in the method rls_handle_notify. That's
> probably why I do not see any NOTIFY with presence state information.
>
> I see the following error:
> DBG:rls:rls_handle_notify: no dialog match found in hash table
>
> This is because res_id is zero after a call to
> if(pua_get_record_id(&dialog, &res_id)< 0) // verify if within a
> stored dialog
>
> Does anyone have a hint?
> Thanks
> -Patrice
>
> On Wed, Mar 3, 2010 at 9:19 AM, Patrice Dalle <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hi,
>
>     I would really appreciate if anyone can give me feedback about the
>     problem described below.
>
>     I am trying to setup opensips to use rls with a resource list. So
>     far I have been able to populate the rls-services XML file using
>     XCAP and to subscribe to the resource-list but I cannot receive
>     NOTIFYs with presence state. I only receive the initial NOTIFY...
>
>     I suspect that there might be a problem with the handling of
>     PUBLISH requests as I see the following error in the opensips logs.
>
>     ERROR:mi_datagram:mi_datagram_server: command not available
>
>     I also see this warning but cannot tell if this is a problem?
>
>     DBG:pua:db_update: NO_UPDATEDB_FLAG
>
>     Logs are provided in attachment:
>     rls-services -> The RLS document on the XCAP server
>     opensips.cfg
>     sip_log_presence_rls_no_notify.txt -> The SIP packets logging
>     opensips.log
>
>     Thanks,
>     Patrice
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


--
Anca Vamanu
www.voice-system.ro


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users