OpenXCAP on Debian...

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenXCAP on Debian...

OpenSIPS - Users mailing list
I just tried to install OpenXCAP on Debian Stretch and was having issues because of missing dependencies (python-twisted-web2). I then tried on both Jessie and Wheezy, but each of those were exposing different dependency problems.

Was anybody successful recently in installing OpenXCAP on Debian? Not from source but from binary packages?

Thanks
Boris




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenXCAP on Debian...

Adrian Georgescu
Can you paste the full output of your commands?

Regards,
Adrian


> On 6 Dec 2017, at 14:11, Boris via Users <[hidden email]> wrote:
>
> I just tried to install OpenXCAP on Debian Stretch and was having issues because of missing dependencies (python-twisted-web2). I then tried on both Jessie and Wheezy, but each of those were exposing different dependency problems.
>
> Was anybody successful recently in installing OpenXCAP on Debian? Not from source but from binary packages?
>
> Thanks
> Boris
>
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

signature.asc (242 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenXCAP on Debian...

Dan Pascu
In reply to this post by OpenSIPS - Users mailing list

On 6 Dec 2017, at 19:11, Boris via Users wrote:

> I just tried to install OpenXCAP on Debian Stretch and was having issues because of missing dependencies (python-twisted-web2).

It seems debian stretch decided to not ship this package. You can ask them why, because the package is present in wheezy (old old stable), jessie (old stable) and it is still present in unstable. They just seem to have skipped stretch.

https://packages.debian.org/search?keywords=python-twisted-web2

> I then tried on both Jessie and Wheezy, but each of those were exposing different dependency problems.

You'll most likely need the jessie-backports repository for jessie. I won't recommend wheezy as it's too old.

--
Dan





_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: OpenXCAP on Debian...

OpenSIPS - Users mailing list
Thanks, Dan. Jessie backports seems to work as expected.

-Boris



-------- Original Message --------
Subject: Re: [OpenSIPS-Users] OpenXCAP on Debian...
Local Time: December 8, 2017 12:26 PM
UTC Time: December 8, 2017 11:26 AM
To: Boris <[hidden email]>, OpenSIPS users mailling list <[hidden email]>


On 6 Dec 2017, at 19:11, Boris via Users wrote:
I just tried to install OpenXCAP on Debian Stretch and was having issues because of missing dependencies (python-twisted-web2).

It seems debian stretch decided to not ship this package. You can ask them why, because the package is present in wheezy (old old stable), jessie (old stable) and it is still present in unstable. They just seem to have skipped stretch.


I then tried on both Jessie and Wheezy, but each of those were exposing different dependency problems.

You'll most likely need the jessie-backports repository for jessie. I won't recommend wheezy as it's too old.

--
Dan




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users