Opensips 1.11 - Debian Wheezy - libmysqlclient

classic Classic list List threaded Threaded
4 messages Options
leo
Reply | Threaded
Open this post in threaded view
|

Opensips 1.11 - Debian Wheezy - libmysqlclient

leo
Hello:

I'm trying to install opensips 1.11 from the Official OpenSIPS Debian/Ubuntu repository (APT i386/amd64) (by Dynamic Packet & OpenSIPS Solutions) -> http://apt.opensips.org (deb http://apt.opensips.org/ stable111 main) in a Debian Wheezy x64 but I'm finding a dependency problem regarding the libmysqlclient.

Opensips installation requires libmysqlclient16 (that is it for squeeze/mysql 5.1) and in wheezy there is libmysqlclient18 (mysql 5.5).

Is this just a package dependencies error or Opensips really requires mysql 5.1?

Thanks a lot,

Leo.
Reply | Threaded
Open this post in threaded view
|

Re: Opensips 1.11 - Debian Wheezy - libmysqlclient

Razvan Crainea-3
Hi, Leo!

No, there is no requirement for OpenSIPS to run with a specific mysql
library version (client or server). I think this dependency is too
strict, libmysqlclient18 should work without any issues.
I will replace the dependency with the meta-package libmysqlclient.

Best regards,

Răzvan Crainea
OpenSIPS Solutions
www.opensips-solutions.com

On 03/24/2015 05:48 PM, leo wrote:

> Hello:
>
> I'm trying to install opensips 1.11 from the Official OpenSIPS Debian/Ubuntu
> repository (APT i386/amd64) (by Dynamic Packet & OpenSIPS Solutions) ->
> http://apt.opensips.org (deb http://apt.opensips.org/ stable111 main) in a
> Debian Wheezy x64 but I'm finding a dependency problem regarding the
> libmysqlclient.
>
> Opensips installation requires libmysqlclient16 (that is it for
> squeeze/mysql 5.1) and in wheezy there is libmysqlclient18 (mysql 5.5).
>
> Is this just a package dependencies error or Opensips really requires mysql
> 5.1?
>
> Thanks a lot,
>
> Leo.
>
>
>
> --
> View this message in context: http://opensips-open-sip-server.1449251.n2.nabble.com/Opensips-1-11-Debian-Wheezy-libmysqlclient-tp7596120.html
> Sent from the OpenSIPS - Users mailing list archive at Nabble.com.
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
leo
Reply | Threaded
Open this post in threaded view
|

Re: Opensips 1.11 - Debian Wheezy - libmysqlclient

leo
Hello Răzvan:

Do you have any update? I've tried to install opensips again today and i'm having the same dependency error.
Thanks a lot!

Leo
Reply | Threaded
Open this post in threaded view
|

Re: Opensips 1.11 - Debian Wheezy - libmysqlclient

Razvan Crainea-3
Hi, Leo!

I updated the dependencies in the sources, but the Dynamic Packet guys
should also update the debs[1]. They will probably do it today, after
the release.

[1] http://apt.opensips.org/

Best regards,

Răzvan Crainea
OpenSIPS Solutions
www.opensips-solutions.com

On 04/01/2015 11:39 PM, leo wrote:

> Hello Răzvan:
>
> Do you have any update? I've tried to install opensips again today and i'm
> having the same dependency error.
> Thanks a lot!
>
> Leo
>
>
>
> --
> View this message in context: http://opensips-open-sip-server.1449251.n2.nabble.com/Opensips-1-11-Debian-Wheezy-libmysqlclient-tp7596120p7596290.html
> Sent from the OpenSIPS - Users mailing list archive at Nabble.com.
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users