Opensips ( Monit Cant! Connect )

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Opensips ( Monit Cant! Connect )

David Perrin
Greetings all:,


I have been pulling my hair out trying to get this Monit service running and I just cant figure it out, its the mi_xmlrpc server and MDB2, im running opensips over Centos5.
I have excluded the mi_xmlrpc module on the build and manually got the xmlrpc-c package, however when i do a netstat -tal I dont see anything on the monit port or 8080, could someone that set this up on centos please give me a little push in the right direction.


Thanks kindly,

David P/

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips ( Monit Cant! Connect )

Indiver
Hi David,
I worked on Monit tool and succeeded in working that. May be this procedure i followed helps you:

Step 1:

I included xmlrpc module which is necessary for working of most of the tabs in opensips control panel.

Step 2:
Downloaded and configured Monit tool.

Step 3:
Checked whether the ssl option is set to 0 or 1 in boxes.inc.php file. If it is set to 1 change it to 0.


David Perrin wrote
Greetings all:,


I have been pulling my hair out trying to get this Monit service running and
I just cant figure it out, its the mi_xmlrpc server and MDB2, im running
opensips over Centos5.
I have excluded the mi_xmlrpc module on the build and manually got the
xmlrpc-c package, however when i do a netstat -tal I dont see anything on
the monit port or 8080, could someone that set this up on centos please give
me a little push in the right direction.


Thanks kindly,

David P/

_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips ( Monit Cant! Connect )

Iulia Bublea-2
Hi David,

Also check monit's login credentials(username,password and port) in boxes.global.inc.php to be the same as in monitrc file.

Iulia

Indiver wrote:
Hi David,
I worked on Monit tool and succeeded in working that. May be this procedure
i followed helps you:

Step 1:

I included xmlrpc module which is necessary for working of most of the tabs
in opensips control panel.

Step 2:
Downloaded and configured Monit tool.

Step 3:
Checked whether the ssl option is set to 0 or 1 in boxes.inc.php file. If it
is set to 1 change it to 0. 



David Perrin wrote:
  
Greetings all:,


I have been pulling my hair out trying to get this Monit service running
and
I just cant figure it out, its the mi_xmlrpc server and MDB2, im running
opensips over Centos5.
I have excluded the mi_xmlrpc module on the build and manually got the
xmlrpc-c package, however when i do a netstat -tal I dont see anything on
the monit port or 8080, could someone that set this up on centos please
give
me a little push in the right direction.


Thanks kindly,

David P/

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


    

  


--
Iulia Bublea
Web: www.voice-system.ro
Email: [hidden email]

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips ( Monit Cant! Connect )

David Perrin
In reply to this post by Indiver
Thanks so much for the response, I have completed these steps, and I see that xmlrpc server is not running, I removed it on the opensips Makefile and built in, this I am sure, cause I got the abyss errors, where you have to manually get xmlrpc-c package and install it in order to compile mi_xmlrpc module, I have check the boxes config and monit config both have identical passwords and usernames. hmmm. When i do a netstat -tal, I dont see anything running on port 2812 or 8080.

On Thu, Dec 10, 2009 at 9:05 PM, Indiver <[hidden email]> wrote:

Hi David,
I worked on Monit tool and succeeded in working that. May be this procedure
i followed helps you:

Step 1:

I included xmlrpc module which is necessary for working of most of the tabs
in opensips control panel.

Step 2:
Downloaded and configured Monit tool.

Step 3:
Checked whether the ssl option is set to 0 or 1 in boxes.inc.php file. If it
is set to 1 change it to 0.



David Perrin wrote:
>
> Greetings all:,
>
>
> I have been pulling my hair out trying to get this Monit service running
> and
> I just cant figure it out, its the mi_xmlrpc server and MDB2, im running
> opensips over Centos5.
> I have excluded the mi_xmlrpc module on the build and manually got the
> xmlrpc-c package, however when i do a netstat -tal I dont see anything on
> the monit port or 8080, could someone that set this up on centos please
> give
> me a little push in the right direction.
>
>
> Thanks kindly,
>
> David P/
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>

--
View this message in context: http://n2.nabble.com/Opensips-Monit-Cant-Connect-tp4148916p4149536.html
Sent from the OpenSIPS - Users mailing list archive at Nabble.com.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
"I never saw a wild thing feeling sorry for itself"

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips ( Monit Cant! Connect )

Indiver
Hi David,
The absyss error will get when u unmet the dependencies. The following libraries or applications must be installed before running OpenSIPS with this module loaded:

libxml
ibxmlrpc-c3 version 0.9.10
ibxmlrpc-c3-dev version 0.9.10

As far as monit tool: check wheter the monit configuration file is correct or not by typing monit -tcommand. Cross check once again in opensips startup log whether xmlrpc server is running or not after overcoming absyys error,as well as monit server running condition.
David Perrin wrote
Thanks so much for the response, I have completed these steps, and I see
that xmlrpc server is not running, I removed it on the opensips Makefile and
built in, this I am sure, cause I got the abyss errors, where you have to
manually get xmlrpc-c package and install it in order to compile mi_xmlrpc
module, I have check the boxes config and monit config both have identical
passwords and usernames. hmmm. When i do a netstat -tal, I dont see anything
running on port 2812 or 8080.

On Thu, Dec 10, 2009 at 9:05 PM, Indiver <nehru.indu@gmail.com> wrote:

>
> Hi David,
> I worked on Monit tool and succeeded in working that. May be this procedure
> i followed helps you:
>
> Step 1:
>
> I included xmlrpc module which is necessary for working of most of the tabs
> in opensips control panel.
>
> Step 2:
> Downloaded and configured Monit tool.
>
> Step 3:
> Checked whether the ssl option is set to 0 or 1 in boxes.inc.php file. If
> it
> is set to 1 change it to 0.
>
>
>
> David Perrin wrote:
> >
> > Greetings all:,
> >
> >
> > I have been pulling my hair out trying to get this Monit service running
> > and
> > I just cant figure it out, its the mi_xmlrpc server and MDB2, im running
> > opensips over Centos5.
> > I have excluded the mi_xmlrpc module on the build and manually got the
> > xmlrpc-c package, however when i do a netstat -tal I dont see anything on
> > the monit port or 8080, could someone that set this up on centos please
> > give
> > me a little push in the right direction.
> >
> >
> > Thanks kindly,
> >
> > David P/
> >
> > _______________________________________________
> > Users mailing list
> > Users@lists.opensips.org
> > http://lists.opensips.org/cgi-bin/mailman/listinfo/users
> >
> >
>
> --
> View this message in context:
> http://n2.nabble.com/Opensips-Monit-Cant-Connect-tp4148916p4149536.html
> Sent from the OpenSIPS - Users mailing list archive at Nabble.com.
>
> _______________________________________________
> Users mailing list
> Users@lists.opensips.org
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>



--
"I never saw a wild thing feeling sorry for itself"

_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users