[Opensips-Users] Problem with secure TLS call

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Opensips-Users] Problem with secure TLS call

rajnikant vanza
Hello List,

REGISTER messages seem to be handled correctly, but I'm still having troubles with TLS:

I have successful audio + video calling done through this opensips server with TLS but i got below error very rapidly and after some days this opensips server not get request and need to restart opensips service then its work fine.

Apr 30 14:52:04 siplocal /usr/local/sbin/opensips[15556]: INFO:core:_tls_read: TLS connection to XXX.XX.XXX.XXX:XXXXX closed cleanly
Apr 30 14:52:31 siplocal /usr/local/sbin/opensips[15555]: ERROR:core:tcpconn_connect: tcp_blocking_connect failed
Apr 30 14:52:31 siplocal /usr/local/sbin/opensips[15555]: ERROR:core:tcp_send: connect failed
Apr 30 14:52:31 siplocal /usr/local/sbin/opensips[15555]: ERROR:tm:msg_send: tcp_send failed
Apr 30 14:52:31 siplocal /usr/local/sbin/opensips[15555]: INFO:core:probe_max_sock_buff: using snd buffer of 512 kb
Apr 30 14:52:31 siplocal /usr/local/sbin/opensips[15555]: INFO:core:init_sock_keepalive: -- TCP keepalive enabled on socket
Apr 30 14:52:31 siplocal /usr/local/sbin/opensips[15555]: ERROR:core:tcp_blocking_connect: poll error: flags 18
Apr 30 14:52:31 siplocal /usr/local/sbin/opensips[15555]: ERROR:core:tcp_blocking_connect: failed to retrieve SO_ERROR (111) Connection refused

I have tried on both opensips server is opensips-1.7.2-tls and  opensips 1.8.0-beta-tls but above problem is occurred.

opensips -V
version: opensips 1.7.2-tls (x86_64/linux)
flags: STATS: Off, USE_IPV6, USE_TCP, USE_TLS, DISABLE_NAGLE, USE_MCAST, SHM_MEM, SHM_MMAP, PKG_MALLOC, DBG_F_MALLOC, FAST_LOCK-ADAPTIVE_WAIT
ADAPTIVE_WAIT_LOOPS=1024, MAX_RECV_BUFFER_SIZE 262144, MAX_LISTEN 16, MAX_URI_SIZE 1024, BUF_SIZE 65535
poll method support: poll, epoll_lt, epoll_et, sigio_rt, select.
svnrevision: unknown
@(#) $Id: main.c 8537 2011-11-08 17:02:11Z bogdan_iancu $
main.c compiled on 09:41:14 Mar 12 2012 with gcc 4.1.2

--------------------

opensips -V
version: opensips 1.8.0-beta-tls (i386/linux)
flags: STATS: Off, USE_IPV6, USE_TCP, USE_TLS, DISABLE_NAGLE, USE_MCAST, SHM_MEM, SHM_MMAP, PKG_MALLOC, F_MALLOC, FAST_LOCK-ADAPTIVE_WAIT
ADAPTIVE_WAIT_LOOPS=1024, MAX_RECV_BUFFER_SIZE 262144, MAX_LISTEN 16, MAX_URI_SIZE 1024, BUF_SIZE 65535
poll method support: poll, epoll_lt, epoll_et, sigio_rt, select.
svnrevision: 2:8972M
@(#) $Id: main.c 8772 2012-03-08 11:16:13Z bogdan_iancu $
main.c compiled on 12:26:50 Apr 30 2012 with gcc 4.4.6


configuraton for TLS in opensips.cfg file.

tls_ciphers_list="ALL"
disable_tls=0
listen=udp:0.0.0.0:5060
listen=tls:0.0.0.0:5061
tls_verify_server=0
tls_verify_client=0
tls_require_client_certificate=0
tls_method=SSLv23
tls_certificate="/usr/local/etc/opensips/tls/user-cert.pem"
tls_private_key="/usr/local/etc/opensips/tls/user-privkey.pem"
tls_ca_list="/usr/local/etc/opensips/tls/user-calist.pem"

Can someone give me help?

Thanks in advance!


--
Best Regards,

Rajnikant Vanza

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users