Opensips + asterisk 1.4

classic Classic list List threaded Threaded
25 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Opensips + asterisk 1.4

willianmazzardo
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

Stephen Vigus
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
Hi Stephens... how do I do this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Stephen Vigus <[hidden email]>
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

Dani Popa
set opensips peer to insecure=port,invite


On Wed, Jul 17, 2013 at 1:12 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Stephens... how do I do this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Stephen Vigus <[hidden email]>
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
Hi Dani ... thanks ... i have for now insecure=very ... my asterisk version is 1.4... and this type of setting is for 1.6+

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
set opensips peer to insecure=port,invite


On Wed, Jul 17, 2013 at 1:12 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Stephens... how do I do this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Stephen Vigus <[hidden email]>
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

Dani Popa
what contex hit invite from opensips ?


On Wed, Jul 17, 2013 at 1:24 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Dani ... thanks ... i have for now insecure=very ... my asterisk version is 1.4... and this type of setting is for 1.6+

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
set opensips peer to insecure=port,invite


On Wed, Jul 17, 2013 at 1:12 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Stephens... how do I do this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Stephen Vigus <[hidden email]>
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
My a2billing context

[callingcard]

exten => _X.,1,DeadAGI(a2billing.php)


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
what contex hit invite from opensips ?


On Wed, Jul 17, 2013 at 1:24 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Dani ... thanks ... i have for now insecure=very ... my asterisk version is 1.4... and this type of setting is for 1.6+

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
set opensips peer to insecure=port,invite


On Wed, Jul 17, 2013 at 1:12 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Stephens... how do I do this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Stephen Vigus <[hidden email]>
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

Dani Popa
when you send a call in asterisk, do you see in asterisj cli that call hit you callingcard context or it hit default context ?


On Wed, Jul 17, 2013 at 1:55 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
My a2billing context

[callingcard]

exten => _X.,1,DeadAGI(a2billing.php)


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
what contex hit invite from opensips ?


On Wed, Jul 17, 2013 at 1:24 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Dani ... thanks ... i have for now insecure=very ... my asterisk version is 1.4... and this type of setting is for 1.6+

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
set opensips peer to insecure=port,invite


On Wed, Jul 17, 2013 at 1:12 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Stephens... how do I do this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Stephen Vigus <[hidden email]>
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
No ... just sip messages, and stops at Proxy Authentication Require.

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
when you send a call in asterisk, do you see in asterisj cli that call hit you callingcard context or it hit default context ?


On Wed, Jul 17, 2013 at 1:55 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
My a2billing context

[callingcard]

exten => _X.,1,DeadAGI(a2billing.php)


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
what contex hit invite from opensips ?


On Wed, Jul 17, 2013 at 1:24 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Dani ... thanks ... i have for now insecure=very ... my asterisk version is 1.4... and this type of setting is for 1.6+

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
set opensips peer to insecure=port,invite


On Wed, Jul 17, 2013 at 1:12 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Stephens... how do I do this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Stephen Vigus <[hidden email]>
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
Hi ... im trying again ... and now WORKED !! ;)

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Willian Mazzardo - SYSSVOIP <[hidden email]>
No ... just sip messages, and stops at Proxy Authentication Require.

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
when you send a call in asterisk, do you see in asterisj cli that call hit you callingcard context or it hit default context ?


On Wed, Jul 17, 2013 at 1:55 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
My a2billing context

[callingcard]

exten => _X.,1,DeadAGI(a2billing.php)


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
what contex hit invite from opensips ?


On Wed, Jul 17, 2013 at 1:24 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Dani ... thanks ... i have for now insecure=very ... my asterisk version is 1.4... and this type of setting is for 1.6+

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Dani Popa <[hidden email]>
set opensips peer to insecure=port,invite


On Wed, Jul 17, 2013 at 1:12 PM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi Stephens... how do I do this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Stephen Vigus <[hidden email]>
Hi Willian

You most likely need to configure Asterisk to not authenticate SIP requests coming from Opensips.

Regards
Stephen



On Wed, Jul 17, 2013 at 3:32 AM, Willian Mazzardo - SYSSVOIP <[hidden email]> wrote:
Hi all..

I know this is a very simple scenario, all PSTN calls be routed to asterisk to do the billing job, but im having some problems, this is my scenario:

Sip Client (10.0.0.3) > Opensips (10.1.1.2) > Asterisk (10.1.1.247) ..... > PSTN

Calls between sip clients on Opensips are working, but when I try to call over Asterisk, I have Proxy authentication problem.

Here is my logs:

Opensips: http://pastebin.com/SWpuRHku
Asterisk: http://pastebin.com/6jp50LSS

[opensips]
host=10.1.1.2
type=friend
context=callingcard
qualify=no
insecure=very
fromdomain=10.1.1.2


Route: http://pastebin.com/mLgpXiNx

Can someone help me on this?

Thanks


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




--
Dani Popa

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

symack
Please specify the solution for future lost souls.

Kind Regards,

Nick.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
Here is my configs:

opensips.cfg :  http://pastebin.com/eLh2fUet

My scenario:

Opensips = 10.1.1.2
Mysql = 10.1.1.249
Asterisk = 10.1.1.247

Im trying to use balancing mode, but when I try to register into Opensips, return Method Not Allowed...

here is the opensips.cfg for balancing:   http://pastebin.com/gu9j6cYc

Im using DISPATCHER module...

Can some one help me on this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Nick Khamis <[hidden email]>
Please specify the solution for future lost souls.

Kind Regards,

Nick.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
Very strange situation I have with this scenario ...

Most of registry coming into opensips are rejected ... returning Proxy Authentication Require ......

I have some domains registered into mysql table... like dns name (sip.provider.com) and External IP ( 222.222.222.222) and my internal ip (10.1.1.2)

in subscriber table I have my peers using domain = MY EXTERN IP, but, if some register come with dns name, it will work?



Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Willian Mazzardo - SYSSVOIP <[hidden email]>
Here is my configs:

opensips.cfg :  http://pastebin.com/eLh2fUet

My scenario:

Opensips = 10.1.1.2
Mysql = 10.1.1.249
Asterisk = 10.1.1.247

Im trying to use balancing mode, but when I try to register into Opensips, return Method Not Allowed...

here is the opensips.cfg for balancing:   http://pastebin.com/gu9j6cYc

Im using DISPATCHER module...

Can some one help me on this?

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
<a href="tel:55%203537%202030" value="+555535372030" target="_blank">55 3537 2030


2013/7/17 Nick Khamis <[hidden email]>
Please specify the solution for future lost souls.

Kind Regards,

Nick.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

symack
Is it possible to use 1.8? I am not familiar with Asterisk 10 or 1.4.
I could help you more if you consider that.

N.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
My billing system require asterisk 1.4.

Did you check my opensips.cfg to see if everything is ok about handle register messages?

Thanks

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Nick Khamis <[hidden email]>
Is it possible to use 1.8? I am not familiar with Asterisk 10 or 1.4.
I could help you more if you consider that.

N.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

symack
if (!proxy_authorize("", "subscriber")) {
        proxy_challenge("", "0");
        exit;
}
if (!db_check_from()) {
        sl_send_reply("403","Forbidden auth ID");
        exit;
}
consume_credentials();

This seems fine to me. But you're registration issue is not from
OpenSIPS side, it's from Asterisk no? Please post a trace of a single
register off of the OpenSIPS and Asterisk box. You could also check
opensips.location table to make sure you have an entry for the
authenticated UA there.

Finally, do you have OpenSIPS as a peer on your Asterisk box? As
already mentioned use Also, as metioned earlier use
insecure=port,invite. This variable was available port 1.0.9
http://www.voip-info.org/wiki/view/Asterisk+sip+insecure.

Kind Regards,

Nick.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

symack
When you post your trace be sure not to include the actual public IP.


N.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
This is my sip trace:

http://pastebin.com/jALwj12r

Scenario:

10.0.0.3 = Sip soft phone (behind NAT)
10.1.1.2 = Opensips

My subscriber table:

Imagem inline 1


If in subscriber table I have in DOMAIN = 10.1.1.2 it works nice.

And there is my question.

Not all my customers use same dns name to register.

I have some:  sip.myprovider.com, sip2.myprovider.com, sip3.myprovider.com and I have my IPs (111.222.333.444).

Can I let domain blank to use "any" ?

Thanks

Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/17 Nick Khamis <[hidden email]>
When you post your trace be sure not to include the actual public IP.


N.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

symack
First things first. Forget the asterisk box for now. The phones are not getting registered with OpenSIPS.
dOES the username, domain, in the digest make sense? Also, recheck the auth part of your configuration:

# ----- auth params -----
modparam("auth","username_spec","$avp(user_spec)")
modparam("auth","password_spec","$avp(pass_spec)")


# ----- auth_db params -----
/* uncomment the following lines if you want to enable the DB based
   authentication */

modparam("auth_db", "user_column", "username")
modparam("auth_db", "password_column", "ha1")
# modparam("auth_db", "password_column2", "ha1b")
modparam("auth_db", "use_domain", 1)
modparam("auth_db", "calculate_ha1", 0)
modparam("auth_db", "load_credentials", "rpid")
modparam("auth_db", "load_credentials", "$avp(pass_spec)=ha1")

Maybe start with clear text username/password and then add the md5 when you know that it is working. Oh!!! Increase
the debug level of OpenSIPS (debug=4), and eye the REGISTER, it will show you the clear text usernames and passwords
being sent, the comparisson, and why it's etting rejected. You can post it on pastebin, but please make sure it's for an example
user (i.e, 1001/12345a), that you will delete later.

>> Not all my customers use same dns name to register.
>> I have some:  sip.myprovider.comsip2.myprovider.comsip3.myprovider.com and I have my IPs (111.222.333.444).
>> Can I let domain blank to use "any" ?


Set, modparam("auth_db", "use_domain", 0).

Let us know how you progress.

Cheers,

Nick from Toronto.



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Opensips + asterisk 1.4

willianmazzardo
Hi Nick ... thanks for your help ... very appreciated.

Here is the news... changed the opensips.cfg to your modeparams, and use_domain to 0 and the problem still the same:

In my domain tables I have all domains (10.1.1.2, test.provider.com) but into subscriber, i have recreated without VIEW and use more simple data, like 1000 and 1001 as username and password = teste and domain = 10.1.1.2.

If I try register softphone with domain = 10.1.1.2, it work, but if I try domain = test.provider.com wich is using 10.1.1.2 as IP address, doesn't work.

here is the log:

http://pastebin.com/zTz0eNjV

Thanks for your help


Willian Mazzardo
Depto TI - SYSSVOIP
www.syssvoip.com.br
55 3537 2030


2013/7/18 Nick Khamis <[hidden email]>
First things first. Forget the asterisk box for now. The phones are not getting registered with OpenSIPS.
dOES the username, domain, in the digest make sense? Also, recheck the auth part of your configuration:

# ----- auth params -----
modparam("auth","username_spec","$avp(user_spec)")
modparam("auth","password_spec","$avp(pass_spec)")


# ----- auth_db params -----
/* uncomment the following lines if you want to enable the DB based
   authentication */

modparam("auth_db", "user_column", "username")
modparam("auth_db", "password_column", "ha1")
# modparam("auth_db", "password_column2", "ha1b")
modparam("auth_db", "use_domain", 1)
modparam("auth_db", "calculate_ha1", 0)
modparam("auth_db", "load_credentials", "rpid")
modparam("auth_db", "load_credentials", "$avp(pass_spec)=ha1")

Maybe start with clear text username/password and then add the md5 when you know that it is working. Oh!!! Increase
the debug level of OpenSIPS (debug=4), and eye the REGISTER, it will show you the clear text usernames and passwords
being sent, the comparisson, and why it's etting rejected. You can post it on pastebin, but please make sure it's for an example
user (i.e, 1001/12345a), that you will delete later.

>> Not all my customers use same dns name to register.
>> I have some:  sip.myprovider.comsip2.myprovider.comsip3.myprovider.com and I have my IPs (111.222.333.444).
>> Can I let domain blank to use "any" ?


Set, modparam("auth_db", "use_domain", 0).

Let us know how you progress.

Cheers,

Nick from Toronto.



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
12