Osipsconsole and store_plaintext_pw variable

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Osipsconsole and store_plaintext_pw variable

Carlo Dimaggio
Hello,

I have set the variable STORE_PLAINTEXT_PW=0 in osipsconsolerc but if  
I exec the commands add or passwd, the password of the account in db  
is not encrypted.
Is there something I should change?


Thanks,
Carlo

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Osipsconsole and store_plaintext_pw variable

Iulia Bublea-2
Hi,

There was indeed a problem with the password encryption. I have fixed
this problem. Try the latest version of the trunk. Tomorrow morning the
fix will be available for 1.5 also.

Regards,
Iulia


Carlo Dimaggio wrote:

> Hello,
>
> I have set the variable STORE_PLAINTEXT_PW=0 in osipsconsolerc but if  
> I exec the commands add or passwd, the password of the account in db  
> is not encrypted.
> Is there something I should change?
>
>
> Thanks,
> Carlo
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Osipsconsole and store_plaintext_pw variable

Carlo Dimaggio

Il giorno 06/mag/09, alle ore 19:54, Iulia Bublea ha scritto:

> Hi,
> There was indeed a problem with the password encryption. I have  
> fixed this problem. Try the latest version of the trunk. Tomorrow  
> morning the fix will be available for 1.5 also.

Hi Iulia,

I have tried the latest version from trunk. All works fine, thank you.
Anyway I ask you about the location of the configuration file because  
I see that osipsconsole script find the osipsconsolerc in ./script/  
and ~/.osipsconsolerc while the installation of opensips puts the  
osipsconsolerc in /etc/opensips (with prefix=/):

root@sip:/etc/opensips# strace osipsconsole 2>&1 | grep osipsco
execve("/sbin/osipsconsole", ["osipsconsole"], [/* 20 vars */]) = 0
open("/sbin/osipsconsole", O_RDONLY|O_LARGEFILE) = 3
read(3, "#!/usr/bin/perl \n#\n#$Id: osipsco"..., 4096) = 4096
stat64("./scripts/osipsconsolerc", 0x81530c8) = -1 ENOENT (No such  
file or directory)
        -> I have to copy osipsconsole in /etc/opensips/scripts/

stat64("~/.osipsconsolerc", 0x81530c8)  = -1 ENOENT (No such file or  
directory)

Is this a problem only with my installation?


Thanks and regards,
Carlo Dimaggio

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users