Phone Registration :(

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Phone Registration :(

JustForVoip
Hello,

I'm totally new with OpenSIPS and I manged to install it and adjust the configuration script. However, I tried to register a phone using X-Lite and ZOPIPER but I could not.

I tried to sniff using ngrep but I did not find any SIP messages. I used the following command:
 
ngrep -pqtw byline port 5060 >sip_Messages_Debug.sip


===============

In addition, I used the opensipsctl ul show command but I got:

ERROR: /tmp/opensips_fifo does not exist
ERROR: Make sure you have the line 'modparam("mi_fifo", "fifo_name", "/tmp/opensips_fifo")' in your config
ERROR: and also have loaded the mi_fifo module.

Any help please?

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Phone Registration :(

Rik Broers

Some basic things:

 

Are the opensips processes running when you check with ps?

Is your firewall configured/opened correct?

Do you see opensips listening on port 5060 and correct interface when you check with netstat -ulpn?

 

Also a tip for troubleshooting the script flow, enable script_trace or put xlog commands everywhere.

http://www.opensips.org/Documentation/Script-CoreFunctions-2-3#toc43

 

For the error you pasted related to the fifo command, you can do exactly as the error says and check if the mod_param and load module are in the script.

 

For errors related to starting opensips, you can refer to your syslog as that is where opensips will log by default. They are pretty self explanatory most of the time just as the mi_fifo error shows ;)

 

Good luck!

Regards,

Met vriendelijke groet,

Rik Broers
Voice Engineer

 

Van: Users [mailto:[hidden email]] Namens Voice TAC
Verzonden: 07 June 2017 23:51
Aan: OpenSIPS users mailling list <[hidden email]>
Onderwerp: [OpenSIPS-Users] Phone Registration :(

 

Hello,

I'm totally new with OpenSIPS and I manged to install it and adjust the configuration script. However, I tried to register a phone using X-Lite and ZOPIPER but I could not.

I tried to sniff using ngrep but I did not find any SIP messages. I used the following command:
 
ngrep -pqtw byline port 5060 >sip_Messages_Debug.sip


===============


In addition, I used the opensipsctl ul show command but I got:

ERROR: /tmp/opensips_fifo does not exist
ERROR: Make sure you have the line 'modparam("mi_fifo", "fifo_name", "/tmp/opensips_fifo")' in your config
ERROR: and also have loaded the mi_fifo module.

Any help please?


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Phone Registration :(

Alexander Jankowsky
In reply to this post by JustForVoip

 

There is also Sipgrep. I find Sipgrep is very simple to use.

 

Always check this when using opensipsctl ul show, to see if anything changes,

do you always consistently get exactly the same errors each and every time you boot.

 

Maybe you can get hold of some used Voip phones. That makes it a lot more interesting.

You might say if you are still running a virtual machine or are now on a dedicated install.

What version of Opensips. What version of Linux.

Sometimes that might be important to know.

 

Alex

 

 

From: Users [mailto:[hidden email]] On Behalf Of Voice TAC
Sent: Thursday, 8 June 2017 7:21 AM
To: OpenSIPS users mailling list
Subject: [OpenSIPS-Users] Phone Registration :(

 

Hello,

I'm totally new with OpenSIPS and I manged to install it and adjust the configuration script. However, I tried to register a phone using X-Lite and ZOPIPER but I could not.

I tried to sniff using ngrep but I did not find any SIP messages. I used the following command:
 
ngrep -pqtw byline port 5060 >sip_Messages_Debug.sip


===============


In addition, I used the opensipsctl ul show command but I got:

ERROR: /tmp/opensips_fifo does not exist
ERROR: Make sure you have the line 'modparam("mi_fifo", "fifo_name", "/tmp/opensips_fifo")' in your config
ERROR: and also have loaded the mi_fifo module.

Any help please?


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Phone Registration :(

JustForVoip
In reply to this post by Rik Broers
This is the output of ps command:

root@OpenSIPS:~# /etc/init.d/opensips start
[ ok ] Starting opensips (via systemctl): opensips.service.
root@OpenSIPS:~#


I can not see the IP addresses.


On Thu, Jun 8, 2017 at 10:38 AM, Rik Broers <[hidden email]> wrote:

Some basic things:

 

Are the opensips processes running when you check with ps?

Is your firewall configured/opened correct?

Do you see opensips listening on port 5060 and correct interface when you check with netstat -ulpn?

 

Also a tip for troubleshooting the script flow, enable script_trace or put xlog commands everywhere.

http://www.opensips.org/Documentation/Script-CoreFunctions-2-3#toc43

 

For the error you pasted related to the fifo command, you can do exactly as the error says and check if the mod_param and load module are in the script.

 

For errors related to starting opensips, you can refer to your syslog as that is where opensips will log by default. They are pretty self explanatory most of the time just as the mi_fifo error shows ;)

 

Good luck!

Regards,

Met vriendelijke groet,

Rik Broers
Voice Engineer

 

Van: Users [mailto:[hidden email]] Namens Voice TAC
Verzonden: 07 June 2017 23:51
Aan: OpenSIPS users mailling list <[hidden email]>
Onderwerp: [OpenSIPS-Users] Phone Registration :(

 

Hello,

I'm totally new with OpenSIPS and I manged to install it and adjust the configuration script. However, I tried to register a phone using X-Lite and ZOPIPER but I could not.

I tried to sniff using ngrep but I did not find any SIP messages. I used the following command:
 
ngrep -pqtw byline port 5060 >sip_Messages_Debug.sip


===============


In addition, I used the opensipsctl ul show command but I got:

ERROR: /tmp/opensips_fifo does not exist
ERROR: Make sure you have the line 'modparam("mi_fifo", "fifo_name", "/tmp/opensips_fifo")' in your config
ERROR: and also have loaded the mi_fifo module.

Any help please?


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Phone Registration :(

JustForVoip
In reply to this post by Alexander Jankowsky
The output of opensipsctl ul show is as below:

root@OpenSIPS:~#
root@OpenSIPS:~# opensipsctl ul show
ERROR: /tmp/opensips_fifo does not exist
ERROR: Make sure you have the line 'modparam("mi_fifo", "fifo_name", "/tmp/opensips_fifo")' in your config
ERROR: and also have loaded the mi_fifo module.
root@OpenSIPS:~#


Any help please?



On Thu, Jun 8, 2017 at 3:30 PM, Alexander Jankowsky <[hidden email]> wrote:

 

There is also Sipgrep. I find Sipgrep is very simple to use.

 

Always check this when using opensipsctl ul show, to see if anything changes,

do you always consistently get exactly the same errors each and every time you boot.

 

Maybe you can get hold of some used Voip phones. That makes it a lot more interesting.

You might say if you are still running a virtual machine or are now on a dedicated install.

What version of Opensips. What version of Linux.

Sometimes that might be important to know.

 

Alex

 

 

From: Users [mailto:[hidden email]] On Behalf Of Voice TAC
Sent: Thursday, 8 June 2017 7:21 AM
To: OpenSIPS users mailling list
Subject: [OpenSIPS-Users] Phone Registration :(

 

Hello,

I'm totally new with OpenSIPS and I manged to install it and adjust the configuration script. However, I tried to register a phone using X-Lite and ZOPIPER but I could not.

I tried to sniff using ngrep but I did not find any SIP messages. I used the following command:
 
ngrep -pqtw byline port 5060 >sip_Messages_Debug.sip


===============


In addition, I used the opensipsctl ul show command but I got:

ERROR: /tmp/opensips_fifo does not exist
ERROR: Make sure you have the line 'modparam("mi_fifo", "fifo_name", "/tmp/opensips_fifo")' in your config
ERROR: and also have loaded the mi_fifo module.

Any help please?


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Phone Registration :(

Bogdan-Andrei Iancu-2
Hi,

As Rik asked - are you sure your OpenSIPS is actually running ?

Run in a shell, on your server : "ps auxw | grep opensips"

Regards,
Bogdan-Andrei Iancu
  OpenSIPS Founder and Developer
  http://www.opensips-solutions.com

OpenSIPS Bootcamp 2017, Houston, US
  http://opensips.org/training/OpenSIPS_Bootcamp_2017.html
On 06/10/2017 12:11 AM, Voice TAC wrote:
The output of opensipsctl ul show is as below:

root@OpenSIPS:~#
root@OpenSIPS:~# opensipsctl ul show
ERROR: /tmp/opensips_fifo does not exist
ERROR: Make sure you have the line 'modparam("mi_fifo", "fifo_name", "/tmp/opensips_fifo")' in your config
ERROR: and also have loaded the mi_fifo module.
root@OpenSIPS:~#


Any help please?



On Thu, Jun 8, 2017 at 3:30 PM, Alexander Jankowsky <[hidden email]> wrote:

 

There is also Sipgrep. I find Sipgrep is very simple to use.

 

Always check this when using opensipsctl ul show, to see if anything changes,

do you always consistently get exactly the same errors each and every time you boot.

 

Maybe you can get hold of some used Voip phones. That makes it a lot more interesting.

You might say if you are still running a virtual machine or are now on a dedicated install.

What version of Opensips. What version of Linux.

Sometimes that might be important to know.

 

Alex

 

 

From: Users [mailto:[hidden email]] On Behalf Of Voice TAC
Sent: Thursday, 8 June 2017 7:21 AM
To: OpenSIPS users mailling list
Subject: [OpenSIPS-Users] Phone Registration :(

 

Hello,

I'm totally new with OpenSIPS and I manged to install it and adjust the configuration script. However, I tried to register a phone using X-Lite and ZOPIPER but I could not.

I tried to sniff using ngrep but I did not find any SIP messages. I used the following command:
 
ngrep -pqtw byline port 5060 >sip_Messages_Debug.sip


===============


In addition, I used the opensipsctl ul show command but I got:

ERROR: /tmp/opensips_fifo does not exist
ERROR: Make sure you have the line 'modparam("mi_fifo", "fifo_name", "/tmp/opensips_fifo")' in your config
ERROR: and also have loaded the mi_fifo module.

Any help please?


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Loading...