Presence Issue

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Presence Issue

ASHWINI NAIDU
Hi all,

    The opensips crashes due to presence problem. I have appended the log of the opensips

Sep 25 20:33:03 rtp /sbin/opensips[5225]: NOTICE:presence:mod_init: initializing module ...
Sep 25 20:33:03 rtp /sbin/opensips[5225]: ERROR:presence:restore_db_subs: bad format for stored sockinfo string
Sep 25 20:33:03 rtp /sbin/opensips[5225]: ERROR:presence:mod_init: restoring subscribe info from database
Sep 25 20:33:03 rtp /sbin/opensips[5225]: ERROR:core:init_mod: failed to initialize module presence
Sep 25 20:33:03 rtp /sbin/opensips[5225]: ERROR:core:main: error while initializing modules
Sep 25 20:33:03 rtp /sbin/opensips[5225]: NOTICE:presence:destroy: destroy module ...
Sep 25 20:33:03 rtp /sbin/opensips[5225]: ERROR:dialog:use_dialog_table: invalid database handle


   

--
Thanking You,
Ashwini BR Naidu

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Presence Issue

Saúl Ibarra Corretgé-2
How are you loading the presnce modules? Please paste your config
file's relevant section.


--
/Saúl
http://www.saghul.net | http://www.sipdoc.net

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Presence Issue

ASHWINI NAIDU
/* Modules For Presence Support */
loadmodule "presence.so"
loadmodule "presence_xml.so"
loadmodule "presence_mwi.so"


# ----- presence params (Simple configuration)-----
/* uncomment the following lines if you want to enable presence */
modparam("presence|presence_xml", "db_url", "mysql://opensips:[hidden email]/opensips")
modparam("presence_xml", "force_active", 1)
modparam("presence", "server_address", "sip:xxx.xxxx.net:5080")

On Sat, Sep 26, 2009 at 11:14 PM, Saúl Ibarra <[hidden email]> wrote:
How are you loading the presnce modules? Please paste your config
file's relevant section.


--
/Saúl
http://www.saghul.net | http://www.sipdoc.net

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
Thanking You,
Ashwini BR Naidu

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Presence Issue

Saúl Ibarra Corretgé-2
Your configuration seems correct. By reading the error I suspect the
data in the active_watchers table is incorrect. Could you delete the
data from active_watchers table and test again?


--
/Saúl
http://www.saghul.net | http://www.sipdoc.net

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users