Rating engine testing problem using telnet

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Rating engine testing problem using telnet

bay2x1
I have recently upgraded to cdrtool version 6.7.8.  Using the instruction for testing the rating engine I have encountered this problem.  I am wondering what might I have misconfigured. Previously I was able to execute this command and display the call computation. But right now it is only display this:

Duration: 59 s
         App: audio
 Destination: 31650222333
    Customer: domain=example.com

This is the error log on /var/log/messages

May  4 11:09:51 ws16 cdrtool[2251]: ShowPrice From=sip:123@example.com To=sip:0031650222333@example.com Gateway=10.0.0.1 Duration=59
May  4 11:09:52 ws16 cdrtool[2251]: Error: Cannot find rates for callid=, billing party=123@example.com, customer domain=example.com, gateway=10.0.0.1, destination=31650222333, profile=441, app=audio

If I substitute my sip users on the From and To values it only displays 0.
I have no idea on what might be causing this problem...
Reply | Threaded
Open this post in threaded view
|

Re: Rating engine testing problem using telnet

Adrian Georgescu
You need to provide the CallId as well. Check Prepaid API section from

http://cdrtool.ag-projects.com/browser/doc/PREPAID.txt

as it was updated.

Adrian

On May 4, 2009, at 5:17 AM, bay2x1 wrote:

>
> I have recently upgraded to cdrtool version 6.7.8.  Using the  
> instruction for
> testing the rating engine I have encountered this problem.  I am  
> wondering
> what might I have misconfigured. Previously I was able to execute this
> command and display the call computation. But right now it is only  
> display
> this:
>
> Duration: 59 s
>         App: audio
> Destination: 31650222333
>    Customer: domain=example.com
>
> This is the error log on /var/log/messages
>
> May  4 11:09:51 ws16 cdrtool[2251]: ShowPrice From=sip:[hidden email]
> To=sip:[hidden email] Gateway=10.0.0.1 Duration=59
> May  4 11:09:52 ws16 cdrtool[2251]: Error: Cannot find rates for  
> callid=,
> billing party=[hidden email], customer domain=example.com,
> gateway=10.0.0.1, destination=31650222333, profile=441, app=audio
>
> If I substitute my sip users on the From and To values it only  
> displays 0.
> I have no idea on what might be causing this problem...
>
> --
> View this message in context: http://n2.nabble.com/Rating-engine-testing-problem-using-telnet-tp2785440p2785440.html
> Sent from the OpenSIPS - Users mailing list archive at Nabble.com.
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

CDRTools rating calls with a '+' prefix

Darren Sessions-2
In reply to this post by bay2x1
Any hints on how to get CDRTools to properly rate calls that have a  
'+' prefix?

I've tinkered a bit with cdr_generic.php but I keep breaking things.  
I've read something about creating a E164 class, but nothing concrete.  
If that's the case, how do I do that or where are the instructions to  
do that?

I appreciate it,

Cheers,

- Darren

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: CDRTools rating calls with a '+' prefix

Darren Sessions-2
btw, I've tried adding:

"intAccessCode"      => "\+",

to the "opensips_radius" data source in globals.inc, and that gets the  
rating going, but then it prefixes the destination and the signaling  
information (To, Canonical, and Next Hop) on CDR call search output  
with the '\' symbol.

Cheers,

  - D



On May 5, 2009, at 6:03 PM, Darren Sessions wrote:

> Any hints on how to get CDRTools to properly rate calls that have a
> '+' prefix?
>
> I've tinkered a bit with cdr_generic.php but I keep breaking things.
> I've read something about creating a E164 class, but nothing concrete.
> If that's the case, how do I do that or where are the instructions to
> do that?
>
> I appreciate it,
>
> Cheers,
>
> - Darren
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: CDRTools rating calls with a '+' prefix

Darren Sessions-2
Also, new calls that are being rated (that show the '\') are now rated but are missing the name of the location.

i.e

(New Calls that are rated - destination field)
\+44XXXXXXXXX@1.1.1.1

(Old Calls before "intAccessCode"      => "\+" - not rated - destination field) 
+44XXXXXXXXX (United Kingdom 44)
+44XXXXXXXXX (United Kingdom 44)
+44XXXXXXXXX (United Kingdom 44)
+44XXXXXXXXX (United Kingdom 44)
+44XXXXXXXXX (United Kingdom 44)


On May 5, 2009, at 6:12 PM, Darren Sessions wrote:

btw, I've tried adding:

"intAccessCode"      => "\+",

to the "opensips_radius" data source in globals.inc, and that gets the  
rating going, but then it prefixes the destination and the signaling  
information (To, Canonical, and Next Hop) on CDR call search output  
with the '\' symbol.

Cheers,

 - D



On May 5, 2009, at 6:03 PM, Darren Sessions wrote:

Any hints on how to get CDRTools to properly rate calls that have a
'+' prefix?

I've tinkered a bit with cdr_generic.php but I keep breaking things.
I've read something about creating a E164 class, but nothing concrete.
If that's the case, how do I do that or where are the instructions to
do that?

I appreciate it,

Cheers,

- Darren

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users