Re: Fwd: Error on openxcap 1.0.7

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Error on openxcap 1.0.7

Denis Bilenko-3
Hi,

OpenXCAP 1.0.7 is indeed incompatible with python-application 1.1.0.
This will be fixed with the new 1.1.0 release of OpenXCAP that will be uploaded tomorrow.

>
>
> OpenXcap was running but when I upgraded to mediaproxy2.3.4 and upgraded python-application, python-twisted openxcap crashes during run time.  Here is the error log.  Is there some compatibility issues between openxcap and python application and/or python-twisted?
>
>
> Apr 15 07:25:29 ws16 openxcap[4320]: Starting OpenXCAP 1.0.7
> Apr 15 07:25:29 ws16 openxcap[4320]: Supported Root URIs: https://ws16.racequeen.local/xcap-root
> Apr 15 07:25:29 ws16 openxcap[4320]: error: Traceback (most recent call last):
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "/usr/bin/openxcap", line 55, in <module>
> Apr 15 07:25:29 ws16 openxcap[4320]: error:     from xcap.server import XCAPServer
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "/usr/lib/python2.5/site-packages/xcap/server.py", line 17, in <module>
> Apr 15 07:25:29 ws16 openxcap[4320]: error:     from xcap import authentication
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "/usr/lib/python2.5/site-packages/xcap/authentication.py", line 22, in <module>
> Apr 15 07:25:29 ws16 openxcap[4320]: error:     from xcap.appusage import getApplicationForURI, namespaces
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "/usr/lib/python2.5/site-packages/xcap/appusage/__init__.py", line 514, in <module>
> Apr 15 07:25:29 ws16 openxcap[4320]: error:     theStorage = ServerConfig.backend.Storage()
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "/usr/lib/python2.5/site-packages/application/python/util.py", line 35, in __call__
> Apr 15 07:25:29 ws16 openxcap[4320]: error:     return cls._instance_creator(*args, **kw)
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "<string>", line 1, in __init__
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "/usr/lib/python2.5/site-packages/application/python/util.py", line 29, in instance_creator
> Apr 15 07:25:29 ws16 openxcap[4320]: error:     cls._instances[key] = super(Singleton, cls).__call__(*args, **kwargs)
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "/usr/lib/python2.5/site-packages/xcap/interfaces/backend/openser.py", line 56, in __init__
> Apr 15 07:25:29 ws16 openxcap[4320]: error:     self.notifier = Notifier(root_uris[0], ManagementInterface().publish_xcapdiff)
> Apr 15 07:25:29 ws16 openxcap[4320]: error:   File "/usr/lib/python2.5/site-packages/application/python/util.py", line 35, in __call__
> Apr 15 07:25:29 ws16 openxcap[4320]: error:     return cls._instance_creator(*args, **kw)
> Apr 15 07:25:29 ws16 openxcap[4320]: error: TypeError: __init__() takes exactly 2 arguments (1 given)
>


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users