Sip invite sent, not reaching dest from certain phones

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Sip invite sent, not reaching dest from certain phones

S. Rosenberg
I'm pretty new to opensips, I'm having a interesting problem, I use my
opensips for loadbalancing purposes I'm trying to place a call, and
from My linksys phone everything works fine, call comes into opensips
and opensips sends it to my asterisk system and call goes through
properly, from other phone (Aastra) Opensips accept the call, it even
sends it to the Asterisk but in never hits the asterisk server, can
anyone please review the 2 invites and let me know why second invite
gets lost, and how I can fix it

Here is the invite from the Linksys that worked

U 64.69.40.120:5060 -> 68.233.222.9:5060
INVITE sip:61@68.233.222.9:5060 SIP/2.0.
Record-Route: <sip:64.69.40.120;lr=on>.
Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK9857.800b0681.0.
Via: SIP/2.0/UDP
192.168.1.104:5060;rport=5060;received=173.220.6.65;branch=z9hG4bK-4194567e.
From: solhome5 <sip:[hidden email]>;tag=833ac73613f3482o0.
To: <sip:[hidden email]>.
Remote-Party-ID: solhome5
<sip:[hidden email]>;screen=yes;party=calling.
Call-ID: 78a92c07-62e399fe@192.168.1.104.
CSeq: 102 INVITE.
Max-Forwards: 69.
Contact: solhome5 <sip:solhome5@173.220.6.65:5060;nat=yes>.
Expires: 240.
User-Agent: Linksys/SPA2102-5.2.12.
Content-Length: 446.
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER.
Supported: x-sipura, replaces.
Content-Type: application/sdp.

Here is the invite of the Aastra that did not work

U 64.69.40.120:5060 -> 68.233.222.9:5060
INVITE sip:61@68.233.222.9:5060;user=phone SIP/2.0.
Record-Route: <sip:64.69.40.120;lr=on>.
Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK847d.93e9e112.0.
Via: SIP/2.0/UDP
192.168.1.102;rport=32857;received=173.220.6.65;branch=z9hG4bK7d9e53a542fc6ebe6.6e57a6889920eccf1.
Max-Forwards: 69.
From: "test2" <sip:[hidden email]:5060>;tag=ef646132b8.
To: <sip:[hidden email]:5060;user=phone>.
Call-ID: f12b5324f31c0d30.
CSeq: 20777 INVITE.
Allow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, OPTIONS, UPDATE,
PRACK, SUBSCRIBE, INFO.
Allow-Events: talk, hold, conference, LocalModeStatus.
Contact: "test2"
<sip:test2@173.220.6.65:32857;transport=udp;nat=yes>;+sip.instance="<urn:uuid:00000000-0000-1000-8000-00085D2A6C9E>".
Supported: path, 100rel, replaces.
User-Agent: Aastra 57iCT/3.2.2.56.
Content-Type: application/sdp.
Content-Length: 630.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

Brett Nemeroff
On Wed, Sep 21, 2011 at 4:25 PM, Schneur Rosenberg <[hidden email]> wrote:
I'm pretty new to opensips, I'm having a interesting problem, I use my
opensips for loadbalancing purposes I'm trying to place a call, and
from My linksys phone everything works fine, call comes into opensips
and opensips sends it to my asterisk system and call goes through
properly, from other phone (Aastra) Opensips accept the call, it even
sends it to the Asterisk but in never hits the asterisk server, can
anyone please review the 2 invites and let me know why second invite
gets lost, and how I can fix it


Schneur,
Welcome to the community!

So I'm sorry to give you an answer that will probably not help you very much, but if opensips is sending the call to asterisk,. then the problem isn't likely with OpenSIPs.

One thing I did notice was the contact headers are very different. It's like nat support is enabled on one phone and disabled on the other. I'd check that.

Other than that, you need to perform a trace from your asterisk server and see what it sees.

Good Luck!
-Brett
 

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

osiris123d
In reply to this post by S. Rosenberg
These are the INVITES that are coming from your Phones correct?  These won't help to troubleshoot I don't think.  You will need to show the INVITES that are leaving OpenSIPS and heading towards your Asterisk server.

Honestly if your opensips.cfg does the exact same thing for linksys and aastra phones I can't see it being an opensips issue.  That's just a guess since I don't have anything to go on.

On Wed, Sep 21, 2011 at 4:25 PM, Schneur Rosenberg <[hidden email]> wrote:
I'm pretty new to opensips, I'm having a interesting problem, I use my
opensips for loadbalancing purposes I'm trying to place a call, and
from My linksys phone everything works fine, call comes into opensips
and opensips sends it to my asterisk system and call goes through
properly, from other phone (Aastra) Opensips accept the call, it even
sends it to the Asterisk but in never hits the asterisk server, can
anyone please review the 2 invites and let me know why second invite
gets lost, and how I can fix it

Here is the invite from the Linksys that worked

U 64.69.40.120:5060 -> 68.233.222.9:5060
INVITE sip:61@68.233.222.9:5060 SIP/2.0.
Record-Route: <sip:64.69.40.120;lr=on>.
Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK9857.800b0681.0.
Via: SIP/2.0/UDP
192.168.1.104:5060;rport=5060;received=173.220.6.65;branch=z9hG4bK-4194567e.
From: solhome5 <[hidden email]>;tag=833ac73613f3482o0.
To: <[hidden email]>.
Remote-Party-ID: solhome5
<[hidden email]>;screen=yes;party=calling.
Call-ID: [hidden email].
CSeq: 102 INVITE.
Max-Forwards: 69.
Contact: solhome5 <sip:solhome5@173.220.6.65:5060;nat=yes>.
Expires: 240.
User-Agent: Linksys/SPA2102-5.2.12.
Content-Length: 446.
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER.
Supported: x-sipura, replaces.
Content-Type: application/sdp.

Here is the invite of the Aastra that did not work

U 64.69.40.120:5060 -> 68.233.222.9:5060
INVITE sip:61@68.233.222.9:5060;user=phone SIP/2.0.
Record-Route: <sip:64.69.40.120;lr=on>.
Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK847d.93e9e112.0.
Via: SIP/2.0/UDP
192.168.1.102;rport=32857;received=173.220.6.65;branch=z9hG4bK7d9e53a542fc6ebe6.6e57a6889920eccf1.
Max-Forwards: 69.
From: "test2" <sip:test2@...:5060>;tag=ef646132b8.
To: <sip:[hidden email]:5060;user=phone>.
Call-ID: f12b5324f31c0d30.
CSeq: 20777 INVITE.
Allow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, OPTIONS, UPDATE,
PRACK, SUBSCRIBE, INFO.
Allow-Events: talk, hold, conference, LocalModeStatus.
Contact: "test2"
<sip:test2@173.220.6.65:32857;transport=udp;nat=yes>;+sip.instance="<urn:uuid:00000000-0000-1000-8000-00085D2A6C9E>".
Supported: path, 100rel, replaces.
User-Agent: Aastra 57iCT/3.2.2.56.
Content-Type: application/sdp.
Content-Length: 630.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



--
--
*--*--*--*--*--*
Duane
*--*--*--*--*--*
--

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

S. Rosenberg
NO These are the invites going from the opensips to the asterisk NOT
the ones from the phone, I did a ngrep on the asterisk box and the
packet never reaches it, both opensips and asterisk are open no NAT,
the phones are behind a nat as you can see in the sip packets


On Thu, Sep 22, 2011 at 12:37 AM, Duane Larson <[hidden email]> wrote:

> These are the INVITES that are coming from your Phones correct?  These won't
> help to troubleshoot I don't think.  You will need to show the INVITES that
> are leaving OpenSIPS and heading towards your Asterisk server.
>
> Honestly if your opensips.cfg does the exact same thing for linksys and
> aastra phones I can't see it being an opensips issue.  That's just a guess
> since I don't have anything to go on.
>
> On Wed, Sep 21, 2011 at 4:25 PM, Schneur Rosenberg
> <[hidden email]> wrote:
>>
>> I'm pretty new to opensips, I'm having a interesting problem, I use my
>> opensips for loadbalancing purposes I'm trying to place a call, and
>> from My linksys phone everything works fine, call comes into opensips
>> and opensips sends it to my asterisk system and call goes through
>> properly, from other phone (Aastra) Opensips accept the call, it even
>> sends it to the Asterisk but in never hits the asterisk server, can
>> anyone please review the 2 invites and let me know why second invite
>> gets lost, and how I can fix it
>>
>> Here is the invite from the Linksys that worked
>>
>> U 64.69.40.120:5060 -> 68.233.222.9:5060
>> INVITE sip:61@68.233.222.9:5060 SIP/2.0.
>> Record-Route: <sip:64.69.40.120;lr=on>.
>> Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK9857.800b0681.0.
>> Via: SIP/2.0/UDP
>>
>> 192.168.1.104:5060;rport=5060;received=173.220.6.65;branch=z9hG4bK-4194567e.
>> From: solhome5
>> <sip:[hidden email]>;tag=833ac73613f3482o0.
>> To: <sip:[hidden email]>.
>> Remote-Party-ID: solhome5
>> <sip:[hidden email]>;screen=yes;party=calling.
>> Call-ID: 78a92c07-62e399fe@192.168.1.104.
>> CSeq: 102 INVITE.
>> Max-Forwards: 69.
>> Contact: solhome5 <sip:solhome5@173.220.6.65:5060;nat=yes>.
>> Expires: 240.
>> User-Agent: Linksys/SPA2102-5.2.12.
>> Content-Length: 446.
>> Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER.
>> Supported: x-sipura, replaces.
>> Content-Type: application/sdp.
>>
>> Here is the invite of the Aastra that did not work
>>
>> U 64.69.40.120:5060 -> 68.233.222.9:5060
>> INVITE sip:61@68.233.222.9:5060;user=phone SIP/2.0.
>> Record-Route: <sip:64.69.40.120;lr=on>.
>> Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK847d.93e9e112.0.
>> Via: SIP/2.0/UDP
>>
>> 192.168.1.102;rport=32857;received=173.220.6.65;branch=z9hG4bK7d9e53a542fc6ebe6.6e57a6889920eccf1.
>> Max-Forwards: 69.
>> From: "test2" <sip:[hidden email]:5060>;tag=ef646132b8.
>> To: <sip:[hidden email]:5060;user=phone>.
>> Call-ID: f12b5324f31c0d30.
>> CSeq: 20777 INVITE.
>> Allow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, OPTIONS, UPDATE,
>> PRACK, SUBSCRIBE, INFO.
>> Allow-Events: talk, hold, conference, LocalModeStatus.
>> Contact: "test2"
>>
>> <sip:test2@173.220.6.65:32857;transport=udp;nat=yes>;+sip.instance="<urn:uuid:00000000-0000-1000-8000-00085D2A6C9E>".
>> Supported: path, 100rel, replaces.
>> User-Agent: Aastra 57iCT/3.2.2.56.
>> Content-Type: application/sdp.
>> Content-Length: 630.
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
>
> --
> --
> *--*--*--*--*--*
> Duane
> *--*--*--*--*--*
> --
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

vallimamod abdullah
Hi Schneur,

What do you mean precisely by never hitting the asterisk server ?
As your ngrep trace shows, both packets are sent over the wire to the exact same address (68.233.222.9:5060) so they should both reach Asterisk. But it's possible that the latter doesn't treat them the same way, depending on nat issues most of the time (Asterisk send replies to the contact header URI by default if I recall correctly...)

Try to make a ngrep trace on the iface attached to 68.233.222.9 and check if Asterisk does not send the answer to a different IP. Also enable the debug log on the asterisk console to spot any error / warning messages or sip retransmissions.

Hope this would help.

Regards,
-vma
.

On Sep 21, 2011, at 11:43 PM, Schneur Rosenberg wrote:

> NO These are the invites going from the opensips to the asterisk NOT
> the ones from the phone, I did a ngrep on the asterisk box and the
> packet never reaches it, both opensips and asterisk are open no NAT,
> the phones are behind a nat as you can see in the sip packets
>
>
> On Thu, Sep 22, 2011 at 12:37 AM, Duane Larson <[hidden email]> wrote:
>> These are the INVITES that are coming from your Phones correct?  These won't
>> help to troubleshoot I don't think.  You will need to show the INVITES that
>> are leaving OpenSIPS and heading towards your Asterisk server.
>>
>> Honestly if your opensips.cfg does the exact same thing for linksys and
>> aastra phones I can't see it being an opensips issue.  That's just a guess
>> since I don't have anything to go on.
>>
>> On Wed, Sep 21, 2011 at 4:25 PM, Schneur Rosenberg
>> <[hidden email]> wrote:
>>>
>>> I'm pretty new to opensips, I'm having a interesting problem, I use my
>>> opensips for loadbalancing purposes I'm trying to place a call, and
>>> from My linksys phone everything works fine, call comes into opensips
>>> and opensips sends it to my asterisk system and call goes through
>>> properly, from other phone (Aastra) Opensips accept the call, it even
>>> sends it to the Asterisk but in never hits the asterisk server, can
>>> anyone please review the 2 invites and let me know why second invite
>>> gets lost, and how I can fix it
>>>
>>> Here is the invite from the Linksys that worked
>>>
>>> U 64.69.40.120:5060 -> 68.233.222.9:5060
>>> INVITE sip:61@68.233.222.9:5060 SIP/2.0.
>>> Record-Route: <sip:64.69.40.120;lr=on>.
>>> Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK9857.800b0681.0.
>>> Via: SIP/2.0/UDP
>>>
>>> 192.168.1.104:5060;rport=5060;received=173.220.6.65;branch=z9hG4bK-4194567e.
>>> From: solhome5
>>> <sip:[hidden email]>;tag=833ac73613f3482o0.
>>> To: <sip:[hidden email]>.
>>> Remote-Party-ID: solhome5
>>> <sip:[hidden email]>;screen=yes;party=calling.
>>> Call-ID: 78a92c07-62e399fe@192.168.1.104.
>>> CSeq: 102 INVITE.
>>> Max-Forwards: 69.
>>> Contact: solhome5 <sip:solhome5@173.220.6.65:5060;nat=yes>.
>>> Expires: 240.
>>> User-Agent: Linksys/SPA2102-5.2.12.
>>> Content-Length: 446.
>>> Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER.
>>> Supported: x-sipura, replaces.
>>> Content-Type: application/sdp.
>>>
>>> Here is the invite of the Aastra that did not work
>>>
>>> U 64.69.40.120:5060 -> 68.233.222.9:5060
>>> INVITE sip:61@68.233.222.9:5060;user=phone SIP/2.0.
>>> Record-Route: <sip:64.69.40.120;lr=on>.
>>> Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK847d.93e9e112.0.
>>> Via: SIP/2.0/UDP
>>>
>>> 192.168.1.102;rport=32857;received=173.220.6.65;branch=z9hG4bK7d9e53a542fc6ebe6.6e57a6889920eccf1.
>>> Max-Forwards: 69.
>>> From: "test2" <sip:[hidden email]:5060>;tag=ef646132b8.
>>> To: <sip:[hidden email]:5060;user=phone>.
>>> Call-ID: f12b5324f31c0d30.
>>> CSeq: 20777 INVITE.
>>> Allow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, OPTIONS, UPDATE,
>>> PRACK, SUBSCRIBE, INFO.
>>> Allow-Events: talk, hold, conference, LocalModeStatus.
>>> Contact: "test2"
>>>
>>> <sip:test2@173.220.6.65:32857;transport=udp;nat=yes>;+sip.instance="<urn:uuid:00000000-0000-1000-8000-00085D2A6C9E>".
>>> Supported: path, 100rel, replaces.
>>> User-Agent: Aastra 57iCT/3.2.2.56.
>>> Content-Type: application/sdp.
>>> Content-Length: 630.
>>>
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>>
>> --
>> --
>> *--*--*--*--*--*
>> Duane
>> *--*--*--*--*--*
>> --
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

S. Rosenberg
The packet does not reach asterisk, I did a ngrep on the asterisk
server and not a single packet arrives from the opensips when using
the Aastra phone, therefore its not sending back anything, the
asterisk CLI is also quiet nothing whatsoever :-(

On Thu, Sep 22, 2011 at 1:03 AM, Vallimamod ABDULLAH
<[hidden email]> wrote:

> Hi Schneur,
>
> What do you mean precisely by never hitting the asterisk server ?
> As your ngrep trace shows, both packets are sent over the wire to the exact same address (68.233.222.9:5060) so they should both reach Asterisk. But it's possible that the latter doesn't treat them the same way, depending on nat issues most of the time (Asterisk send replies to the contact header URI by default if I recall correctly...)
>
> Try to make a ngrep trace on the iface attached to 68.233.222.9 and check if Asterisk does not send the answer to a different IP. Also enable the debug log on the asterisk console to spot any error / warning messages or sip retransmissions.
>
> Hope this would help.
>
> Regards,
> -vma
> .
>
> On Sep 21, 2011, at 11:43 PM, Schneur Rosenberg wrote:
>
>> NO These are the invites going from the opensips to the asterisk NOT
>> the ones from the phone, I did a ngrep on the asterisk box and the
>> packet never reaches it, both opensips and asterisk are open no NAT,
>> the phones are behind a nat as you can see in the sip packets
>>
>>
>> On Thu, Sep 22, 2011 at 12:37 AM, Duane Larson <[hidden email]> wrote:
>>> These are the INVITES that are coming from your Phones correct?  These won't
>>> help to troubleshoot I don't think.  You will need to show the INVITES that
>>> are leaving OpenSIPS and heading towards your Asterisk server.
>>>
>>> Honestly if your opensips.cfg does the exact same thing for linksys and
>>> aastra phones I can't see it being an opensips issue.  That's just a guess
>>> since I don't have anything to go on.
>>>
>>> On Wed, Sep 21, 2011 at 4:25 PM, Schneur Rosenberg
>>> <[hidden email]> wrote:
>>>>
>>>> I'm pretty new to opensips, I'm having a interesting problem, I use my
>>>> opensips for loadbalancing purposes I'm trying to place a call, and
>>>> from My linksys phone everything works fine, call comes into opensips
>>>> and opensips sends it to my asterisk system and call goes through
>>>> properly, from other phone (Aastra) Opensips accept the call, it even
>>>> sends it to the Asterisk but in never hits the asterisk server, can
>>>> anyone please review the 2 invites and let me know why second invite
>>>> gets lost, and how I can fix it
>>>>
>>>> Here is the invite from the Linksys that worked
>>>>
>>>> U 64.69.40.120:5060 -> 68.233.222.9:5060
>>>> INVITE sip:61@68.233.222.9:5060 SIP/2.0.
>>>> Record-Route: <sip:64.69.40.120;lr=on>.
>>>> Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK9857.800b0681.0.
>>>> Via: SIP/2.0/UDP
>>>>
>>>> 192.168.1.104:5060;rport=5060;received=173.220.6.65;branch=z9hG4bK-4194567e.
>>>> From: solhome5
>>>> <sip:[hidden email]>;tag=833ac73613f3482o0.
>>>> To: <sip:[hidden email]>.
>>>> Remote-Party-ID: solhome5
>>>> <sip:[hidden email]>;screen=yes;party=calling.
>>>> Call-ID: 78a92c07-62e399fe@192.168.1.104.
>>>> CSeq: 102 INVITE.
>>>> Max-Forwards: 69.
>>>> Contact: solhome5 <sip:solhome5@173.220.6.65:5060;nat=yes>.
>>>> Expires: 240.
>>>> User-Agent: Linksys/SPA2102-5.2.12.
>>>> Content-Length: 446.
>>>> Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER.
>>>> Supported: x-sipura, replaces.
>>>> Content-Type: application/sdp.
>>>>
>>>> Here is the invite of the Aastra that did not work
>>>>
>>>> U 64.69.40.120:5060 -> 68.233.222.9:5060
>>>> INVITE sip:61@68.233.222.9:5060;user=phone SIP/2.0.
>>>> Record-Route: <sip:64.69.40.120;lr=on>.
>>>> Via: SIP/2.0/UDP 64.69.40.120;branch=z9hG4bK847d.93e9e112.0.
>>>> Via: SIP/2.0/UDP
>>>>
>>>> 192.168.1.102;rport=32857;received=173.220.6.65;branch=z9hG4bK7d9e53a542fc6ebe6.6e57a6889920eccf1.
>>>> Max-Forwards: 69.
>>>> From: "test2" <sip:[hidden email]:5060>;tag=ef646132b8.
>>>> To: <sip:[hidden email]:5060;user=phone>.
>>>> Call-ID: f12b5324f31c0d30.
>>>> CSeq: 20777 INVITE.
>>>> Allow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, OPTIONS, UPDATE,
>>>> PRACK, SUBSCRIBE, INFO.
>>>> Allow-Events: talk, hold, conference, LocalModeStatus.
>>>> Contact: "test2"
>>>>
>>>> <sip:test2@173.220.6.65:32857;transport=udp;nat=yes>;+sip.instance="<urn:uuid:00000000-0000-1000-8000-00085D2A6C9E>".
>>>> Supported: path, 100rel, replaces.
>>>> User-Agent: Aastra 57iCT/3.2.2.56.
>>>> Content-Type: application/sdp.
>>>> Content-Length: 630.
>>>>
>>>> _______________________________________________
>>>> Users mailing list
>>>> [hidden email]
>>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>>
>>> --
>>> --
>>> *--*--*--*--*--*
>>> Duane
>>> *--*--*--*--*--*
>>> --
>>>
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

Brett Nemeroff
In reply to this post by vallimamod abdullah
On Wed, Sep 21, 2011 at 5:03 PM, Vallimamod ABDULLAH <[hidden email]> wrote:
Hi Schneur,

What do you mean precisely by never hitting the asterisk server ?
As your ngrep trace shows, both packets are sent over the wire to the exact same address (68.233.222.9:5060) so they should both reach Asterisk. But it's possible that the latter doesn't treat them the same way, depending on nat issues most of the time (Asterisk send replies to the contact header URI by default if I recall correctly...)

I think asterisk does reply to the contact header and they are obviously different in the two traces. You'll see one is port 5060 and the other is based on some NAT translation. Need to find out why those are different..

-Brett
 

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

S. Rosenberg
If the packet would of reached asterisk then you might of been right,
problem is a ngrep trace does not show a single packet reaching it.

On Thu, Sep 22, 2011 at 1:09 AM, Brett Nemeroff <[hidden email]> wrote:

> On Wed, Sep 21, 2011 at 5:03 PM, Vallimamod ABDULLAH
> <[hidden email]> wrote:
>>
>> Hi Schneur,
>>
>> What do you mean precisely by never hitting the asterisk server ?
>> As your ngrep trace shows, both packets are sent over the wire to the
>> exact same address (68.233.222.9:5060) so they should both reach Asterisk.
>> But it's possible that the latter doesn't treat them the same way, depending
>> on nat issues most of the time (Asterisk send replies to the contact header
>> URI by default if I recall correctly...)
>
> I think asterisk does reply to the contact header and they are obviously
> different in the two traces. You'll see one is port 5060 and the other is
> based on some NAT translation. Need to find out why those are different..
>
> -Brett
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

vallimamod abdullah
In reply to this post by S. Rosenberg
Then you have any intermediate device (known or unknown) that does filtering or mangling in some way…
Try to trace the sip packet on every hop between the 2 servers to see how far it goes.

Regards,
- vma
.

On Sep 22, 2011, at 12:07 AM, Schneur Rosenberg wrote:

> The packet does not reach asterisk, I did a ngrep on the asterisk
> server and not a single packet arrives from the opensips when using
> the Aastra phone, therefore its not sending back anything, the
> asterisk CLI is also quiet nothing whatsoever :-(
>
> On Thu, Sep 22, 2011 at 1:03 AM, Vallimamod ABDULLAH
> <[hidden email]> wrote:
>> Hi Schneur,
>>
>> What do you mean precisely by never hitting the asterisk server ?
>> As your ngrep trace shows, both packets are sent over the wire to the exact same address (68.233.222.9:5060) so they should both reach Asterisk. But it's possible that the latter doesn't treat them the same way, depending on nat issues most of the time (Asterisk send replies to the contact header URI by default if I recall correctly...)
>>
>> Try to make a ngrep trace on the iface attached to 68.233.222.9 and check if Asterisk does not send the answer to a different IP. Also enable the debug log on the asterisk console to spot any error / warning messages or sip retransmissions.
>>
>> Hope this would help.


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

S. Rosenberg
both systems are on the open internet, I have no firewalls etc on any
of the systems, I will try another 2 systems with same configurations
and see what happens.

On Thu, Sep 22, 2011 at 1:24 AM, Vallimamod ABDULLAH
<[hidden email]> wrote:

> Then you have any intermediate device (known or unknown) that does filtering or mangling in some way…
> Try to trace the sip packet on every hop between the 2 servers to see how far it goes.
>
> Regards,
> - vma
> .
>
> On Sep 22, 2011, at 12:07 AM, Schneur Rosenberg wrote:
>
>> The packet does not reach asterisk, I did a ngrep on the asterisk
>> server and not a single packet arrives from the opensips when using
>> the Aastra phone, therefore its not sending back anything, the
>> asterisk CLI is also quiet nothing whatsoever :-(
>>
>> On Thu, Sep 22, 2011 at 1:03 AM, Vallimamod ABDULLAH
>> <[hidden email]> wrote:
>>> Hi Schneur,
>>>
>>> What do you mean precisely by never hitting the asterisk server ?
>>> As your ngrep trace shows, both packets are sent over the wire to the exact same address (68.233.222.9:5060) so they should both reach Asterisk. But it's possible that the latter doesn't treat them the same way, depending on nat issues most of the time (Asterisk send replies to the contact header URI by default if I recall correctly...)
>>>
>>> Try to make a ngrep trace on the iface attached to 68.233.222.9 and check if Asterisk does not send the answer to a different IP. Also enable the debug log on the asterisk console to spot any error / warning messages or sip retransmissions.
>>>
>>> Hope this would help.
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Sip invite sent, not reaching dest from certain phones

SamyGo
Looking at the INVITEs I bet the packet is reaching the asterisk server(I second Abdullah) - try run a tcpdump of whole interface at asterisk server and see if you're getting anything from OpenSIPs.

Also I found that "rport=32857" is different on the second one so replies may get lost on that port !

Regards,
-Sammy

On Thu, Sep 22, 2011 at 3:40 AM, Schneur Rosenberg <[hidden email]> wrote:
both systems are on the open internet, I have no firewalls etc on any
of the systems, I will try another 2 systems with same configurations
and see what happens.

On Thu, Sep 22, 2011 at 1:24 AM, Vallimamod ABDULLAH
<[hidden email]> wrote:
> Then you have any intermediate device (known or unknown) that does filtering or mangling in some way…
> Try to trace the sip packet on every hop between the 2 servers to see how far it goes.
>
> Regards,
> - vma
> .
>
> On Sep 22, 2011, at 12:07 AM, Schneur Rosenberg wrote:
>
>> The packet does not reach asterisk, I did a ngrep on the asterisk
>> server and not a single packet arrives from the opensips when using
>> the Aastra phone, therefore its not sending back anything, the
>> asterisk CLI is also quiet nothing whatsoever :-(
>>
>> On Thu, Sep 22, 2011 at 1:03 AM, Vallimamod ABDULLAH
>> <[hidden email]> wrote:
>>> Hi Schneur,
>>>
>>> What do you mean precisely by never hitting the asterisk server ?
>>> As your ngrep trace shows, both packets are sent over the wire to the exact same address (68.233.222.9:5060) so they should both reach Asterisk. But it's possible that the latter doesn't treat them the same way, depending on nat issues most of the time (Asterisk send replies to the contact header URI by default if I recall correctly...)
>>>
>>> Try to make a ngrep trace on the iface attached to 68.233.222.9 and check if Asterisk does not send the answer to a different IP. Also enable the debug log on the asterisk console to spot any error / warning messages or sip retransmissions.
>>>
>>> Hope this would help.
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users