Still having problems with osipsconsole and reinit databases

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Still having problems with osipsconsole and reinit databases

Joan-2-2
Good morning,

I tried again to do the osipsconsole reinit, and I'm still having problems  ..
Altought it seems to work from what it outputs:

OpenSIPS$:reinit opensips
Password for root (If no password is needed just hit Enter, else
introduce password): pass
Database was successfuly dropped!
Password for root (If no password is needed just hit Enter, else
introduce password): pass
Creating database opensips ...
Database opensips....created
Creating core table: standard...
Creating core table: acc...
Creating core table: lcr...
Creating core table: domain...
Creating core table: group...
Creating core table: permissions...
Creating core table: registrar...
Creating core table: usrloc...
Creating core table: msilo...
Creating core table: alias_db...
Creating core table: uri_db...
Creating core table: speeddial...
Creating core table: avpops...
Creating core table: auth_db...
Creating core table: pdt...
Creating core table: dialog...
Creating core table: dispatcher...
Creating core table: dialplan...
Core OpenSIPS tables succesfully created.
Install presence related tables? (y/n): n



It just dropped all my tables, but it didn't create anything, so I had
to manually recreate them all...
For any testing, just drop me a line ..

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still having problems with osipsconsole and reinit databases

Joan-2-2
2009/2/10 Joan <[hidden email]>:

> Good morning,
>
> I tried again to do the osipsconsole reinit, and I'm still having problems  ..
> Altought it seems to work from what it outputs:
>
> OpenSIPS$:reinit opensips
> Password for root (If no password is needed just hit Enter, else
> introduce password): pass
> Database was successfuly dropped!
> Password for root (If no password is needed just hit Enter, else
> introduce password): pass
> Creating database opensips ...
> Database opensips....created
> Creating core table: standard...
> Creating core table: acc...
> Creating core table: lcr...
> Creating core table: domain...
> Creating core table: group...
> Creating core table: permissions...
> Creating core table: registrar...
> Creating core table: usrloc...
> Creating core table: msilo...
> Creating core table: alias_db...
> Creating core table: uri_db...
> Creating core table: speeddial...
> Creating core table: avpops...
> Creating core table: auth_db...
> Creating core table: pdt...
> Creating core table: dialog...
> Creating core table: dispatcher...
> Creating core table: dialplan...
> Core OpenSIPS tables succesfully created.
> Install presence related tables? (y/n): n
>
>
>
> It just dropped all my tables, but it didn't create anything, so I had
> to manually recreate them all...
> For any testing, just drop me a line ..
>
I just saw that when doing the reinit, it also destroyed the users I
had and recreated them. Maybe it's the expected behavior, but the
ideal thing would to to keep the users and the database (in case you
are on a restricted environment) and drop/recreate all the tables ..

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still having problems with osipsconsole and reinit databases

Iulia Bublea-2
Joan wrote:

> 2009/2/10 Joan <[hidden email]>:
>  
>> Good morning,
>>
>> I tried again to do the osipsconsole reinit, and I'm still having problems  ..
>> Altought it seems to work from what it outputs:
>>
>> OpenSIPS$:reinit opensips
>> Password for root (If no password is needed just hit Enter, else
>> introduce password): pass
>> Database was successfuly dropped!
>> Password for root (If no password is needed just hit Enter, else
>> introduce password): pass
>> Creating database opensips ...
>> Database opensips....created
>> Creating core table: standard...
>> Creating core table: acc...
>> Creating core table: lcr...
>> Creating core table: domain...
>> Creating core table: group...
>> Creating core table: permissions...
>> Creating core table: registrar...
>> Creating core table: usrloc...
>> Creating core table: msilo...
>> Creating core table: alias_db...
>> Creating core table: uri_db...
>> Creating core table: speeddial...
>> Creating core table: avpops...
>> Creating core table: auth_db...
>> Creating core table: pdt...
>> Creating core table: dialog...
>> Creating core table: dispatcher...
>> Creating core table: dialplan...
>> Core OpenSIPS tables succesfully created.
>> Install presence related tables? (y/n): n
>>
>>
>>
>> It just dropped all my tables, but it didn't create anything, so I had
>> to manually recreate them all...
>> For any testing, just drop me a line ..
>>
>>    
> I just saw that when doing the reinit, it also destroyed the users I
> had and recreated them. Maybe it's the expected behavior, but the
> ideal thing would to to keep the users and the database (in case you
> are on a restricted environment) and drop/recreate all the tables ..
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  
Hi Joan,

There was another revision immediately after the one I told you about.
That should work. If not, I will have a look again. Though I have tested
it and for me it worked fine.


Regards,
Iulia

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still having problems with osipsconsole and reinit databases

Joan-2-2
2009/2/10 Iulia Bublea <[hidden email]>:

> Joan wrote:
>>
>> 2009/2/10 Joan <[hidden email]>:
>>
>>>
>>> Good morning,
>>>
>>> I tried again to do the osipsconsole reinit, and I'm still having
>>> problems  ..
>>> Altought it seems to work from what it outputs:
>>>
>>> OpenSIPS$:reinit opensips
>>> Password for root (If no password is needed just hit Enter, else
>>> introduce password): pass
>>> Database was successfuly dropped!
>>> Password for root (If no password is needed just hit Enter, else
>>> introduce password): pass
>>> Creating database opensips ...
>>> Database opensips....created
>>> Creating core table: standard...
>>> Creating core table: acc...
>>> Creating core table: lcr...
>>> Creating core table: domain...
>>> Creating core table: group...
>>> Creating core table: permissions...
>>> Creating core table: registrar...
>>> Creating core table: usrloc...
>>> Creating core table: msilo...
>>> Creating core table: alias_db...
>>> Creating core table: uri_db...
>>> Creating core table: speeddial...
>>> Creating core table: avpops...
>>> Creating core table: auth_db...
>>> Creating core table: pdt...
>>> Creating core table: dialog...
>>> Creating core table: dispatcher...
>>> Creating core table: dialplan...
>>> Core OpenSIPS tables succesfully created.
>>> Install presence related tables? (y/n): n
>>>
>>>
>>>
>>> It just dropped all my tables, but it didn't create anything, so I had
>>> to manually recreate them all...
>>> For any testing, just drop me a line ..
>>>
>>>
>>
>> I just saw that when doing the reinit, it also destroyed the users I
>> had and recreated them. Maybe it's the expected behavior, but the
>> ideal thing would to to keep the users and the database (in case you
>> are on a restricted environment) and drop/recreate all the tables ..
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>
>>
>
> Hi Joan,
>
> There was another revision immediately after the one I told you about. That
> should work. If not, I will have a look again. Though I have tested it and
> for me it worked fine.
>
The problem when passing the password seems to be totally solved,
there are no more errors with that.
What is happening now, it's something different. It's seem by the
messages that it's working, but the only part working is the dropping
of the tables, not the step when it creates everything...
>
>
> Regards,
> Iulia
>

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Still having problems with osipsconsole and reinit databases

Iulia Bublea-2
Joan wrote:

> 2009/2/10 Iulia Bublea <[hidden email]>:
>  
>> Joan wrote:
>>    
>>> 2009/2/10 Joan <[hidden email]>:
>>>
>>>      
>>>> Good morning,
>>>>
>>>> I tried again to do the osipsconsole reinit, and I'm still having
>>>> problems  ..
>>>> Altought it seems to work from what it outputs:
>>>>
>>>> OpenSIPS$:reinit opensips
>>>> Password for root (If no password is needed just hit Enter, else
>>>> introduce password): pass
>>>> Database was successfuly dropped!
>>>> Password for root (If no password is needed just hit Enter, else
>>>> introduce password): pass
>>>> Creating database opensips ...
>>>> Database opensips....created
>>>> Creating core table: standard...
>>>> Creating core table: acc...
>>>> Creating core table: lcr...
>>>> Creating core table: domain...
>>>> Creating core table: group...
>>>> Creating core table: permissions...
>>>> Creating core table: registrar...
>>>> Creating core table: usrloc...
>>>> Creating core table: msilo...
>>>> Creating core table: alias_db...
>>>> Creating core table: uri_db...
>>>> Creating core table: speeddial...
>>>> Creating core table: avpops...
>>>> Creating core table: auth_db...
>>>> Creating core table: pdt...
>>>> Creating core table: dialog...
>>>> Creating core table: dispatcher...
>>>> Creating core table: dialplan...
>>>> Core OpenSIPS tables succesfully created.
>>>> Install presence related tables? (y/n): n
>>>>
>>>>
>>>>
>>>> It just dropped all my tables, but it didn't create anything, so I had
>>>> to manually recreate them all...
>>>> For any testing, just drop me a line ..
>>>>
>>>>
>>>>        
>>> I just saw that when doing the reinit, it also destroyed the users I
>>> had and recreated them. Maybe it's the expected behavior, but the
>>> ideal thing would to to keep the users and the database (in case you
>>> are on a restricted environment) and drop/recreate all the tables ..
>>>
>>> _______________________________________________
>>> Users mailing list
>>> [hidden email]
>>> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>>>
>>>
>>>      
>> Hi Joan,
>>
>> There was another revision immediately after the one I told you about. That
>> should work. If not, I will have a look again. Though I have tested it and
>> for me it worked fine.
>>
>>    
> The problem when passing the password seems to be totally solved,
> there are no more errors with that.
> What is happening now, it's something different. It's seem by the
> messages that it's working, but the only part working is the dropping
> of the tables, not the step when it creates everything...
>  
>> Regards,
>> Iulia
>>
>>    
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>
>  

Hi,

I have look into the script and there indeed was a problem. I have fixed
it now and hopefully there will be no problem with this issue.

Regards,
Iulia

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users