TLS

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

TLS

michel freiha
Dear All,

I made the below configuration on opensips.cfg regarding using TLS mode

disable_tls=no
listen=tls:87.232.133.11:443
tls_verify_server =1
tls_verify_client =0
tls_require_client_certificate = 0
tls_method = TLSv1
tls_certificate ="/tmp/ca.crt"
tls_private_key ="/tmp/ca.key"

When trying to register on the server using TLs I got request timeout on the client side

Any Help please

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: TLS

Bogdan-Andrei Iancu
Hi Michel,

check with tcpdump the TCP connection - see if the client is able to
connect via TCP to opensips. If so, go further and check the logs from
opensips to see what happened.

Regards,
Bogdan

michel freiha wrote:

> Dear All,
>
> I made the below configuration on opensips.cfg regarding using TLS mode
>
> disable_tls=no
> listen=tls:87.232.133.11:443 <http://87.232.133.11:443>
> tls_verify_server =1
> tls_verify_client =0
> tls_require_client_certificate = 0
> tls_method = TLSv1
> tls_certificate ="/tmp/ca.crt"
> tls_private_key ="/tmp/ca.key"
>
> When trying to register on the server using TLs I got request timeout
> on the client side
>
> Any Help please
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


--
Bogdan-Andrei Iancu
www.voice-system.ro


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users