Touble installing Mediaproxy 2.1.0

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Touble installing Mediaproxy 2.1.0

Juha Teräslahti
Hello everyone!

I'm trying to install Mediaproxy 2.1.0 on a Fedora Core 9 and I get the following error while compiling:

./setup.py build
running build
running build_py
running build_ext
building 'mediaproxy.interfaces.system._conntrack' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fPIC -DMODULE_VERSION=2.1.0 -DIPTABLES_VERSION="1.4.0" -Imediaproxy/interfaces/system/libiptc/include -I/usr/include/python2.4 -c mediaproxy/interfaces/system/_conntrack.c -o build/temp.linux-i686-2.4/mediaproxy/interfaces/system/_conntrack.o
mediaproxy/interfaces/system/_conntrack.c: In function ‘ForwardingRule_init’:
mediaproxy/interfaces/system/_conntrack.c:224: error: ‘NFCT_SOPT_SETUP_REPLY’ undeclared (first use in this function)
mediaproxy/interfaces/system/_conntrack.c:224: error: (Each undeclared identifier is reported only once
mediaproxy/interfaces/system/_conntrack.c:224: error: for each function it appears in.)
error: command 'gcc' failed with exit status 1

Am I missing a package ? I've ran out of options here so I'm turning to you for assistance.

Thanks.

...................................................................
Luukku Plus paketilla pääset eroon tila- ja turvallisuusongelmista.
Hanki Luukku Plus ja helpotat elämääsi. http://www.mtv3.fi/luukku

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Touble installing Mediaproxy 2.1.0

Jeff Pyle
Juha,

From the looks of your errors there, it appears you're missing the libnetfilter_conntrack and libnetfilter_conntrack-devel packages.

But, even if you install those as I have done, I believe you will run into dependency problems with some of the TLS libraries.  The recommendation from the AG Projects folks has been to run the "unstable" build of Debian, as they have packages built for that and only that distribution.

If you do manage to work your way past the other dependencies, be sure to post to the list how you did it on Fedora.



- Jeff


-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Juha Teräslahti
Sent: Monday, November 17, 2008 9:17 AM
To: [hidden email]
Subject: [OpenSIPS-Users] Touble installing Mediaproxy 2.1.0

Hello everyone!

I'm trying to install Mediaproxy 2.1.0 on a Fedora Core 9 and I get the following error while compiling:

./setup.py build
running build
running build_py
running build_ext
building 'mediaproxy.interfaces.system._conntrack' extension gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fPIC -DMODULE_VERSION=2.1.0 -DIPTABLES_VERSION="1.4.0" -Imediaproxy/interfaces/system/libiptc/include -I/usr/include/python2.4 -c mediaproxy/interfaces/system/_conntrack.c -o build/temp.linux-i686-2.4/mediaproxy/interfaces/system/_conntrack.o
mediaproxy/interfaces/system/_conntrack.c: In function 'ForwardingRule_init':
mediaproxy/interfaces/system/_conntrack.c:224: error: 'NFCT_SOPT_SETUP_REPLY' undeclared (first use in this function)
mediaproxy/interfaces/system/_conntrack.c:224: error: (Each undeclared identifier is reported only once
mediaproxy/interfaces/system/_conntrack.c:224: error: for each function it appears in.)
error: command 'gcc' failed with exit status 1

Am I missing a package ? I've ran out of options here so I'm turning to you for assistance.

Thanks.

...................................................................
Luukku Plus paketilla pääset eroon tila- ja turvallisuusongelmista.
Hanki Luukku Plus ja helpotat elämääsi. http://www.mtv3.fi/luukku

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Touble installing Mediaproxy 2.1.0

Dan Pascu
In reply to this post by Juha Teräslahti
On Monday 17 November 2008, Juha Teräslahti wrote:

> Hello everyone!
>
> I'm trying to install Mediaproxy 2.1.0 on a Fedora Core 9 and I get the
> following error while compiling:
>
> ./setup.py build
> running build
> running build_py
> running build_ext
> building 'mediaproxy.interfaces.system._conntrack' extension
> gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
> -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
> --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
> -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fPIC
> -DMODULE_VERSION=2.1.0 -DIPTABLES_VERSION="1.4.0"
> -Imediaproxy/interfaces/system/libiptc/include -I/usr/include/python2.4
> -c mediaproxy/interfaces/system/_conntrack.c -o
> build/temp.linux-i686-2.4/mediaproxy/interfaces/system/_conntrack.o
> mediaproxy/interfaces/system/_conntrack.c: In function
> ‘ForwardingRule_init’: mediaproxy/interfaces/system/_conntrack.c:224:
> error: ‘NFCT_SOPT_SETUP_REPLY’ undeclared (first use in this function)
> mediaproxy/interfaces/system/_conntrack.c:224: error: (Each undeclared
> identifier is reported only once
> mediaproxy/interfaces/system/_conntrack.c:224: error: for each function
> it appears in.) error: command 'gcc' failed with exit status 1
>
> Am I missing a package ? I've ran out of options here so I'm turning to
> you for assistance.

Read INSTALL.

--
Dan

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Touble installing Mediaproxy 2.1.0

Dan Pascu
In reply to this post by Jeff Pyle
On Monday 17 November 2008, Jeff Pyle wrote:

> Juha,
>
> From the looks of your errors there, it appears you're missing the
> libnetfilter_conntrack and libnetfilter_conntrack-devel packages.
>
> But, even if you install those as I have done, I believe you will run
> into dependency problems with some of the TLS libraries.  The
> recommendation from the AG Projects folks has been to run the
> "unstable" build of Debian, as they have packages built for that and
> only that distribution.

Actually Debian (testing or unstable), or Ubuntu (8.10) should work just
fine, and we recommend them because it is the easiest way to get
mediaproxy up and running with minimal effort.

Otherwise there is nothing specific in mediaproxy to Debian or Ubuntu. It
depends on a number of packages, so if you install all the dependencies
it should work on any linux distribution. If some distribution doesn't
provide them, one can always install from source.

--
Dan

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users