Upgrade CDRTool to 6.7.1 - problems

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade CDRTool to 6.7.1 - problems

Carlo Dimaggio
Hi all,

I have some problems with the upgrade of CDRTool from 6.6.10 to 6.7.1.
I have downloaded the debian package (my machine is an ubuntu server)  
and followed the instruction included in http://download.ag-projects.com/CDRTool/doc/Upgrade.txt 
.
Now I can start (and reload) successfully cdrtool but if I connect to  
the web interface this error is shown:

"Error initializing CDRTool datasource sip_trace"

Before the upgrade all was fine (mysql user/pass, permissions,  
configurations,...). There are no errors in syslog.

How can I debug the problem?

Thanks,
Carlo

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade CDRTool to 6.7.1 - problems

Carlo Dimaggio
Anybody can help me?
Where I can find more informations about this "datasource ERROR"?

Thank you!


Il giorno 23/dic/08, alle ore 22:23, Carlo Dimaggio ha scritto:

> Hi all,
>
> I have some problems with the upgrade of CDRTool from 6.6.10 to 6.7.1.
> I have downloaded the debian package (my machine is an ubuntu server)
> and followed the instruction included in http://download.ag-projects.com/CDRTool/doc/Upgrade.txt
> .
> Now I can start (and reload) successfully cdrtool but if I connect to
> the web interface this error is shown:
>
> "Error initializing CDRTool datasource sip_trace"
>
> Before the upgrade all was fine (mysql user/pass, permissions,
> configurations,...). There are no errors in syslog.
>
> How can I debug the problem?
>
> Thanks,
> Carlo

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade CDRTool to 6.7.1 - problems

Adrian Georgescu
Carlo,

From your description it looks like an incorrect configuration in global.inc.

If I were you I would start with a fresh  global.inc.simple.sample and port the settings from the old version.

Adrian


On Dec 29, 2008, at 3:41 AM, Carlo Dimaggio wrote:

Anybody can help me?
Where I can find more informations about this "datasource ERROR"?

Thank you!


Il giorno 23/dic/08, alle ore 22:23, Carlo Dimaggio ha scritto:

Hi all,

I have some problems with the upgrade of CDRTool from 6.6.10 to 6.7.1.
I have downloaded the debian package (my machine is an ubuntu server)
and followed the instruction included in http://download.ag-projects.com/CDRTool/doc/Upgrade.txt
.
Now I can start (and reload) successfully cdrtool but if I connect to
the web interface this error is shown:

"Error initializing CDRTool datasource sip_trace"

Before the upgrade all was fine (mysql user/pass, permissions,
configurations,...). There are no errors in syslog.

How can I debug the problem?

Thanks,
Carlo

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade CDRTool to 6.7.1 - problems

Carlo Dimaggio

Il giorno 29/dic/08, alle ore 15:51, Adrian Georgescu ha scritto:

> Carlo,
>
> From your description it looks like an incorrect configuration in  
> global.inc.
>
> If I were you I would start with a fresh  global.inc.simple.sample  
> and port the settings from the old version.
>
> Adrian

Hi Adrian,

Thank you for your reply.
I created another global.inc starting from global.inc.simple.sample  
but the problem still remained.
After that, I have dropped the cdrtool db and created another through  
the new script setup_mysql.sh. (ver. 6.7.1)

Now the problem is solved and I can connect to the web interface. So I  
think that there was some differences between the database schemas...


Regards,
Carlo

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade CDRTool to 6.7.1 - problems

Carlo Dimaggio
In reply to this post by Adrian Georgescu

Il giorno 29/dic/08, alle ore 15:51, Adrian Georgescu ha scritto:

> Carlo,
>
> From your description it looks like an incorrect configuration in  
> global.inc.
>
> If I were you I would start with a fresh  global.inc.simple.sample  
> and port the settings from the old version.
>
> Adrian


Hi Adrian,

Thank you for your reply.
I created another global.inc starting from global.inc.simple.sample  
but the problem still remained.
After that, I have dropped the cdrtool db and created another through  
the new script setup_mysql.sh. (ver. 6.7.1)

Now the problem is solved and I can connect to the web interface. So I  
think that there was some differences between the database schemas...


Regards,
Carlo

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade CDRTool to 6.7.1 - problems

Adrian Georgescu
In reply to this post by Carlo Dimaggio
Yes, the differences in mysql schema between different versions are logged here:


Regards,
Adrian

On Jan 8, 2009, at 11:14 AM, Carlo Dimaggio wrote:


Il giorno 29/dic/08, alle ore 15:51, Adrian Georgescu ha scritto:

Carlo,

From your description it looks like an incorrect configuration in  
global.inc.

If I were you I would start with a fresh  global.inc.simple.sample  
and port the settings from the old version.

Adrian

Hi Adrian,

Thank you for your reply.
I created another global.inc starting from global.inc.simple.sample  
but the problem still remained.
After that, I have dropped the cdrtool db and created another through  
the new script setup_mysql.sh. (ver. 6.7.1)

Now the problem is solved and I can connect to the web interface. So I  
think that there was some differences between the database schemas...


Regards,
Carlo

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users