XMLRPC again

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

XMLRPC again

Matti Zemack

Hi all,

 

 

Getting to use mi_xmlrpc is becoming really tough (at least for me).

 

On my standard OpenSips OpenSUSE 11.1 I couldn’t even get 1.5 to compile, probably because I’ve messed up the system and can’t get xmlrpc-c-devel to install… Not much to do I suppose, just start a new VmWare instance.

 

On a new CentOS 5.2 instance I finally got all xmlrpc bits in place and could compile with xmlrpc enabled. But I couldn’t start opensips with the standard 1.5 opensips.cfg including the mi_xmlrpc.so added.

It gave me an error I’ve seen here on the list, but with no solution (or at least I couldn’t find one…):

 

ERROR:core:sr_load_module: could not open module </usr/local/lib/opensips/modules/mi_xmlrpc.so>: /usr/local/lib/opensips/modules/mi_xmlrpc.so: undefined symbol: xmlrpc_array_size

 

Thankful for any help!

 

 

Best Regards,

Matti Zemack, Stockholm, Sweden


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: XMLRPC again

Bogdan-Andrei Iancu
Hi Matti,

what xmlrpc-c3 version is installed on CentOS 5.2 ?

Regards,
Bogdan

Matti Zemack wrote:

>
> Hi all,
>
> Getting to use mi_xmlrpc is becoming really tough (at least for me).
>
> On my standard OpenSips OpenSUSE 11.1 I couldn’t even get 1.5 to
> compile, probably because I’ve messed up the system and can’t get
> xmlrpc-c-devel to install… Not much to do I suppose, just start a new
> VmWare instance.
>
> On a new CentOS 5.2 instance I finally got all xmlrpc bits in place
> and could compile with xmlrpc enabled. But I couldn’t start opensips
> with the standard 1.5 opensips.cfg including the mi_xmlrpc.so added.
>
> It gave me an error I’ve seen here on the list, but with no solution
> (or at least I couldn’t find one…):
>
> ERROR:core:sr_load_module: could not open module
> </usr/local/lib/opensips/modules/mi_xmlrpc.so>:
> /usr/local/lib/opensips/modules/mi_xmlrpc.so: undefined symbol:
> xmlrpc_array_size
>
> Thankful for any help!
>
> Best Regards,
>
> Matti Zemack, Stockholm, Sweden
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users