dialog and load_balance problems

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

dialog and load_balance problems

Jorge Ortea
Hi,

when i restart opensips returns this:

Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: NOTICE:signaling:mod_init: initializing module ...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:sl:mod_init: Initializing StateLess engine
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:tm:mod_init: TM - initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:rr:mod_init: rr - initializing
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:maxfwd:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:usrloc:ul_init_locks: locks array size 512
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:registrar:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:textops:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:acc:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:auth:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:auth_db:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:dialog:mod_init: Dialog module - initializing
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:dialog:read_dialog_profiles: profile <lbXTDM> does not exist anymore
Mar  6 15:20:03 ghss02 last message repeated 2 times
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:avpops:avpops_init: initializing...
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:load_balancer:mod_init: Load-Balancer module - initializing
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:parse_resources_list: empty list of resorces
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:add_lb_dsturi: failed to parse resourse string <>
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:lb_db_load_data: failed to add destination 5 -> skipping
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:uac:mod_init: initializing...
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:textops:hname_fixup: using hdr type name <Referred-By>
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:core:probe_max_receive_buffer: using a UDP receive buffer of 255 kb
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:core:probe_max_receive_buffer: using a UDP receive buffer of 255 kb


Now opensips is working fine but three days ago i had problems with load_balancer module, when tried find a mediagateway as always by the way load_balance function, returned null. I had that restart opensips.


Thanks.
Regards.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: dialog and load_balance problems

SamyGo
ERROR:load_balancer:parse_resources_list: empty list of resorces  
If there were no changes made in the load-balancer table and you get theis error randomly then i doubt interconnectivity with DB, maybe the DB conn pool exhausted !!

On Wed, Mar 7, 2012 at 2:44 PM, Jorge Ortea <[hidden email]> wrote:
Hi,

when i restart opensips returns this:

Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: NOTICE:signaling:mod_init: initializing module ...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:sl:mod_init: Initializing StateLess engine
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:tm:mod_init: TM - initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:rr:mod_init: rr - initializing
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:maxfwd:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:usrloc:ul_init_locks: locks array size 512
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:registrar:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:textops:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:acc:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:auth:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:auth_db:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:dialog:mod_init: Dialog module - initializing
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:dialog:read_dialog_profiles: profile <lbXTDM> does not exist anymore
Mar  6 15:20:03 ghss02 last message repeated 2 times
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:avpops:avpops_init: initializing...
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:load_balancer:mod_init: Load-Balancer module - initializing
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:parse_resources_list: empty list of resorces
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:add_lb_dsturi: failed to parse resourse string <>
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:lb_db_load_data: failed to add destination 5 -> skipping
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:uac:mod_init: initializing...
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:textops:hname_fixup: using hdr type name <Referred-By>
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:core:probe_max_receive_buffer: using a UDP receive buffer of 255 kb
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:core:probe_max_receive_buffer: using a UDP receive buffer of 255 kb


Now opensips is working fine but three days ago i had problems with load_balancer module, when tried find a mediagateway as always by the way load_balance function, returned null. I had that restart opensips.


Thanks.
Regards.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: dialog and load_balance problems

Bogdan-Andrei Iancu-2
In reply to this post by Jorge Ortea
Hi Jorge,

About the original problem, on the mediagw which is not used - you can use the "lb_list" MI command to see what is the status of each entry in the LB:
        opensipsctl fifo lb_list
Maybe your GW is set as inactive . Please see:
        http://www.opensips.org/html/docs/modules/1.7.x/load_balancer.html#id249005

Now, about the restart issue: it seams you have an invalid entry in DB for LB module - entry ID "5" has actually no list of resources - check your DB.

Regards,
Bogdan

On 03/07/2012 11:44 AM, Jorge Ortea wrote:
Hi,

when i restart opensips returns this:

Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: NOTICE:signaling:mod_init: initializing module ...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:sl:mod_init: Initializing StateLess engine
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:tm:mod_init: TM - initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:rr:mod_init: rr - initializing
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:maxfwd:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:usrloc:ul_init_locks: locks array size 512
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:registrar:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:textops:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:acc:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:auth:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:auth_db:mod_init: initializing...
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:dialog:mod_init: Dialog module - initializing
Mar  6 15:20:02 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:dialog:read_dialog_profiles: profile <lbXTDM> does not exist anymore
Mar  6 15:20:03 ghss02 last message repeated 2 times
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:avpops:avpops_init: initializing...
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:load_balancer:mod_init: Load-Balancer module - initializing
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:parse_resources_list: empty list of resorces
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:add_lb_dsturi: failed to parse resourse string <>
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: ERROR:load_balancer:lb_db_load_data: failed to add destination 5 -> skipping
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:uac:mod_init: initializing...
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:textops:hname_fixup: using hdr type name <Referred-By>
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:core:probe_max_receive_buffer: using a UDP receive buffer of 255 kb
Mar  6 15:20:03 ghss02 /usr/local/opensips/sbin/opensips[29437]: INFO:core:probe_max_receive_buffer: using a UDP receive buffer of 255 kb


Now opensips is working fine but three days ago i had problems with load_balancer module, when tried find a mediagateway as always by the way load_balance function, returned null. I had that restart opensips.


Thanks.
Regards.
_______________________________________________ Users mailing list [hidden email] http://lists.opensips.org/cgi-bin/mailman/listinfo/users


-- 
Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users