issue with compiling opensips

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

issue with compiling opensips

Miha
Hello

which deb pack should I install regarding this error: https://pastebin.com/c4RHMbcT

I installed this package " libjson-c-dev" but it is not ok.


tnx
miha

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: issue with compiling opensips

Răzvan Crainea-2
Are you using an older version of OpenSIPS? This should have been fixed in all supported versions.

Best regards,
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/15/2017 01:52 PM, Miha wrote:
Hello

which deb pack should I install regarding this error: https://pastebin.com/c4RHMbcT

I installed this package " libjson-c-dev" but it is not ok.


tnx
miha


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: issue with compiling opensips

Miha
hello Razvan

no, i downloaded it from opensips on git, i did this yesterday (2.3)


br
miha

On 16/11/2017 11:23, Răzvan Crainea wrote:
Are you using an older version of OpenSIPS? This should have been fixed in all supported versions.

Best regards,
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/15/2017 01:52 PM, Miha wrote:
Hello

which deb pack should I install regarding this error: https://pastebin.com/c4RHMbcT

I installed this package " libjson-c-dev" but it is not ok.


tnx
miha


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: issue with compiling opensips

Răzvan Crainea-2
What version of libjson are you using, and what OS are you running?
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/16/2017 01:49 PM, Miha wrote:
hello Razvan

no, i downloaded it from opensips on git, i did this yesterday (2.3)


br
miha

On 16/11/2017 11:23, Răzvan Crainea wrote:
Are you using an older version of OpenSIPS? This should have been fixed in all supported versions.

Best regards,
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/15/2017 01:52 PM, Miha wrote:
Hello

which deb pack should I install regarding this error: https://pastebin.com/c4RHMbcT

I installed this package " libjson-c-dev" but it is not ok.


tnx
miha


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: issue with compiling opensips

Miha
hey

this is what i have:

cat /etc/issue
Debian GNU/Linux 9 \n \


apt list libjson*
Listing... Done
libjson-any-perl/stable 1.39-1 all
libjson-c-dev/stable,now 0.12.1-1.1 amd64 [installed]
libjson-c-doc/stable 0.12.1-1.1 all
libjson-c3/stable,now 0.12.1-1.1 amd64 [installed,automatic]
libjson-glib-1.0-0/stable,now 1.2.6-1 amd64 [installed,automatic]
libjson-glib-1.0-common/stable,now 1.2.6-1 all [installed,automatic]
libjson-glib-dev/stable 1.2.6-1 amd64
libjson-glib-doc/stable 1.2.6-1 all
libjson-java/stable 2.4-3 all
libjson-maybexs-perl/stable 1.003008-1 all
libjson-multivalueordered-perl/stable 0.005-1 all
libjson-perl/stable 2.90-1 all
libjson-pointer-perl/stable 0.07-1 all
libjson-pp-perl/stable 2.27400-1 all
libjson-rpc-perl/stable 1.06-2 all
libjson-simple-doc/stable 1.1.1-4 all
libjson-simple-java/stable 1.1.1-4 all
libjson-smart-java/stable 2.2-1 all
libjson-types-perl/stable 0.05-1 all
libjson-validator-perl/stable 0.92+dfsg-1 all
libjson-webtoken-perl/stable 0.10-2 all
libjson-xs-perl/stable 3.030-1 amd64
libjsoncpp-dev/stable,now 1.7.4-3 amd64 [installed]
libjsoncpp-doc/stable 1.7.4-3 all
libjsoncpp1/stable,now 1.7.4-3 amd64 [installed,automatic]
libjsonm-ocaml/stable 0.9.1-2 amd64
libjsonm-ocaml-dev/stable 0.9.1-2 amd64
libjsonm-ocaml-doc/stable 0.9.1-2 all
libjsonp-java/stable 1.0.4-1 all
libjsonp-java-doc/stable 1.0.4-1 all
libjsonpath-java/stable 2.0.0-3 all
libjsonrpccpp-client0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-client0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-common0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-common0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-dev/stable 0.7.0-1+b2 amd64
libjsonrpccpp-server0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-server0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-stub0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-stub0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-tools/stable 0.7.0-1+b2 amd64




On 16/11/2017 16:47, Răzvan Crainea wrote:
What version of libjson are you using, and what OS are you running?
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/16/2017 01:49 PM, Miha wrote:
hello Razvan

no, i downloaded it from opensips on git, i did this yesterday (2.3)


br
miha

On 16/11/2017 11:23, Răzvan Crainea wrote:
Are you using an older version of OpenSIPS? This should have been fixed in all supported versions.

Best regards,
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/15/2017 01:52 PM, Miha wrote:
Hello

which deb pack should I install regarding this error: https://pastebin.com/c4RHMbcT

I installed this package " libjson-c-dev" but it is not ok.


tnx
miha


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: issue with compiling opensips

ketank
Hello Miha,

Please verify below dependency installed on your server or not.

libjson-c-dev
libjson-c-doc
libjson-c2
libjson-c2-dbg
libjson0
libjson0-dev



On Fri, Nov 17, 2017 at 12:58 PM, Miha <[hidden email]> wrote:
hey

this is what i have:

cat /etc/issue
Debian GNU/Linux 9 \n \


apt list libjson*
Listing... Done
libjson-any-perl/stable 1.39-1 all
libjson-c-dev/stable,now 0.12.1-1.1 amd64 [installed]
libjson-c-doc/stable 0.12.1-1.1 all
libjson-c3/stable,now 0.12.1-1.1 amd64 [installed,automatic]
libjson-glib-1.0-0/stable,now 1.2.6-1 amd64 [installed,automatic]
libjson-glib-1.0-common/stable,now 1.2.6-1 all [installed,automatic]
libjson-glib-dev/stable 1.2.6-1 amd64
libjson-glib-doc/stable 1.2.6-1 all
libjson-java/stable 2.4-3 all
libjson-maybexs-perl/stable 1.003008-1 all
libjson-multivalueordered-perl/stable 0.005-1 all
libjson-perl/stable 2.90-1 all
libjson-pointer-perl/stable 0.07-1 all
libjson-pp-perl/stable 2.27400-1 all
libjson-rpc-perl/stable 1.06-2 all
libjson-simple-doc/stable 1.1.1-4 all
libjson-simple-java/stable 1.1.1-4 all
libjson-smart-java/stable 2.2-1 all
libjson-types-perl/stable 0.05-1 all
libjson-validator-perl/stable 0.92+dfsg-1 all
libjson-webtoken-perl/stable 0.10-2 all
libjson-xs-perl/stable 3.030-1 amd64
libjsoncpp-dev/stable,now 1.7.4-3 amd64 [installed]
libjsoncpp-doc/stable 1.7.4-3 all
libjsoncpp1/stable,now 1.7.4-3 amd64 [installed,automatic]
libjsonm-ocaml/stable 0.9.1-2 amd64
libjsonm-ocaml-dev/stable 0.9.1-2 amd64
libjsonm-ocaml-doc/stable 0.9.1-2 all
libjsonp-java/stable 1.0.4-1 all
libjsonp-java-doc/stable 1.0.4-1 all
libjsonpath-java/stable 2.0.0-3 all
libjsonrpccpp-client0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-client0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-common0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-common0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-dev/stable 0.7.0-1+b2 amd64
libjsonrpccpp-server0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-server0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-stub0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-stub0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-tools/stable 0.7.0-1+b2 amd64




On 16/11/2017 16:47, Răzvan Crainea wrote:
What version of libjson are you using, and what OS are you running?
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/16/2017 01:49 PM, Miha wrote:
hello Razvan

no, i downloaded it from opensips on git, i did this yesterday (2.3)


br
miha

On 16/11/2017 11:23, Răzvan Crainea wrote:
Are you using an older version of OpenSIPS? This should have been fixed in all supported versions.

Best regards,
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/15/2017 01:52 PM, Miha wrote:
Hello

which deb pack should I install regarding this error: https://pastebin.com/c4RHMbcT

I installed this package " libjson-c-dev" but it is not ok.


tnx
miha


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: issue with compiling opensips

Miha
hello

is there on www where written which libraries are all mandatory (debian)?


tnx
miha

On 17/11/2017 08:42, Ketan Kothari wrote:
Hello Miha,

Please verify below dependency installed on your server or not.

libjson-c-dev
libjson-c-doc
libjson-c2
libjson-c2-dbg
libjson0
libjson0-dev



On Fri, Nov 17, 2017 at 12:58 PM, Miha <[hidden email]> wrote:
hey

this is what i have:

cat /etc/issue
Debian GNU/Linux 9 \n \


apt list libjson*
Listing... Done
libjson-any-perl/stable 1.39-1 all
libjson-c-dev/stable,now 0.12.1-1.1 amd64 [installed]
libjson-c-doc/stable 0.12.1-1.1 all
libjson-c3/stable,now 0.12.1-1.1 amd64 [installed,automatic]
libjson-glib-1.0-0/stable,now 1.2.6-1 amd64 [installed,automatic]
libjson-glib-1.0-common/stable,now 1.2.6-1 all [installed,automatic]
libjson-glib-dev/stable 1.2.6-1 amd64
libjson-glib-doc/stable 1.2.6-1 all
libjson-java/stable 2.4-3 all
libjson-maybexs-perl/stable 1.003008-1 all
libjson-multivalueordered-perl/stable 0.005-1 all
libjson-perl/stable 2.90-1 all
libjson-pointer-perl/stable 0.07-1 all
libjson-pp-perl/stable 2.27400-1 all
libjson-rpc-perl/stable 1.06-2 all
libjson-simple-doc/stable 1.1.1-4 all
libjson-simple-java/stable 1.1.1-4 all
libjson-smart-java/stable 2.2-1 all
libjson-types-perl/stable 0.05-1 all
libjson-validator-perl/stable 0.92+dfsg-1 all
libjson-webtoken-perl/stable 0.10-2 all
libjson-xs-perl/stable 3.030-1 amd64
libjsoncpp-dev/stable,now 1.7.4-3 amd64 [installed]
libjsoncpp-doc/stable 1.7.4-3 all
libjsoncpp1/stable,now 1.7.4-3 amd64 [installed,automatic]
libjsonm-ocaml/stable 0.9.1-2 amd64
libjsonm-ocaml-dev/stable 0.9.1-2 amd64
libjsonm-ocaml-doc/stable 0.9.1-2 all
libjsonp-java/stable 1.0.4-1 all
libjsonp-java-doc/stable 1.0.4-1 all
libjsonpath-java/stable 2.0.0-3 all
libjsonrpccpp-client0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-client0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-common0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-common0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-dev/stable 0.7.0-1+b2 amd64
libjsonrpccpp-server0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-server0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-stub0/stable 0.7.0-1+b2 amd64
libjsonrpccpp-stub0-dbg/stable 0.7.0-1+b2 amd64
libjsonrpccpp-tools/stable 0.7.0-1+b2 amd64




On 16/11/2017 16:47, Răzvan Crainea wrote:
What version of libjson are you using, and what OS are you running?
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/16/2017 01:49 PM, Miha wrote:
hello Razvan

no, i downloaded it from opensips on git, i did this yesterday (2.3)


br
miha

On 16/11/2017 11:23, Răzvan Crainea wrote:
Are you using an older version of OpenSIPS? This should have been fixed in all supported versions.

Best regards,
Răzvan Crainea
OpenSIPS Developer
www.opensips-solutions.com
On 11/15/2017 01:52 PM, Miha wrote:
Hello

which deb pack should I install regarding this error: https://pastebin.com/c4RHMbcT

I installed this package " libjson-c-dev" but it is not ok.


tnx
miha


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users