mmgeoip

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

mmgeoip

k1028
I am getting unknown when using mmgeoip. I tried both the citylite version and city version from maxmind. Thank You

version: opensips 1.7.2-notls (x86_64/linux)

if (mmg_lookup("lon:lat:cc:reg","$si","$avp(lat_lon)")) {
                xlog("GEOIP: $(avp(lat_lon)[0]) $(avp(lat_lon)[1]) $(avp(lat_lon)[2]) $(avp(lat_lon)[3]) $(avp(lat_lon)[4]) $avp(lat_lon)");
}

DBG:mmgeoip:mmg_lookup_cmd: 'x.x.x.x'--> 'Unknown'.
GEOIP: <null> <null> <null> <null> <null> <null>
Reply | Threaded
Open this post in threaded view
|

Re: mmgeoip

Bogdan-Andrei Iancu-2
Hi,

1) do you get any warnings/errors from mmgeoip at startup / query time ?

2) are you able to get proper response from mmgeoip using CLI ?

3) are you able to retrieve any attribute at all ?

Regards,

Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com


On 06/29/2012 09:16 PM, k1028 wrote:

> I am getting unknown when using mmgeoip. I tried both the citylite version
> and city version from maxmind. Thank You
>
> version: opensips 1.7.2-notls (x86_64/linux)
>
> if (mmg_lookup("lon:lat:cc:reg","$si","$avp(lat_lon)")) {
>                  xlog("GEOIP: $(avp(lat_lon)[0]) $(avp(lat_lon)[1])
> $(avp(lat_lon)[2]) $(avp(lat_lon)[3]) $(avp(lat_lon)[4]) $avp(lat_lon)");
> }
>
> DBG:mmgeoip:mmg_lookup_cmd: 'x.x.x.x'-->  'Unknown'.
> GEOIP:<null>  <null>  <null>  <null>  <null>  <null>
>
> --
> View this message in context: http://opensips-open-sip-server.1449251.n2.nabble.com/mmgeoip-tp7580620.html
> Sent from the OpenSIPS - Users mailing list archive at Nabble.com.
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: mmgeoip

k1028
Hi Bodgan, Thank you very much. We got it to work. The problem is we have the country edition loaded instead of the city edition. See you at cluecon. Thank You