[ opensips-Bugs-2186836 ] PUA_BLA fails for UA's registered behind NAT

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ opensips-Bugs-2186836 ] PUA_BLA fails for UA's registered behind NAT

SourceForge.net
Bugs item #2186836, was opened at 2008-10-22 15:26
Message generated for change (Comment added) made by ibc_sf
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2186836&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: modules
Group: trunk
Status: Open
Resolution: Fixed
Priority: 5
Private: No
Submitted By: Iñaki Baz (ibc_sf)
Assigned to: Anca Vamanu (anca_vamanu)
Summary: PUA_BLA fails for UA's registered behind NAT

Initial Comment:
I'm trying PUA_BLA with phones behind NAT. When the REGISTER arrives I do "fix_nated_register()" so the original Contact:
  Contact: <sip:user@192.168.1.100:5060>
becomes:
  Contact: <sip:user@192.168.1.100:5060;received=80.80.12.54:34567>


After that I do "bla_set_flag()" so PUA_BLA generates a SUBSCRIBE that should arrive to the UA, but PUA_BLA generates it:

  SUBSCRIBE sip:user@192.168.1.100:5060

So this SUBSCRIBE will never arrive to the UAC since it's a private IP. The SUBSCRIBE should be sent to the "received" parameter (added before) but I don't know how to achieve it.

A dirty workaround is doing "fix_natted_contact()" before "bla_set_flag()" but this is a bad idea since it will change the stored Contact URI in "location" table (and normally UA's need to see their same private IP in
the RURI of requests sent from the proxy).

As a suggestion, PUA_BLA should take in account the "received" parameter added in Contact during registration to send the SUBSCRIBE.

----------------------------------------------------------------------

>Comment By: Iñaki Baz (ibc_sf)
Date: 2008-12-10 17:48

Message:
Hi Anca, unfortunatelly I have no access to Polycom phones anymore so I
cannot test the new code.
Could somebody test it?

----------------------------------------------------------------------

Comment By: Iñaki Baz (ibc_sf)
Date: 2008-12-08 15:51

Message:
Sorry, I had this scenario temporaly dissabled. Let me to check it during
this week.

Thanks a lot.

----------------------------------------------------------------------

Comment By: Anca Vamanu (anca_vamanu)
Date: 2008-12-08 13:40

Message:
Hi Inaki,

Can you please provide a feedback to this as I would like to close this
bug report.

regards,
Anca

----------------------------------------------------------------------

Comment By: Iñaki Baz (ibc_sf)
Date: 2008-10-22 15:43

Message:
Thanks a lot, I'll try it ASAP and comment here the result.

----------------------------------------------------------------------

Comment By: Anca Vamanu (anca_vamanu)
Date: 2008-10-22 15:31

Message:
Hi Inaki,

I have just commited a fix for this. Please test and let me know if it
works.

regards,
Anca Vamanu


----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2186836&group_id=232389

_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel