[ opensips-Bugs-2591935 ] Error in sending NOTIFY for PUBLISH in RLS mode

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ opensips-Bugs-2591935 ] Error in sending NOTIFY for PUBLISH in RLS mode

SourceForge.net
Bugs item #2591935, was opened at 2009-02-12 08:31
Message generated for change (Comment added) made by anca_vamanu
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2591935&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: modules
Group: trunk
Status: Open
Resolution: Fixed
Priority: 5
Private: No
Submitted By: Nathan (rmnathan)
Assigned to: Anca Vamanu (anca_vamanu)
Summary: Error in sending NOTIFY for PUBLISH in RLS mode

Initial Comment:
Hi
When opensips got publish for the user(say E1_1) which has in two list subscriptions, it is sending notify to one user only.
For example:
UE2_1 list will have 2 entry uri like E1_1,E1_2
UE2_2 list will have 2 entry uri like E1_2,E1_1

S2_1 subscribe to UE2_1
S2_2 subscribe to UE2_2
If E1_1 send publish, opensips sends notify to S2_1 only. But it should send notify to S2_2 too.

Please find the attached pcap file for detailed call flow.

Regards,
rmnathan


----------------------------------------------------------------------

>Comment By: Anca Vamanu (anca_vamanu)
Date: 2009-02-18 17:17

Message:
Hi Rmnathan,

Thank you for this report.
Indeed, you were right- not all update Notifies were sent due to a bug in
the code. I have fixed it. Please update to the new svn version and test it
yourself. I will wait for your feedback before closing this bug report.

regards,
Anca



----------------------------------------------------------------------

Comment By: Anca Vamanu (anca_vamanu)
Date: 2009-02-18 17:17

Message:
Hi Rmnathan,

Thank you for this report.
Indeed, you were right- not all update Notifies were sent due to a bug in
the code. I have fixed it. Please update to the new svn version and test it
yourself. I will wait for your feedback before closing this bug report.

regards,
Anca



----------------------------------------------------------------------

Comment By: Anca Vamanu (anca_vamanu)
Date: 2009-02-18 17:16

Message:
Hi Rmnathan,

Thank you for this report.
Indeed, you were right- not all update Notifies were sent due to a bug in
the code. I have fixed it. Please update to the new svn version and test it
yourself. I will wait for your feedback before closing this bug report.

regards,
Anca



----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2591935&group_id=232389

_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel