[ opensips-Bugs-2641464 ] engage_media_proxy failes if called after create_dialog

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ opensips-Bugs-2641464 ] engage_media_proxy failes if called after create_dialog

SourceForge.net
Bugs item #2641464, was opened at 2009-02-26 13:16
Message generated for change (Tracker Item Submitted) made by Item Submitter
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2641464&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: modules
Group: None
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Thomas Gelf (thomas_gelf)
Assigned to: Nobody/Anonymous (nobody)
Summary: engage_media_proxy failes if called after create_dialog

Initial Comment:
If I correctly understood mediaproxy.c it installs a callback handler __dialog_created, responsible for setting up the other handlers for this dialog (using dlg_api.register_dlgcb).

However, if you called create_dialog() before, "dialog_created" will not be fired again if you are using engage_media_proxy().

Proposed solution: either add a note to current documentation ("...do NOT use create_dialog when using engage_media_proxy...") or find a way to catch this situation in EngageMediaProxy (maybe: if dlg started, immediately register dialog callbacks).

Best regards,
Thomas Gelf


----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2641464&group_id=232389

_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel