[ opensips-Bugs-2685700 ] parse_uri function in parse_uri.c segfaults

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ opensips-Bugs-2685700 ] parse_uri function in parse_uri.c segfaults

SourceForge.net
Bugs item #2685700, was opened at 2009-03-13 00:30
Message generated for change (Settings changed) made by bogdan_iancu
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2685700&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: core
Group: trunk
Status: Open
Resolution: None
>Priority: 2
Private: No
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Bogdan-Andrei Iancu (bogdan_iancu)
Summary: parse_uri function in parse_uri.c segfaults

Initial Comment:
parse_uri function segfaults if the input buffer doesn't contain a uri in proper format. e.g., as the source comments sip:[hidden email]:5060;a=b?h=i, this function will fail if just "x" is supplied in the given buffer as first parameter to parse_uri.

----------------------------------------------------------------------

Comment By: Bogdan-Andrei Iancu (bogdan_iancu)
Date: 2009-03-13 11:29

Message:
And what is the len you pass as a second param ? (first is just "x", right
?)

Regards,
Bogdan

----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2685700&group_id=232389

_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel