[ opensips-Bugs-2740829 ] Presence SUBSCRIBE returns in-correct CONTACT header in 200O

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ opensips-Bugs-2740829 ] Presence SUBSCRIBE returns in-correct CONTACT header in 200O

SourceForge.net
Bugs item #2740829, was opened at 2009-04-08 00:13
Message generated for change (Tracker Item Submitted) made by jimbohamez
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2740829&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: modules
Group: 1.4.x
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Jim Burke (jimbohamez)
Assigned to: Nobody/Anonymous (nobody)
Summary: Presence SUBSCRIBE returns in-correct CONTACT header in 200O

Initial Comment:
This is a follow-up from bug 2354984.  

version: opensips 1.4.5-tls (i386/linux)

Testing presence with Eyebeam and Xlite and found this patch is causing an issue due to the CONTACT header returned from a SUBSCRIBE message.

In sending 200OK with a contact header equal to the opensips server, any subsequent SUBSCRIBE messages use this contact header in the URI and result in 481 Subscription does not exist.  See attached messages.

I'm not sure what the driver was for changing this behaviour, however I think it needs some more investigation.  If you need any further info please advise.

Regards,
Jim



----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2740829&group_id=232389

_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel