[ opensips-Bugs-2788957 ] dialog entry purge and dialog timeout bug

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ opensips-Bugs-2788957 ] dialog entry purge and dialog timeout bug

SourceForge.net
Bugs item #2788957, was opened at 2009-05-08 15:36
Message generated for change (Comment added) made by bogdan_iancu
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2788957&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: modules
Group: 1.5.x
>Status: Closed
>Resolution: Invalid
Priority: 2
Private: No
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Bogdan-Andrei Iancu (bogdan_iancu)
Summary: dialog entry purge and dialog timeout bug

Initial Comment:
Hello all,
In OpenSIPs 1.4.5, dialog appeared in "opensipsctl fifo dlg_list" only if setflag was called on "modparam("dialog", "dlg_flag", 4)" that I triggered it only on an INVITE.
And everything looks fine, dialog was terminated receiving a BYE packet.

In OpenSIPS 1.5.1, all dialogs are visible in "opensipsctl fifo dlg_list", even without calling setflag(4) and furthermore, all my REGISTER transactions are not purged from memory after 200OK and the timeout parameter of these transaction increase with OpenSIPs uptime.

For example, I have put a default timeout of 10800s, my first REGISTER will get a timeout of 10807s, and another 60s later has a timeout of 10867s.

I'm trying to see where is the problem. I will keep you inform if I find something!

I used:
opensips -V
version: opensips 1.5.1-notls (x86_64/linux)
flags: STATS: Off, USE_IPV6, USE_TCP, DISABLE_NAGLE, USE_MCAST, SHM_MEM, SHM_MMAP, PKG_MALLOC, F_MALLOC, FAST_LOCK-ADAPTIVE_WAIT
ADAPTIVE_WAIT_LOOPS=1024, MAX_RECV_BUFFER_SIZE 262144, MAX_LISTEN 16, MAX_URI_SIZE 1024, BUF_SIZE 65535
poll method support: poll, epoll_lt, epoll_et, sigio_rt, select.
svnrevision: unknown
@(#) $Id: main.c 5469 2009-03-18 12:43:10Z bogdan_iancu $
main.c compiled on 19:03:00 Apr 30 2009 with gcc 4.1.2


PS: I put some other outputs in OpenSIPs user mailing list

----------------------------------------------------------------------

>Comment By: Bogdan-Andrei Iancu (bogdan_iancu)
Date: 2009-07-23 10:42

Message:
Hi Marc,

I will close this bug report as there was no additional info on it. If you
manage to reproduce this, please open a new report.

Thanks and regards,
Bogdan

----------------------------------------------------------------------

Comment By: Bogdan-Andrei Iancu (bogdan_iancu)
Date: 2009-07-09 12:47

Message:
Marc, thanks for the feedback - sure, I will wait yo see if you have some
updates on this. In the mean while I downgraded the severity of this
report.

Thanks and regards,
Bogdan

----------------------------------------------------------------------

Comment By: Marc LEURENT (lftsy)
Date: 2009-07-08 11:07

Message:
Hello Bogdan,
All my server are still running OpenSIPs 1.4.5, I do not have anymore
server available for testing. I should get them for July 17th if they are
delivered on schedule.
I have so many trouble with CentOS (with Asterisk or OpenSIPs) that I'm
starting to think that the problem could be linked with my compilation
environment on CentOS...
Best Regards

----------------------------------------------------------------------

Comment By: Bogdan-Andrei Iancu (bogdan_iancu)
Date: 2009-07-08 10:55

Message:
Hi Marc,

if this report is still valid, could you please post or send me the full
log (from startup) in debug 6? I just want to take a look and see what I
can find out.

Thanks and regards,
Bogdan

----------------------------------------------------------------------

Comment By: Marc LEURENT (lftsy)
Date: 2009-05-09 12:21

Message:
I do not use any of these modules, I don't have my config here, but I use
bacic modules: from default opensips,cfg
additionnal modules: dispatcher, nathelper,db_mysql,domain
 
I use the function create_dialog() only in a if method == INVITE section,
but I have commented it in OpenSIPs 1.5.1 and I still have dialogs with
strange timeout, I have posted my dialog parameters in an email yesterday
if you want to see.

I should go an IRC, but I do not have access to my servers from here...
Thank you for your time

----------------------------------------------------------------------

Comment By: Bogdan-Andrei Iancu (bogdan_iancu)
Date: 2009-05-09 12:02

Message:
I see....
Do you use create_dialog() function or any of these modules:
nat_traversal, siptrace, mediaproxy, sst, call_control, pua_dialoginfo,
qos, load_balancer ?

Regards,
Bogdan

----------------------------------------------------------------------

Comment By: Marc LEURENT (lftsy)
Date: 2009-05-09 11:41

Message:
Hello Bogdan,
no I'm not using Mediaproxy. I use nathelper module to deal with NATed
users.
The only strange thing, is that I'm forwarding REGISTER to loadbalanced
(with dispatcher module) Asterisks, but I intercept REGISTER to be able to
ping all NATed users from the proxy.
Everything works fine with OpenSIPs 1.4.x


----------------------------------------------------------------------

Comment By: Bogdan-Andrei Iancu (bogdan_iancu)
Date: 2009-05-09 11:27

Message:
Hi Marc,

regarding the first issue, with seeing all the dialogs - do you use
mediaproxy with engage_mediaproxy() ? because it forces dialog creation in
order to keep track of the dialog changes.

Regards,
Bogdan

----------------------------------------------------------------------

Comment By: Marc LEURENT (lftsy)
Date: 2009-05-08 15:38

Message:
Sorry, I have posted this anonymously, Here is a comment...
Best Regards,
Marc Leurent

----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2788957&group_id=232389

_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel