[ opensips-Bugs-2858334 ] uac_replace_to failes if called on multiple branches

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ opensips-Bugs-2858334 ] uac_replace_to failes if called on multiple branches

SourceForge.net
Bugs item #2858334, was opened at 2009-09-14 03:42
Message generated for change (Settings changed) made by bogdan_iancu
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2858334&group_id=232389

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
>Category: modules
>Group: trunk
>Status: Closed
>Resolution: Fixed
Priority: 5
Private: No
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Bogdan-Andrei Iancu (bogdan_iancu)
Summary: uac_replace_to failes if called on multiple branches

Initial Comment:
If uac_replace_to() is called in a branch_route, it's replacement logic
get's confused on reply packets: To URI is added multiple times.

Best regards,
Thomas Gelf


----------------------------------------------------------------------

Comment By: Thomas Gelf (thomas_gelf)
Date: 2009-09-15 22:10

Message:
This issue is fixed by latest changes on SVN, successfully tested with
r6130.

Btw: heeey, I was first to report this malfunction, I also did so on ML
in my mail at 9/11, 05:58 AM +0200! Just kidding ;-)

Could someone please close this ticket? I opened it as "anonymous", so
I'm not allowed to do so.

Best regards,
Thomas Gelf


----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=1086410&aid=2858334&group_id=232389

_______________________________________________
Devel mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/devel