opensips running on 2 NIC's

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

opensips running on 2 NIC's

Indiver
Hi Everyone,

I had two network interfaces eth0 and eth1. I configured eth0 to listen public IP and eth1 to listen on private IP. My question is how to configure opensips in order to listen on both interfaces.  I configured in opensips cfg as follows
listen=udp:public IP [eth0]
alias=udp:private IP [eth1], but in vain. Can any one suggests how to configure opensips in order to listen on both interfaces.

Regards,
Indiver.
Reply | Threaded
Open this post in threaded view
|

Re: opensips running on 2 NIC's

vallimamod abdullah
Hello Indiver,

On Monday 17 May, 2010, at 8:18 AM, Indiver wrote:

>
> Hi Everyone,
>
> I had two network interfaces eth0 and eth1. I configured eth0 to  
> listen
> public IP and eth1 to listen on private IP. My question is how to  
> configure
> opensips in order to listen on both interfaces.  I configured in  
> opensips
> cfg as follows
> listen=udp:public IP [eth0]
> alias=udp:private IP [eth1], but in vain. Can any one suggests how to

You need a second 'listen' line for your private IP...

Regards,
-vma
.
 
 

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: opensips running on 2 NIC's

Indiver
Hi Abdullah,

Thanks for your response. I tried the solution mentioned in ur post ,but no luck. I even tried to listen the two interfaces on starting opensips by using -l option. But nothing went right for me.

Regards,
Indiver
Reply | Threaded
Open this post in threaded view
|

Re: opensips running on 2 NIC's

Bogdan-Andrei Iancu
Hi,

are you saying that:

listen=udp:pub_ip:5060
listen=udp:priv_ip:5060

does not work for you ?? have you enabled forking mode (fork=yes param) ?

Regards,
Bogdan

Indiver wrote:
> Hi Abdullah,
>
> Thanks for your response. I tried the solution mentioned in ur post ,but no
> luck. I even tried to listen the two interfaces on starting opensips by
> using -l option. But nothing went right for me.
>
> Regards,
> Indiver
>  


--
Bogdan-Andrei Iancu
www.voice-system.ro


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: opensips running on 2 NIC's

Indiver
The issue is solved. we had some routing issues in the router. we fixed that part. working fine.