opensipsctl fifo get_statistics 'usrloc:' registered_users=3, but in script stat(registered_users) is always 0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

opensipsctl fifo get_statistics 'usrloc:' registered_users=3, but in script stat(registered_users) is always 0

jing
hi,all
I want to get the value of registered_users in my script :
  xlog ("$fu not registered, register users $stat(registered_users)");
 
The log shows:
sip:10000@10.75.58.9 not registered, register users 0
 
But when I use opensipsctl fifo get_statistics 'usrloc:' in command line,it shows:
usrloc:registered_users = 4
usrloc:location-users = 4
usrloc:location-contacts = 4
usrloc:location-expires = 0
I don't how to use the export statistics in script.
regards,
 jing

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: opensipsctl fifo get_statistics 'usrloc:' registered_users=3, but in script stat(registered_users) is always 0

Bogdan-Andrei Iancu-2
Hi Jing,

I have in my script:
        xlog ("We have $stat(registered_users) users registered so far !\n");
and it works perfectly (in 1.11). I placed it just after the save("location").

What version do you have?

Regards,
Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com
On 04.07.2014 12:34, jing wrote:
hi,all
I want to get the value of registered_users in my script :
  xlog ("$fu not registered, register users $stat(registered_users)");
 
The log shows:
[hidden email] not registered, register users 0
 
But when I use opensipsctl fifo get_statistics 'usrloc:' in command line,it shows:
usrloc:registered_users = 4
usrloc:location-users = 4
usrloc:location-contacts = 4
usrloc:location-expires = 0
I don't how to use the export statistics in script.
regards,
 jing


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: opensipsctl fifo get_statistics 'usrloc:' registered_users=3, but in script stat(registered_users) is always 0

jing
hi,Bogdan
I found the problem,you are right ,thank you.
regards,
jing


------------------ Original ------------------
From: "Bogdan-Andrei Iancu"<[hidden email]>;
Date: 2014年7月4日(星期五) 晚上6:08
To: "users"<[hidden email]>; "jing "<[hidden email]>;
Subject: Re: [OpenSIPS-Users] opensipsctl fifo get_statistics 'usrloc:' registered_users=3,but in script stat(registered_users) is always 0

Hi Jing,

I have in my script:
        xlog ("We have $stat(registered_users) users registered so far !\n");
and it works perfectly (in 1.11). I placed it just after the save("location").

What version do you have?

Regards,
Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com
On 04.07.2014 12:34, jing wrote:
hi,all
I want to get the value of registered_users in my script :
  xlog ("$fu not registered, register users $stat(registered_users)");
 
The log shows:
[hidden email] not registered, register users 0
 
But when I use opensipsctl fifo get_statistics 'usrloc:' in command line,it shows:
usrloc:registered_users = 4
usrloc:location-users = 4
usrloc:location-contacts = 4
usrloc:location-expires = 0
I don't how to use the export statistics in script.
regards,
 jing


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users